PDA

View Full Version : UV export problem



wyattharris
01-29-2011, 12:49 PM
I'm building a custom item set for TF2. My workflow is modeling and UVs in Modeler 9.6. Export to Collada file and import to the XSI Mod Tool using Crosswalk. This has worked fine for the first 3 models. For the last one I created 3 UV maps because of the detail in the model. I was given some good advice saying basically, "Is you crazy, 3 maps, that's way too big." So I combined the 3 maps down to one using the "Copy Vertex Map" tool in modeler and then made my adjustments.

Now that is the only difference in the process. Using the copy vertex map tool. But when I imported into the mod tool it kept the same layout of the UVs but it shuffled them around. Like a piece that should be in the front was now in the back etc. Plus about a dozen polys were distorted and stretched out into long skinny lines. I've tried exporting every different file format that was available and they all pretty much do the same just with different results. I've tried it in LW 10 but the exporters don't give the same results or just not something I can use with the mod tool.

So my question is, does anyone know what the Copy Vertex Map tool did and is there a way to fix it?

If there's no easy fix I'm just going to rebuild the map today. I've wasted enough time trying to 1-step this. Thanks for any help.

wyattharris
01-29-2011, 01:21 PM
Okay may have found something. I used the Heal UV tool and the UV turned into a giant mess but it did import the same in the Mod Tool. This I can fix.

So, does anyone know what is going on with the Copy Vertex Map tool? It appears to be a bit more than just a copy paste. Just for my curiosity. :D

Sensei
01-29-2011, 02:53 PM
We have no idea what Copy Vertex Map did, because you didn't show any examples...

But I would first try unwelding all points, then merge them back, just to see whether it changes something..
And unify polys.
Remove all 1-2 point polys if any.

wyattharris
01-29-2011, 06:20 PM
We have no idea what Copy Vertex Map did, because you didn't show any examples...

But I would first try unwelding all points, then merge them back, just to see whether it changes something..
And unify polys.
Remove all 1-2 point polys if any.
Sorry, I didn't mean my specific example. Just what is it doing "under the hood". Thanks for the reply.

Sensei
01-29-2011, 11:36 PM
Sorry, I have not experienced what you described in the first post..