View Full Version : Corrupted Scenes in LW 10

01-28-2011, 03:32 PM
I realize this is a general observation/criticism, but I haven't been able to narrow a particular bug down yet. I sure am having to rebuild scenes a lot lately using load from scene, because SOMETHING stops working in LW 10, and it always turns out to be a corrupted scene file.

(I've run disc diagnostics, and everything on my drives is working perfectly, so I am convinced it's LW 10. Also no problems in other apps.)

My latest one happened after saving a particle emitter and its corresponding HV settings, then loading them back into a different scene: when I hit VPR, I couldn't see the HV's at all, although in the original scene they render visibly. The background was black. When I turned it to white as I began my investigation into why this was happening, the HV texture showed up, but the luminosity was missing (hence not being able to see them over a black background). The luminosity and all other HV settings were exactly the same as in the original scene, and should have rendered properly. I spent about an hour scratching my head and looking at everything in the scene, but nothing I ever found solved the problem, until I finally just gave up and rebuilt the scene using load from (corrupted) scene. Now all the HV's render properly. (Load from scene has saved my bacon a LOT lately!)

Scene corruption is happening here a lot with LW 10.

I considered reporting a problem with loading HV settings, but once I rebuilt the scene, HV's worked like they should. So I am left wondering why my LW 10 scenes are getting corrupted so often.

Also very much looking forward to 10.x. :-)

01-29-2011, 12:23 PM
I have had a scene go corrupt for no apparent reason as well in LW10.
It was not heavy scene or have any plugins involved at all.
I've not been able to recreate the problem(much to my delight) but it was a bit disconcerting to have set something up only to not be able to open it again later.

01-29-2011, 12:36 PM
+3 ,using LW10 trail . working on proton and kurts scene . save , save , save latest edition ,the scene file is corrupt , loads ok although sluggish , but takes about another 2 hrs longer than the previous saved scene and it I cant work in it , jitters too much ...

also why is when I try to open a scene file or obj straight from the desktop it will not load , I have to go into the program ?

also when I revert scene to last saved , it goes MEGA slow

Nigel Baker
01-29-2011, 12:55 PM
Hello All,

Same here, happened about two weeks ago. It is file that was working fine and I was getting decent renders in it (test render under ten minutes). Something along the way happened. Don't know what but the renders increased to two hours, then to 6 hours.

I was still able to work within the scene and modeler no problems just render at my peril, Then as the scene became almost complete I set it off to render one night hoping to meet my deadline the next day. After ten hours of rendering the machine still had 36 hours left to render or so the clock said.

Crazy multiplication of time.
I had to stop everything and move over to Maxwell Render to get something workable and had a render out within two hours and photoshoped up to some standard for presentation for the client.

I contacted Newtek but after one reply which gave me a bunch of procedures to follow which I had already done which is part of my normal overnight heavy render protocols, I never heard back from them, felt just ignored, not good support that time.

I also asked Newtek to look at the file but no word back.


01-29-2011, 12:58 PM
at first I thought it was a memory leak , but it's down to the actual scene files , like I said previous saved version runs fine ."which kinda defeats the purpose of save "

01-29-2011, 02:59 PM
this sene looks like the same trainning dvd I am working on that is explosive effects with hyper voxels. I no I had worked on this training video in lightwave 9.6 some time back but tried it again here last week. The light attached to the null seems to be in the tail other then the location I set it to. This may be a bug for 10 area and not core but was involved with voxels. This was a dvd from desktop images (smoke and flame particles trails)

I am going to do some more checking on this scene , This may be a reflection on my other light.

01-29-2011, 04:26 PM
Had a sequence of around three thousand frames, test renders showed an average frame time of about seventeen seconds at setup regardless of where I rendered so it was pretty even no wild fluctuations, initial render time was estimated at start to be around three hours ( ok not a reliable guide by any means) this time inflated to over six hours ended up at twelve with frames getting progressively longer and longer till they were well over four times the original test time, this was a simple scene with FG a few textures and a normal map and it's happened on more than one occasion. I thought memory leak at first as FG used to plagued with this sort of thing in 9x beta, the stats panel said I was using 60Mb's of ram, system stats told me I was using 6Gb's of ram, so something's up for sure.

Nigel Baker
01-30-2011, 04:54 AM
Hi All,

Another corrupt scene that was highlighted again today.
It always ends up in a crash and the spinning pizza wheel where I have to force quit LW10. LW only crashes when I open up the Scene Editor, otherwise everything else is fine. I thought I had it tricked into opening but no CRash CRAsh CRASH : )

Anyone else having a similar problem

File has:
Points 3,643,853
Polygons 3,163,320
Memory 602 Megs


01-30-2011, 06:57 AM
That is not sounding good at all..I hope Newtek fixes it asp.

Btw...anybody try reopening the corrupt scene in 9.6?


01-30-2011, 08:44 AM
Compare scenes before and after saving in LW v10 in any text editor.
Multiple times, to find differences.
And you will have something to report on fogbugz..

And remember you can manually edit scene in text editor. If you don't know what you're doing, make backups and experiment.

Nigel Baker
01-30-2011, 10:48 AM
Hello Sensei,

Appreciate the tips but I am not a coder and have deadlines to meet so I have to keep working looking at work arounds and deliver the job or there is no cheque at the end : )


02-04-2011, 11:32 AM
I have had the same issue to, simply trying to load scenes. Unfortunately I loaded 10 on everything, so I can't go back either. Really happy they are just 300 frame scenes and fairly simple. Hope there is better news in the future for everyone. I would like to state that if I save a scene created in 10 that it loads up fine later.

02-04-2011, 12:13 PM
Because I'm bored and doing this seemed better than doing actuall work, I loaded in the Apple.lws scene from the 9.6 content into LW10 then saved it out. theres what ammounts to 1 byte of differences in the files

this chunk is added to the LW10 files between the 'EndPlugin' and "CurrentItemFlyout" :

Plugin ViewportObjectHandler 1 .VPR
Plugin ViewportObjectHandler 2 .VPR
Plugin ViewportObjectHandler 3 .VPR
Plugin ViewportObjectHandler 4 .VPR
ColorSpaceViewer Linear none
ColorSpaceSurfaceColor Linear none
ColorSpaceLightColor Linear none
ColorSpacePaletteFiles Linear none
ColorSpace8BitFiles Linear none
ColorSpaceFloatFiles Linear none
ColorSpaceAlpha Linear none
ColorSpaceOutput Linear none
ColorSpaceOutputAlpha Linear none
ColorSpaceAutoSense 1240928
ColorSpace8BitToFloat 0

further down in the file it added a new Radiosity entry between 'BlurRadiosity' and 'RadiosityCacheModulus' named 'RadiosityFlags'

Next down the list between 'Oversampling' and 'FieldRendering' we get 'UndockPreview'
This reoccures in every AddCamea section of the file.

then between 'BackdropFog' and 'VolumeClipDiscance' we get 'CopyToPerspective' added in.

thats it for additions. I haven't noticed anything else change in the file. all the numbers seem to be the same.

so possibly theres an issue in those areas?

the file saved out of LW10 loads into LW9.6 fine the file reload into LW10 fine as well...

- Will.

02-05-2011, 05:09 AM
Well, you need to analyze lws that's crashing.. Ask DrStrik9 or somebody else who has such file..

Paul Goodrich
02-08-2011, 11:14 AM
OK. This may be the same thing (or not). I was trying some things on Rebel Hill's Adam scene. The scene opens fine in LW 10. Save with a different name as I want to leave the original alone. The scene loads and then the color wheel of doom appears. The scene will NOT open. Crash every time. Now iI need to state this on a Mac. The renamed scene will open in 9.6 in Leopard. But will not in 9.6.1 or 10 in Snow Leopard. Both 10.6.3 or 10.6.4 tried this on several computers. I can't go higher than 10.6.4 due to to other programs I'm running are not compatible with later versions. So, I'm thinking Snow Leopard the problem. Then just for the heck of it. I remove the Hub. Now everything opens and no crashes. I guess the hub is still a POS on the Mac, darn. Also the audio bug I reported on the 9.6.1 beta about sound files having to be re-loaded EVERY time I open a scene is STILL not fixed. This is annoying to say the least.

Paul Goodrich

05-30-2011, 02:31 AM
I'm using LW 10 aswell. I'm not sure if my problem relates to this thread but there are similarities.

I'm having problems with saving the file without the program crashing. The scene file is currently about 200 kb and consists of 3 or 4 very simple objects duplicated about 7 times. I've attached SoftFX and HardFX to all the objects and that might the cause the crashes. At the moment I'm trying to duplicate the objects to crowd the scene and this seems to make the program more prone to crashing.

I've noticed that the scene's file size is related to the crashes. As I mentioned, the original file size is about 200 kb, but when LW crashes, the newly saved filesize exceeds 100 Mb or even more - even if I've only duplicated 4 more objects. And as the program stopped responding while saving, the file won't open at all.

I ran LW also without the hub but this didn't prevent the proplem on my Mac (Os X 10.6.7)

05-31-2011, 03:14 AM
I found a solution to the problem I described.

The program stopped crashing when I calculated the SoftFX before saving. Also the file sizes stayed reasonable.