PDA

View Full Version : Noobacious issue with rigging



steveski74
01-12-2011, 07:22 AM
Hi,

I've only recently started delving into the world of bones. I've followed some tutorials and it all seemed simple enough. After a few goes I'm getting the kind of IK motion I was after, but I'm having issues when I select the Enable Deform button.

I originally created the bones parented to a null object but that caused some issues when re-nesting to my hand object so I started from scratch with the hand in the default position on loading, then I added my first bone and individually placed each bone carefully throughout the mesh, added IK and pivot constraints and goal NULL.

Everything was lined up perfectly from time of creation, but when I press the Enable Deform button my hand object shifts away from the bones. I disabled the deform and tried moving the pivot point to where the same point as the root bones and reapply the deformation but the object still jumps away. I then tried exporting the Rig, removing from the project then importing the Rig back but still no luck.

Can some please assist? I'm sure I'm missing something really simple.
I'm running 64 bit version 10 rev 2067

Regards,

Steve

01-12-2011, 07:28 AM
Pick a bone, any bone, on frame 0.
Press 'r'. Press the down arrow.
Repeat until you get back to the bone in the first line.
Should be good to go.

With what you described, it sounds like you need to rest (or re-rest) your bones. Not sure what has occurred that makes this needed but that seems to be where you are.

RebelHill
01-12-2011, 07:29 AM
you need to bind the bones to the mesh after they have been positioned it... In LW, its called resting... select all your bones, push the r key.

01-12-2011, 08:01 AM
chuckle, I love the long-winded way! Sounds almost musical.

However, the efficient way is best.

steveski74
01-12-2011, 08:16 AM
Thanks so much!!!
Works a treat, now on to the other fingers.

Robert...did you mean I've done something the long winded way?


Thanks again,

Steve