View Full Version : Random Dots Problem from Surface Layer+

01-04-2011, 09:47 AM
I'm using Denis's Surface Layer+ as a gradient with Input Parameter set to Y Thickness to control the colour of an object, but the object is covered in these tiny dots that you can see in the image. The dot pattern is different every render.

In fact any of the input parameters in Surface Layer+ gradient, or procedural (haven't tried image) are giving these dots.

The scene is not animated in any way, shadows are off, colour is the only channel I'm working with here.

This is with LW10 Win64.

I'd appreciate any ideas - powerful input parameter is the Y Thickness, to name but one.



01-04-2011, 02:57 PM
I can get these white dots here,
Color or Surface Layer+, Y thickness color gradient,
on a sample sphere even heavily displaced,
could you post your scene?


01-05-2011, 01:19 AM
I can get these white dots...

...too late for editing a typo, wanted to say
that I can't get it..

I suspect an issue with the geometry
may be overlapped polygons,
so your scene settings and mesh
is needed to reproduce.


01-05-2011, 05:56 AM
Yes, I was looking for odd geometry, though aside from non-planars in the terrain mesh that the, I'm not seeing it. A tripled mesh produces the dots as well, so it's not that.

HD Instance and fog are also involved, but switching both off still gives dots.

I've cut the scene down, and the terrain object ... I don't want to post the whole object as it's for a job ... but even then the dots are still there.

I'll post that shortly.



01-05-2011, 06:23 AM
Here it is then. Stripped down and with reduced topo mesh - but the dots are still there.

I cannot see anything massively off with the meshes, and remember also that any given frame, each successive F9 render gives a different dot pattern. I don't know for sure, but dodgy meshes would give the same error/artefact each time, wouldn't they? Maybe not ... anyway, thanks for taking a look.


01-05-2011, 06:54 AM
No white dots here, win32, LW9.6, LW10 or even VPR


May be somebody else?


01-05-2011, 09:37 AM
The dots are appearing with multiple threads, no problem with one thread.

01-05-2011, 10:17 AM
Ah ... multithreading! There was something at the back of my mind all along about dot artefacts in a render ... that's what it is.

Yes, fine now - one thread is fine - two and more is not.

Thank you!