PDA

View Full Version : Perspective cam & classic cam, black renders on vertex normal smoothing !



prometheus
12-10-2010, 07:08 AM
Why does the perspective cam render out these cushion metal brick surfaces correctly while classic cam is rendering it black? (see attached image).

The object is imported from solidworks then to deep exploration and exported to obj with smoothed vertex maps wich are active in lightwave.

I donīt want to turn of smoothing or remove the vertex normal smoothing map since that would either give smoothing errors or without smoothing just look to flat.

I did try to correct it a little by adding a spot info and geometric normal output to the surface normal input wich seemed to help a little with renders in classic cam.

I guess I could use perspective cam solely, but Im used to render out with classic cam and Itīs predefined Aliasing settings and filters.

Michael

StereoMike
12-11-2010, 06:26 AM
I see only one reason for the classic cam: highly unplanar polys do awkward stuff to the perspective cam, classic cam doesn't have an issue with those. And very very low spec scenes might render faster.
That's all. Every other aspect speaks for perspective cam, speed on heavy scenes, AA, realistic motion blur, you name it.
Some AA settings to start with:
AA:2
Adaptive sampling 0.05
Oversample: 0.02
Filter: Gaussian
Pattern: fixed

If it renders nice on perspective cam, use it :)

edit: if the image appears blurry, it might depend on the filter. Gaussian gives a slight blur wich hides aliasing and doesn't break high res images. But it might be too much for small pics.

Sensei
12-11-2010, 07:51 AM
I think it looks wrong with perspective too.. Look where do you have light source. It doesn't match with this metal - gives impression light is on floor.. But other surfaces have specular highlight on top..

Can you show how it looks when you disable Vertex Normal Map on the all surfaces and enable LW Smoothing?

Can you do something with light(s), so we'll really know where it's located? Turn off GI, Ambient intensity to 0%, disable multiple lights, if you have more than 1. Use some point light.

prometheus
12-11-2010, 12:34 PM
I think it looks wrong with perspective too.. Look where do you have light source. It doesn't match with this metal - gives impression light is on floor.. But other surfaces have specular highlight on top..

Can you show how it looks when you disable Vertex Normal Map on the all surfaces and enable LW Smoothing?

Can you do something with light(s), so we'll really know where it's located? Turn off GI, Ambient intensity to 0%, disable multiple lights, if you have more than 1. Use some point light.

Well the issue here is the black surface showing up because of vertex normal maps, it doesnīt do that without them, lighting and perspective might be secondary since I wasnīt finished with the lighting of the scene.

I could remodel the round cushion brick, or replace them with those modeled part,wich I actually have done on some other machines, that would avoid the problems with vertex normal smoothing and the black surface issue, but I would rather skip that process if I can get it to work as it is from scratch.

Thereīs no ambient lights in the scene, mostly 1 dome light,two or three area lights and sometimes final gather gi or fprime renders.

hereīs some other renders at my company..

http://www.gymleco.se/Produkter/349.php

http://www.gymleco.se/Produkter/365.php

http://www.gymleco.se/Produkter/310.php

http://www.gymleco.se/Produkter/320.php

Mainly converted solidworks models wich are resurfaced and cushions are remodeled since they only consist of the plywood bas construction shape without the foam and leather.

Michael

prometheus
12-11-2010, 12:48 PM
sensei..yeah youre right about the spec highlights, Itīs probably because of inverse distance from the top lights that doesnīt reach the metal.
and probably the same for area lights that gives the metal specs.

I had some anisotrophic shading in there too I beleive wich could be false, but that isnīt the cause of black surface, I checked with and without that.

Michael