PDA

View Full Version : Weights aren't working right



Dreamcube017
12-03-2010, 08:40 AM
Hi guys.

I'm using 9.6 and I can't figure out how to modify the curves in the subpatches in Modeler.

I select a point, go to the Map tab,I try to click Weights, but it is blanked out. So I click New Weight Map. I click Create, but the menu doesn't go away. I guess it worked thoug because I can then select Weights.

However, when I select a point on the object (a cube) and click Weights, and then try to click and drag the mouse over the point, the weighting doesn't change. I looked in weight shaded view to make sure. It doesn't change at all.

Why not?? This is upsetting me because I'm looking at a tutorial and it appears as this is how it's suppose to work.

What am I doing wrong?

Thanks.

vector
12-03-2010, 11:56 AM
At the bottom right of the screen, when the "w" (weights) tab is selected, have you chosen subpatch Weight before try?

http://www.ecst.csuchico.edu/~ranger/samples/CSCI140/tutorialsS05/ToddBrown_tutorial/3t.jpg

Vector

Dreamcube017
12-03-2010, 07:40 PM
Thanks... it worked once... but then it stopped working.

I make a cube, press tab with the subpathces, then I set it to subpatch weight. I then select a point, and then go to Map and then click on Weight... and nothing happens.

I don't get how it worked once, then never again.

Does it work everytime for you? Just make a cube, press tab... well do what I did. Does it work for you?

vector
12-04-2010, 04:01 PM
Sometimes it happens to me. I rotate a bit in perspective viewer or deselect and select again "weights" (Im not sure if this last "technique" is effective or its my feeling) and no problem.

Vector

Sensei
12-05-2010, 02:33 AM
Catmull-Clark Sub-Patches don't have Sub-Patch Weight, but Edge Weight. So make sure right Sub-D type is picked.

You can see what any weight map have values using TrueArt's Modeling Pack http://modelingpack.trueart.eu
tools ShowWeights and ShowEdgeWeights. They are running parallel to LW and real-time with any other LW or 3rd party tool.

http://www.trueart.pl/Products/Plug-Ins/ShowWeights/Graphics/ShowWeights_4.png

I am enabling ShowWeights tool, then using Maps > Weights and adjusting points with real-time feed-back, seeing its value in viewport.