PDA

View Full Version : Funky image problem



macahuna
12-01-2010, 11:24 PM
I'm trying to put a logo on an object by planar image mapping (not UV). When I import the graphic (jpg), I only get about a third of the left side of the graphic, and it's stretched with gray streaks in it. Mapping is worthless with it.

Since that sucked, I tried to import the file from Illustrator so it could be stenciled with Drill. The only exports from AI that are importable seem to be jpeg or png. I've saved the AI files down as far as v3 and as EPS, but they're still grayed out in the import dialog box.

What the heck am I missing?

Thanks!

Dexter2999
12-02-2010, 12:09 AM
No idea about the distortion of the logo.

From AI, you want to export an EPS v8.
Then you are looking to use the EPSF Loader.

Good Luck

nickdigital
12-02-2010, 12:11 AM
What if you try saving your image as a different file format...png, tga?

Can you post a render or screen grab of what it's looking like?

macahuna
12-02-2010, 07:53 AM
Thanks for the ESPF import - I forgot about that.

I've tried everything except the .tga, but in my way of thinking, it shouldn't be that difficult.

Here's a screenshot of the file I'm trying to import and how it appears in LW.

Thanks,

Ron

wrench
12-02-2010, 08:48 AM
Are you sure you want an image that small? I have the feeling that since mipmaps are created by dividing your image by factors of 2 and your image is only 228x120, it might be that that is creating the problem.

B

macahuna
12-02-2010, 08:52 AM
That was a quick example of what I get. I've been trying it in square formats, 6" on a side, and I still get the distortion.

I just enlarged the art to 12" wide and saved it as a jpg and a tga. The tga comes in fine, but the jpg is distorted even more!

At least I know that the tga format will work.

Thanks for your help!

wrench
12-02-2010, 09:03 AM
When you say 6" on a side, what do you mean? What LightWave understands is pixels. A real world measurement only works with an additional component, that of DPI. To be really clear, you need to export your jpegs from Illustrator as 72 dpi files, preferably with resolutions larger than you have there. Because there is no information given about the size the image will be in the render it's impossible to give you a size for it. If this logo is going on a box that will only take up 60 pixels of the final image that resolution will be okay. If, on the other hand, it will be seen in the foreground of an image destined for print, you'll want thousands of pixels to prevent seeing the resolution of your texture image. LightWave *can* support vectorial images (SVG) using a third party plugin by Denis Pontonnier called SVGMap (http://dpont.pagesperso-orange.fr/plugins/SVGMap.html)

B
PS. It occurs to me that you use a Mac since that's what your screenshot shows, and unfortunately, Denis' plugin exists only for Windows 32-bit.

macahuna
12-02-2010, 11:27 AM
Ah, problem solved... I work primarily in print, so my jpeg was set to export as CMYK. It doesn't play well with LW. RGB and Grayscale work just fine.

Whew. Another bullet dodged!

Thanks a lot!