View Full Version : Metalink not working properly, or me just doing it wrong?

11-27-2010, 02:42 PM
I've set up a scene with 3 objects. It's a highpoly mesh of an netbag(the kind you use for storing 10 basketballs for instance), then I have a lowpoly version basicly made out of a sphere primitive.
Then I have a ball object. I've used the dynamics system to calculate the ball falling from inside the lowpoly bag and deforming it accordingly.
Now I'm happy with the animation/deformation of the low poly bag so I want to let the Highpoly version inherit that deformation.

After looking at some related tutorials wich use metalink I did the following:
...I parented my highpoly object under the animated lowpoly bag object, then in the highpoly's deformtab I applied the FX_MetaLink.... nothing happens, no deformation happens on the highpoly version, it's just there as it was before. Any ideas on why this isn't working?

11-27-2010, 02:59 PM
First, last, after motion... which are the subpatches associated with?

11-27-2010, 03:00 PM
no subpatches used on any object involved

11-27-2010, 03:21 PM
Did some more tests to see if I needed to flip the polygons on the lowp object, but it didn't matter, tried making a copy of the lowpoly object, subdivided it onse and tried using metalink on that instead of the original highpolynetbag ocbject... didn't do nothing, tried saving the lowpoly object's clothfx to a motion file and letting the motion playback instead of running calculations all the time, didn't change anything.

Here is the scene and object files if anyone want's to take a look at this:

11-27-2010, 04:12 PM

For the net bag, are you using ClothFX to apply the .mdd? Metalink only works with ClothFX's .mdd reader; it absolutely doesn't work with any other .mdd reader.


11-27-2010, 04:18 PM
ummm.... don't know ehh... what I've been doing is setting up my lowP net bag with clothfx and FX Collision (so that it catches the ball), then I drop in the ball with hardfx and FX Collision as well then I hit calculate. The lowP net bag is deforming to my liking so I take the highP net bag and parent it under the lowP version, then add the Metalink to the highP version. nothing happens. Am I missing a step?

I also tried going into the clothFX of the proxy object after it had calculated the dynamics and saved the motion. And reloaded it as a motion file to the clothFX again, but the metalink still didn't deform the Highpoly net bag at all

11-28-2010, 12:23 AM
went through proton's basketball net tutorial... metalink works there just like I had tried before on my net bag simulation, so it must be something with the dynamics settings I have in that scene that is funking up the metalink process there. Anyways... here's a little still from a stupid video I accidentally ended up making tonite hehe... just for fun :)


11-28-2010, 12:48 AM
hehe..... did another one just for fun, like they say, if it doesn't work like it should, best to have fun with it anyways ;)


11-28-2010, 01:54 AM
Okay I got it to work, though I'm not exactly sure how or what the problem is. I'll post your scene in a minute with an explanation of what I did.

11-28-2010, 02:14 AM
Here you go.

When I first saved the .mdd in ClothFX and applied Metalink to the High Poly object, the deformation did not work as expected.

Here's what I did to fix the problem:

Save the .mdd in ClothFX.
Clear the motion in ClothFX.
Save the original ClothFX settings (You'll need this if you want to recalculate the dynamics later.)
Remove ClothFX from the Low Poly object.
Remove Metalink from the High Poly object.
Save the scene.
Clear Layout and reload the scene.
Apply ClothFX to the Low Poly object and load the .mdd.
Apply Metalink to the parented High Poly object.

Now it should work. I suspect that the instance of ClothFX you originally applied got bugged somehow, and the new instance cleared the problem.

BTW, I only tested this for the net, and not the ball, but the same issue probably applies to the ball's Metalink if you're seeing the problem there too.

Hope this helps.


Edit: Disregard the second .mdd file; I should have removed that. The good .mdd is the file called 'LowP.mdd'.

11-28-2010, 03:02 PM
Greenlaw, thank you soooo much dude !!!! I was starting to suspect that it was some kind of file corruption or something in that direction... man it's sweet to see things working as they should again :) makes the controll-freak in me happy

Mr Rid
03-18-2011, 10:06 PM
So, is there no way to get Metalink to work with something that does not use ClothFX? Cloth is refusing MDs saved out of MD_Scan in a particular scene (no subD).

03-18-2011, 10:18 PM
I have no idea if this will work for you... but i normally use Metalink with SoftFX (all inputs to 0%) with Morphs for things like this: http://www.newtek.com/forums/showthread.php?t=117659

Instead of a Morph, you could use Dpont's Mdd nodes right?

03-18-2011, 10:34 PM
So, is there no way to get Metalink to work with something that does not use ClothFX? Cloth is refusing MDs saved out of MD_Scan in a particular scene (no subD).
Hey DR,

Yeah, FX Metalink and FX Hardlink will only work with ClothFX's MDD reader, and that's been a big problem for us. One more reason we've been doing more of our fx in other programs these days. I don't think even LW10's new MDD reader works with these tools.

I e-mailed somebody at Newtek a while back about this but didn't get a response. Then I asked DPont if he could make his MDD readers recognize Hardlink and Metalink and he explained why this wasn't possible here:

DP Motion Designer (http://www.newtek.com/forums/showthread.php?t=112108&page=2&highlight=metalink)

I don't completely understand what he wrote but if he says it can't be done, I believe him. :)


Mr Rid
03-18-2011, 10:36 PM
I have a weighted mesh animated with bones. I want to apply the deform to a similar 2nd mesh, that has different point count and no weights.

When I save an MDD out of Soft or MD scan, the resulting MDD will not load in Cloth, or Soft. It only loads in MD_Plug(?).

Metalink only works with Cloth loaded MDDs.

Tried to copy the weights from one mesh to the other with Weighter2 but it takes about a day on dense meshes.

Does ANYthing work?:cursin:

Mr Rid
03-18-2011, 10:46 PM

I don't completely understand what he wrote but if he says it can't be done, I believe him. :)


Am really sick of the endless compatibility issues that tie up 60% of my time in troubleshooting. Its like a Rubik's cube where I just want the red square to go THERE. But you have to twist and turn several multi-layered workaround maneuvers, that screwup the other layer you had precariously working. Then regularly you wind up nowhere and waste your day/week/life.

Something is always refusing to get along with another thing.

03-19-2011, 12:09 AM
Could you use the ClothFX scan function to generate the .mdd instead? metalink/hardlink only use dynamics FX as far I know.

Mr Rid
03-19-2011, 01:44 AM
Cloth wont even load its MDD at the moment. I dont know what's wrong now.

For some reason, only MD_plug is loading any MDDs.

But if Cloth would load, I cant save motion out of Cloth without calculating and it distorts the mesh as cloth. Also the mesh is too dense for Cloth to deal with.

Mr Rid
03-19-2011, 02:38 AM
Btw, a tip that may work for some. I have had the old Metaplug work where Metalink would not. But it chokes on dense meshes.

03-19-2011, 04:25 AM
The Scan Motion button in ClothFX just scans the mesh and allows you to save the .mdd, not actually deforming it.

03-19-2011, 11:36 AM
Am really sick of the endless compatibility issues that tie up 60% of my time in troubleshooting.
Yeah. (Sigh!) I've spend more time troubleshooting broken features and plug-ins these past months than actually working on my projects. Very frustrating.


Mr Rid
03-19-2011, 04:29 PM
I know Den. I'm waiting for you to work out all the horror in homegrown mocap, and your tutorial. :D

Most problems are a compatibility issue- one thing is not getting along with one or more other facets. The other prevalent frustration is stuff not working like it obviously should.

Thanks Dodgy, I totally forgot Scan Motion(!) as I never have use for. I use MD_Scan to change rate. But for some reason Cloth and Soft refuse to read MDDs with my particular mesh no matter where they scan from. Another time wasting glitch. GAWD I wish stuff would just work. Or could tell me exactly what the deal is, 'Hey man, I dont get along with 2-point polys... or normal displacement... or Saturday mornings.' Instead of 'error 372940-Z', or 'check log' which NEVER tells me a damm thing.

Its also much more difficult working out crap by yourself. I miss a room full of experienced people to bounce problems off of like at The Box.

03-20-2011, 03:51 AM
a comfort, it should change in CORE, i've already seen some nice dynamics stuff in CORE done by plugin developers, it seems to be very open, which means a skilled programmer can make great dynamics stuff. (of course, this is CORE beta, so it's simple stuff, but Bullet dynamics in CORE will certainly be much more independent and powerful)

Mr Rid
03-20-2011, 04:17 AM
Call me when its all up & working. :) I've been at this too long to give a poot about anything in dev, or betas. I didnt go near 6, 7 , 8 , 9. I wait for the .3/5 version where more kinks are worked out. I have enough frustration trying to get the job done without using or hoping on halfbaked tools.

This is not picking on you, but that word "powerful" is the biggest cliche in app/plugin descriptions. They're all a 'Powerful new tool!'

03-20-2011, 04:30 AM
hehe, i know, i know... http://erikalstad.com/backup/anims.php_files/smile.gif
i'd jump on the ICE train if you can afford it... :]

(and RBD explosions in Si are swell as the it can be exported via MDD afaik...)

03-20-2011, 08:50 AM
So, is there no way to get Metalink to work with something that does not use ClothFX? Cloth is refusing MDs saved out of MD_Scan in a particular scene (no subD).

An alternative way instead of going ClothFX/Metalink is to use MDD MetaPlug. The ONLY thing you load is your highres object and apply MD_MetaPlug under Deform (in Object properties). Bring up the interface and select the MDD as well as the cage-object. In your case, the cage object should be the original character.

It is important that frame 0 is a bindpose though, otherwise things will go wonky.

EDIT: I've attached the content that ArtGoblin provided with this alternative solution applied. Just load the scene with _mb at the end.

Mr Rid
03-20-2011, 12:42 PM
Right, MP sometimes works better, but as I mentioned it's choking on my dense mesh and cage.

03-20-2011, 12:53 PM
Right, MP sometimes works better, but as I mentioned it's choking on my dense mesh and cage.

Hmm... I did a test a couple of days ago in LW9.6 x64 where I had a basemesh driving a 4 million poly object. This was using FX_Metalink with ClothFX though, and when enabling FX_Metalink on the highres mesh, it took some time for LW to calculate things (5-7 minutes maybe), but it worked.

If you can, share your content with me privately and I'll take a look at it.

On this note though, I would have done things quite differently from start to end. Instead of going for highdense poly meshes, I would have used SubDs (which also means that things related to Metalinking is alot easer to achive) and before final renering, baked out either an object sequence based on the display subdlevel, or, with LW10, an MDD based on the disired density from subds.

03-20-2011, 02:48 PM
Mr. Rid doesn't like Sub-Ds don't you remember that conversation? lol.

03-20-2011, 03:38 PM
Mr. Rid doesn't like Sub-Ds don't you remember that conversation? lol.

Yes, I do. However, the problems Mr.Rid has faced with SubDs are related to rendering, which is something that one can avoid, but still take advantage of SubDs features by baking before rendering, but still keep a pipeline where things are in SubDs untill the very moment, so to speak. Personaly, I havn't seen any of the issues related to SubDs that Mr.Rid has mentioned earlier in other threads, but this doesn't mean that he is wrong about it.

What I'm trying to portray here is a middle way where things can be used effectively without rendering issues.