View Full Version : bones and bends

11-23-2010, 02:01 PM

I have created a very simple sub patched 'credit card' that I have added some bones to enable me to 'bend' the card in an animation. I have added a simple weight map and assigned it to the bone i want to move however the bones do not deform the geometry when i rotate the bone in the scene. Im new to this kind of animation - is there something simple Im missing here??


11-23-2010, 02:19 PM
Are the bones rested and activated? Hit the "r" key when you have a bone selected.

The other alternative would be to use the Deform modifier Bend. You only need nulls to set that up.

11-23-2010, 02:44 PM
Thanks Nick

The bones are all active and rested, they havent been reset to zero them in though.

Im trying to use bones on something simple to familiarise myself with this kind of setup.

11-23-2010, 02:45 PM
Can you post the lws and lwo file?

Is the bone strength at 0%?

11-23-2010, 02:54 PM

attached are the scene and object files - im sure bones are set to 100%

Thanks for your help Nick

11-23-2010, 03:05 PM
bones should be children of the object they're supposed to affect, or the object needs its bones properties set to "use bones from" whichever object the bones are children of.

11-23-2010, 03:12 PM
Yep, It looks like you created skelegons in modeler. Select your card object go into bones mode and properties and select use bones from card 1: layer 2.

11-23-2010, 03:45 PM
Thanks guys - Ive tried both of these options above and the bones still do not bend or deform the geometry!!! any chance of updating my scene file and or object so I can download and work out what has been done to make it happen? although some clues would be cool!

Thanks guys

11-23-2010, 04:29 PM
Try this. In modeler cut/paste your skelegons into the first layer with your card. Save. Send to layout. Convert skelegons to bones. rotate bone to check if it's affecting the object. with a bone selected hit p for properties and you'll see the first thing in it is use bones from (self). It works because you cut/pasted the bones form their own layer into the objects layer. In your original scene you need to select your object card: layer 1 and hit shift+B then P and you'll see it says use bones from (self) but the bones are in the layer 2 so itself, so to speak, has no bones. you need to change it to use bones from layer 2.

11-23-2010, 04:46 PM
Aghhh - Thanks for all your help guys, it all makes sense now. I can now apply these fundamentals to lots of animated ideas i have......thanks again


11-23-2010, 05:21 PM
If you set the bones to "parent in place" you can reparent them without the bone moving.