PDA

View Full Version : Question For You Smart Lightwave Users:



B Nartker
11-09-2010, 05:51 PM
I've used Lightwave for a few years now. I have a problem with Lightwave Modeler ( on the Mac platform - although I would be interested in hearing from someone who has expereince this on the PC platform ) I've asked the Tech Team at Lightwave about now and again about it but they haven't had an answer.

Here's my problem. If I zoom in enough within modeler, my most distant object parts begin looking like they're either getting eaten up or vanishing into some sort of Phantom Zone . . . like an unseen wall. I thought that when I bought the latest and greatest Macintosh recently that perhaps my problems would go away with a new powerful graphics card. But the problem is still there. I have to believe that it must be a Lightwave issue, but the people at lightwave didn't seem as though they had ever heard of the problem, let alone know what to do about it.

I've tried resizing and shrinking the obects, updating graphic card drivers. Heck . . . at this point I'd be happy just to know that someone else is familiar with the same problem I experience.

I've attached a screen shot to try and give you an idea of what exactly is happening.

Thanks in advance!

BJ Nartker
[email protected]
http://www.bjnartker.com/

nickdigital
11-09-2010, 05:55 PM
What if you try adjusting the Perspective Amount in the display options?

Does that help?

If this was happening in Layout I would point you to the Clipping Plane setting. But it doesn't look like that exists in Modeler.

XswampyX
11-09-2010, 06:03 PM
http://i465.photobucket.com/albums/rr16/xXswampyXx/FixedNormal.jpg

Setting 'Fixed Normal Length' to a negative number will give this effect.

Danner
11-09-2010, 06:30 PM
I've seen that before, what I do is select a polygon near that zone, center the view on it (shift A), and it becomes the new "center" of the perspective view and objects near it stop dissapearing.

JeffrySG
11-09-2010, 06:50 PM
I've seen that before, what I do is select a polygon near that zone, center the view on it (shift A), and it becomes the new "center" of the perspective view and objects near it stop dissapearing.

Yes, that will work. What is happening is that your object are going past the clipping plane in the viewport. Recentering the view on a poly or point near where you want to zoom will fix this, like Danner said shift-a. This happens all the time to me and is quite the pain.

Sensei
11-09-2010, 06:59 PM
I have to believe that it must be a Lightwave issue, but the people at lightwave didn't seem as though they had ever heard of the problem, let alone know what to do about it.

Apparently they never worked in LightWave.

It happens with the all LW versions I have seen, either in Layout and Modeler, with any gfx card manufacturer and any driver. Same with Duron 1300 MHz running Voodoo 3, Athlon XP 2000 with ATI 9200, and decent Core i7 930 with GeForce 8500 or so..

But Layout have option to fix this issue - there is needed to open Display Options, GL tab, enable Fixed Near Clip Distance, and adjust until effect disappears.

Unfortunately I don't know any Modeler's alternatives..

Did you check all Display Options settings, toggling on/off?

If you won't find anything in Display Options, cut model in many layers.. I believe it'll work.

You have way too big single polygons - with such high zoom, they've couple points way behind viewport camera while another points are still on screen. That's why they're cut. All points should be in positive range, looking from camera POV.

When I am making archiviz, I am making windows inside of array f.e. 3x3 quads, rectangular polygons. Your's are looking like crazy n-gons. Two windows can be joined together, and quad between them.. top points from one window to top points from second window etc with bottom. Just straight lines. Rectangle polys. Such geometry is better optimized in renderer too, means even though might have more poly count, render faster.

B Nartker
11-09-2010, 07:48 PM
My thanks to all those that posted fixes and ideas. Nice especially to know that I'm not going nuts! ( no guarantees there of course )

You guys are great! Thank you so very much!!

BJ

jasonwestmas
11-09-2010, 09:07 PM
Yeah this happens because when you are zooming, LW is zooming in on an imaginary point that is behind the part of the mesh you are focusing on. This will cause clipping. Fixing this usually includes selecting a point or poly and then doing a 'Shift-a' command. Now the camera will tumble around that selected area. You have now changed the focal point for the modeler "camera", if that's what it's called.

Skonk
11-11-2010, 03:02 AM
How big is your object?

If you have made it either very small or massively large then this will happen because the near and far clipping planes are set at values more suited to models built to a life-like scale.

jasonwestmas
11-11-2010, 10:45 AM
How big is your object?

If you have made it either very small or massively large then this will happen because the near and far clipping planes are set at values more suited to models built to a life-like scale.

Yeah this is most likely the case.