PDA

View Full Version : Black diamonds on my render



doug1138
10-28-2010, 10:35 AM
check these out....

http://www.fatbox.com/movies/strange/blackdiamonds.jpg

I have never seen them before.

They appear randomly (frames and locations) and during an F9 they don't appear until the very end (during reconstruction?).

I've tried recursion limit, sampling, reconstruction, etc.

I think they might have something to do with adaptive sampling but I can't be sure.

Thanks
Doug

Inb4 'expert ski run' references.

Dexter2999
10-28-2010, 10:48 AM
Can't say that I've ever seen that. Can you post the model/scene for testing?

doug1138
10-28-2010, 10:49 AM
Thanks for the reply.

I'll have to get client approval first.

PetGerbil
10-28-2010, 05:40 PM
Is your AA set to 1 pass ? if so, try 2.

Andrew March
10-29-2010, 12:34 AM
Hmmmm, I smell something fishy.

Andrew March
10-29-2010, 12:34 AM
Can you post a render from a different angle?

-EsHrA-
10-29-2010, 03:49 AM
try switching cameras.

mlon

m0184you
10-29-2010, 08:40 AM
I had some "holes" in render when messing with Ray Recursion Limit in Render Globals > Render Tab (wen I'm using low values, like 5 or 6, default is 16).
Try it!

Edit: You are aware of this, missed that when I read your post first time. Sorry.

Nangleator
11-02-2010, 08:43 AM
Never seen this. I almost always render with AA of 1 (Adaptive sampling from .1 to .02, for quality) and ray recursion of 4.

It's on different surfaces, but limited to appearing only on geometry. That suggests something about ray tracing, or a camera setting. Any funky nodes? Using Spot Node?

Randomness factor would drive me nutty. It will be hard to track down with test renders.

Mr Rid
11-02-2010, 03:55 PM
Watermark from a demo version of a plug or post process maybe?

Thats one for the brainteaser folder I keep. Can tell you if you post a scene. You just have to disable or remove one thing at a time to pinpoint... disable ray tracing, F9, disable all plugins (check Master plugs), F9, clear surfaces, F9, etc.

First thing I'd try is switching to Classic camera. Also disable Full Scene Parameter Eval- select Prefs panel, press "F" key to toggle (FSPE under General tab). FSPE used to sometimes cause odd red or white dots on items using post processes like HVs, instancing or G2, but I havent seen that in the 9 series.

I once had odd flickering spots an a mesh where LW had a very unusual problem with the UV, but that would come and go with scene reload.

Captain Obvious
11-02-2010, 04:12 PM
It looks like something is generating NaNs. NaN is short for "Not a Number", and they're, well, they're *not* numbers. Imagine if Lightwave tries to render a pixel, and one of the reflection rays returns something that is not a floating point value like "1.5312" or what have, but instead returns something else. Then Lightwave doesn't know how to shade the surface, so it usually ends up being black. Then all the AA samples for that pixel are averaged together, resulting in... MORE black, because Lightwave cannot figure out the average of a bunch of numbers, if one of them is not a number.

Imagine if someone asked you, "what's the average value of 3, 9 and cucumber?" Obviously, that gets confusing.

So now the whole *pixel* is a NaN. Then Lightwave applies a pixel filter, and you're back to the same problem. Pixel filters apply a combination of more or less subtle blurring and sharpening across a fairly large radius. So if you do that over a 10 pixel radius, and one of the pixels is not a number, then ALL the pixels affected by the filter end up being black.

And it looks like your render.


The first thing you'll want to do is turn off one type of thing at a time. Start by turning off all node shaders. If that fixes it, turn half of them back on until you figure out which surface, specifically, is causing the problem. If that doesn't help, turn off ray traced reflections as well. Then refractions, pixel filters, GI, lights, and so on and so forth. If you're methodical, you should be able to narrow it down in about an hour. Just make sure to do your render tests at low resolution to speed things up!




Edit:

Here are some examples of what can cause NaNs! Set up a simple scene with an object with at least two surfaces.

On one of the surfaces, add some nodes to the following effect:

One Constant node. Set it to 1.0. Plug this into the Diffuse Shading channel of the surface. Render. You end up with a surface that's 100 % white, right? Right. Good. Unplug the constant node.

Instead, add a Divide node (Math>Scalar>Divide). Connect the Constant node to input A, and manually set B to zero. Plug the output of the Divide node into the Diffuse Shading, and render again. This SHOULD produce NaNs, unless LW has some kind of special case handling of it.

So, what's going on here?

Well, it's impossible for LW to divide a number by zero. It's not a number, so LW gets confused. Try changing the pixel filter from Box to Mitchell and see what happens!