View Full Version : Audio sync problems

02-28-2003, 01:23 AM
I'm running into some problems with audio sync on capture,
System is a Dell Precision 530; dual 2.2 Xeon; 1GB RAM; Quadro4 700XGL 64MB.

I currently lack a decent drive array - I have a Fujitsu 10K 36Gb U160 drive, and a WD2000JB IDE drive, both of which AutoConfigure rates at about 51Mb/sec average.

Either appears to capture RTV uncompressed OK - it'll go for more than 1 hour without dropping frames. The problem is with the audio, which ends up lagging behind the video - about 1/2 second at the start, but gets worse later on. The footage is PAL format.

I've tried using PicVido MJPEG instead of RTV - no difference I can see. The audio is going in uncompressed.

Is this likely to be because it needs a better drive system, or is it something else?


Stuart Tetley

02-28-2003, 07:37 AM
It seems that you may be needing more hard drive power to you.
36Gigs will only give you about 20min of uncompressed video.
The 200 IDE drive if properly hooked up will give you about 2 hours. But if it is also your system drive it could explain why you're having problems.

I'm sure the drive guru's are going to jump in and suggest some pretty cool solutions for you.


02-28-2003, 07:46 AM
This can be a product of your Capture Options, along with a few other factors - are you recording "Program Out", or "Main In"?

02-28-2003, 08:21 AM
I had the same sort of problem and it turned out that the audio was being captured at something other than 48k. Not sure if that will help??

02-28-2003, 08:40 AM
Thanks for all your prompt replies. In order:

I have a system drive on one of the the mainboards IDE ports. The 200Gb one is the only device attached to a Promise Ultra 100TX2 66MHz PCI card, and seems to like it there - autoconfigure rates it around 50Mb/s whereas on the mainboard it ran about 30. The SCSI is on the onboard Adaptec single-channel U160, and again is the only device on that controller.

I was capturing from Main In (using the 'Select analog sources onto Main In.)

The captured audio is 48KHz in both cases.

I was wondering if putting the audio on a separate drive would help, but can't find a way to do this. I gather Speed Razor can do that, but I have the DFX+ bundle, and don't have Speed Razor.


02-28-2003, 08:59 AM
Originally posted by stuart_tetley

I was capturing from Main In (using the 'Select analog sources onto Main In.)

Well, in that case you are bypassing the Toaster's "TBC", and your audio should be frame for frame with the video, so with that thought eliminated, it begins to seem like a playback issue, and as others have suggested, maybe throughput related.

Originally posted by stuart_tetley

I was wondering if putting the audio on a separate drive would help, but can't find a way to do this.

There's no way to set the Toaster to capture audio to a different directory or drive than video, but apart from the incovenience there's nothing preventing you from physically moving it AFTER capturing it to test your theory.

03-03-2003, 11:13 AM

Thanks for your suggestions. Unfortunately it still has sync problems, even with the audio on a second drive.

I realized I had the Zone Alarm firewall running. In case that was the problem, I shut it down and unplugged the network connection (I've read somewhere that a network connection can be a problem) and recaptured the footage. The result was much the same.

I also tried doing a long capture of NTSC footage. The problem was less pronounced but still there.

I'm interested in setting up a proper SCSI raid set, but the prices are pretty steep for the most part. The most affordable good option I can think of would be a set of 4 Maxtor (Quantum) Atlas 10K IIs (73Gb , 10000rpm, U160, 5.2ms average access. )

I would probably add a 29160 (or 39160 possibly) adapter for this - I gather it's best to stick with Adaptec.

04-11-2003, 04:21 PM
I was just burning a dvd and the problem poped up for my again...

When you go to encode via TMPGEnt load the DVD settings the file should come out as one mpeg file not a seperate video and audio.

04-14-2003, 03:44 PM
Just for completeness try using the Toaster's built-in TBC by recording using 'Program Out'.

Also, was the footage recorded on the original/source tape in one continous recording or was it 'start and stop' recording? Often if it was 'start and stop' recording the control track is no longer continuous from clip to clip. The control track can be broke for other reasons as well. If that is the case perhaps the only solution is to capture one clip at a time. Otherwise manually resync them on the Toaster timeline.

04-19-2003, 09:43 PM
Thanks for the updates.

I can report the following:

The hard drive performance doesn't appear to matter. A RAID array running 133Mb/sec (which I had until one of the drives died) had the same problem.

Howver, capturing 'Program out' appears to cure the audio sync problem.

The footage wasn't a 'start and stop' recording, but was playing back on a standard consumer VHS deck - a fairly recent one. They don't seem to make decent VCRs these days - at the price they cost, shortcuts must have been made...

I now have another problem :confused: VT2 is locking up intermittently during capture. The timecode stops updating for minutes at a time, then starts again for a few seconds, stops again etc. The resulting captured footage reflects this.

I've seen a message 'Input sync glytch' where the capture panel normally says 'recording.'

04-20-2003, 06:31 AM
There is a preference in the Capture options that will stop recording when a frame is dropped. Sounds like you may not have that on. The underlying problem, though, seems to be getting a clean capture. Corrupt fields, severe timing errors or insufficient system throughput rates could be factors.

Assuming your drive array speed isn't dropping too low (low 20's or less) for any sustained period (you don't happen to have Drive indexing on, do you? Or background tasks that poll the drive?), this may simply be a factor of a really unstable consumer VCR. If it's a bandwidth issue, make sure you have the "Minimize PCI Usage During Capture" turned on in Prefs, and also perhaps disable "Background Rendering During Capture".

04-21-2003, 10:23 AM
Thanks Steve,

I think I have all the answers now.

I normally use the stop-when-frames-drop option, but it resets itself whenever I reload VT2 after a lockup, and I sometimes forget to re-enable it.

The lockup was caused by a drive failure in my RAID array, and I'm fairly sure the sync problems are caused by timeing errors from the VCR/tape.

I created a simple volume on one of my two surviving SCSI drives, then reran the capture from 'Program Out.' I had to use the PicVideo MJEPG codec (quality 20) as a single 73Gb isn't enough space.

The result was that it captured everything beautifully, with no trace of any audio sync problems.

Once again, thanks for all your help.

04-21-2003, 10:36 AM
Originally posted by stuart_tetley

I normally use the stop-when-frames-drop option, but it resets itself whenever I reload VT2 after a lockup, and I sometimes forget to re-enable it. Yep, that'll happen. Usually after I change any Prefs, I exit and re-start just to lock the changes in.

Normally, if you happen to crash (this really doesn't happen much any more in my experience), you don't actually encounter any difficulties if you re-start without selecting the option to re-set modules. If you select "No" then, you won't lose your settings. It's rare for this not to work, requiring re-setting things.

04-21-2003, 10:51 AM

I think, casting my mind back, probably every time I've had to 'force exit' from VT2, it's been caused by hardware problems. The VT2 software appears to be rock solid.