PDA

View Full Version : Fiber FX problem



Simon-S
10-25-2010, 05:55 AM
Hi All,

I am trying to use fiber fx to create a mohawk style haircut running down the back of a characters head and back. I want the hair to deform with the character as it moves and I'd like to add some cloth dynamics to it, so that I can get a nice spring or follow thru animation to the hair.

My issue is that if I create my guide strands in a separate layer in modeler I cant seem to get the hair to use the bones from my character and deform as he moves.

If I put the hair guides in the character layer they move with the character (great) but I cant then apply any cloth dynamics to the hair strands alone.

Does anyone have any suggestions on how I can make this work?

Also, in my fiber fx property panel the gravity option is not enabled...any ideas how I switch this on?

Many Thanks,
Simon

Skonk
10-25-2010, 06:15 AM
With them in a separate layer, you can tell that layer to use the bones from the other layer.

Select the guide layer, shift + B to go into bone mode, then press P for properties and there is a "Use Bones From Object" drop down menu where you can select the layer with the bones.

Simon-S
10-25-2010, 06:34 AM
I tried that and the hair doesn't seem to deform with the character :(

** just tried again and all works fine! Dont know what I was doing wrong.

Thanks again.

bugzilla
10-25-2010, 07:21 AM
make sure your subdivision level is set to Last in the Properties panel. That may help.

jasonwestmas
10-25-2010, 09:21 AM
Nevermind, I misread the issue.

Simon-S
10-25-2010, 10:05 AM
Thanks anyway :)

Still wondering why fiber gravity is still not enabled/greyed out in the property panel??

Anyone got any ideas?

jasonwestmas
10-25-2010, 10:56 AM
Thanks anyway :)

Still wondering why fiber gravity is still not enabled/greyed out in the property panel??

Anyone got any ideas?

If you are using 2 point poly chains, gravity won't be active. NT assumes you will use clothfx for any gravity dynamics.

Simon-S
10-26-2010, 02:59 AM
Ah I see...that makes sense.

Cheers for that.