View Full Version : Problem with Morph Mixer and multi-layer objects.

10-20-2010, 02:33 AM
Hello, everyone,

I have encountered of which I don't know whether it's a bug, a feature or a buggy feature.

I have one object with two layers in Layout. I animate one layer via Endomorphs and Morph Mixer. I clone this deformed layer, move it and change its animation in Morph Mixer.

Now here's the problem: When I save and load the scene, both layers have the same deformation/animation.

Looking for the cause i found out that in Graph Editor the "MorphGroup" is not associated with the object layer but seems to be handled globally. If I had saved the animated layer as an individual object everything would have worked as expected.

Now, didn't Morph Mixer use to work properly with layers? Or am I doing something wrong?


10-20-2010, 11:09 AM
I was able to clone an object and change it's individual morph mixer animation. The file saved and loaded up properly too.

Maybe you didn't save your scene after adjusting your 2nd object's morph mixer animation?

10-20-2010, 12:19 PM
Did your object have more than one layer, though? Single-layer objects work fine here, too.


10-20-2010, 12:25 PM
Yes, here's my test:

10-21-2010, 01:18 AM
Thanks for providing the object and scene. When I load them ... it still doesn't work here. Both object layers morph in sync.

Look at the attached screenshot: The scene now has only one global MorphGroup (arrow) instead of individual ones for each deformed object layer.

I can only conlude that this is a bug in 9.6.1 beta (1553). Mmmh, why didn't I think of this earlier?

Thanks again for your effort, Nick D.


10-21-2010, 04:46 AM
Odd. My file doesn't do that, at home or at work.

I don't see any options about linking separate morph mixer sliders in LW and I"ve never run into this problem before.

Morph mixer looks to be working on one of your objects so I'm not sure if re-scanning your plug-ins would help but refreshing your configs is usually the first step in trying to fix LW.

10-21-2010, 04:49 AM
When I load your scene into LW 9.6 (with the exact same config files) it works as advertised. This is why I thought it might be a 9.6.1 bug.


10-21-2010, 06:32 AM
Ah...you're talking about 9.6.1. I see the problem now.

I would post this in the beta forum and FogBuz it.