PDA

View Full Version : New UB Plugins and updates



dpont
09-30-2010, 11:36 AM
Michael posted me a lot of things today,
a bunch of updates and new ports for 32-bit and 64-bit Mac Universal Binary,
for Intel and PPC, 32-bit requires at least OSX 10.4, 64-bit at least 10.5 .


Following updates for Mac UB 32-bit and 64-bit
(details, history in the readme files),
RmanCollect Nodes,
http://dpont.pagesperso-orange.fr/plugins/Textures.htm
DP Kit,
http://dpont.pagesperso-orange.fr/plugins/nodes/Additionnal_Nodes_2.html
DP Light,
http://dpont.pagesperso-orange.fr/plugins/lights/Additional_Lights.html



Added a 64-bit version in the existing Mac UB,
http://dpont.pagesperso-orange.fr/plugins/Sunsky.html

And new port Mac UB 32-bit and 64-bit,
Cushion Camera 2 (bottom of this page),
http://dpont.pagesperso-orange.fr/plugins/Cushion_Camera.html
Radial Shift Camera,
http://dpont.pagesperso-orange.fr/plugins/RadialShift_Camera.html


DP Motion Designer Pack,
http://dpont.pagesperso-orange.fr/plugins/MDD_Pointer.html

the last 1.14 version of DP Instance,
http://dpont.pagesperso-orange.fr/plugins/DP_Instance.html

All thanks go to Michael Wolf at http://www.db-w.com/

Denis.

nickdigital
09-30-2010, 11:46 AM
I'm not a Mac person but this is certainly great news.

Thanks to both of you and especially Michael. :thumbsup:

Lightwolf
09-30-2010, 12:26 PM
I'm not a Mac person ...
Nor am I... I just hack on the machine... ;)

Cheers,
Mike

Kuzey
09-30-2010, 12:53 PM
Super cool...but there seems to be a problem with the DP kit, it only loads 5 plugins??

Mac OS X 10.5.8 & LW 9.6 UB

Kuzey

Lightwolf
09-30-2010, 01:02 PM
Super cool...but there seems to be a problem with the DP kit, it only loads 5 plugins??

I'll check...

Cheers,
Mike

Lightwolf
09-30-2010, 01:14 PM
Super cool...but there seems to be a problem with the DP kit, it only loads 5 plugins??

Ouch, yeah, that's not supposed to be like that. I sent a new compile to Denis which includes the right plugins.

Cheers,
Mike

Kuzey
09-30-2010, 01:17 PM
Cool...so it's not me..hehe :hey:

Kuzey

dpont
09-30-2010, 01:23 PM
I re-uploaded the Mac UB version of DP Kit.

Denis.

Lightwolf
09-30-2010, 01:26 PM
Cool...so it's not me..hehe :hey:

No. If in doubt, it's me.

If it's not me then I'll happily return the kick into the family jewels :D

Cheers,
Mike

CaptainMarlowe
09-30-2010, 01:37 PM
You two rock ! DP Instance looks quite good after my first tests. Can't wait to push it beyond its limits !

Lightwolf
09-30-2010, 02:00 PM
Can't wait to push it beyond its limits !
Please don't. If you do then Denis will update it and I need to compile again... :D

Cheers,
Mike

littlewaves
09-30-2010, 04:52 PM
Thanks a million Denis and Mike.

Newtek should seriously be paying you for this. Lightwave 9.x cycle has been at least twice as good as it would have been without your very generous hard work.

Hey maybe you guys should work on a new hair and fur solution next?

Take a well earned break first though!

thanks again.

Phil
09-30-2010, 10:52 PM
Are these also available for Mac?

Node Volume
Node Texture
Node Item Motion
Node Channel Filter
Node Image Filter
Node Pixel Filter
DP Filter

These have proved to be useful, but have only been available for Windows up to now

dpont
10-01-2010, 12:59 AM
DP Filter for Mac UB 32 and 64-bit is here,
http://dpont.pagesperso-orange.fr/plugins/nodes/DP_Filter.html
It includes Image Filter and Pixel Filter node editors.

Denis.

archijam
10-01-2010, 01:34 AM
We love the dynamic duo! :)

CaptainMarlowe
10-01-2010, 02:05 AM
I have tested DP Instance more in depth this morning, and if the distribution system works very fine, I encountered constant crashes at render.
For instance, I load an object, instance it to a null : works fine. Clone the null several times, works fine.
Load another object, instance it to another null : crash

Load two primitives, instance them to a plane, works fine, even with weight maps for distribution.
Instance them to a particle emitter, crash on render (but I instanced them to HV emitter, pehraps I should have used a partigon emitter ?)

Load a plane, load two different objects.
Instance one of them on the plane, render fine. Try to instance the two objects on the same plane, works fine in layout but new crash on render (with very same render settings as previously).

Try to instance a tree on a complicated terrain : works fine in Layout, crash constantly at render.

With very simple objects, like primitives, I didn't have any problem, even when mixing them on a plane.
But with textured more complicated objects (around 1500 polys per object), it crashes at render constantly if :
- More than one object is instanced
- Objects are instanced to particles
- Several null try to render different objects, with one different object for each null. Starts to crash at render from the second null and above.

I tried each time with and without radiosity, with and without raytraced shadows. All objects were instanced as "based", since they are fairly simple objects with no animations, nor displacement (they have node-based normal maps, though, but once again, the normal maps render fine when one object is instanced to a null).

I'm currently at work so I can't provide test scenes before tonight.

I have a fairly powerful Mac (iMac i7 2.8 with 8 Gb ram) so I don't think the problem comes from there.

I've tried this morning a scene with 5000 trees (all of the same type) on a terrain generated in Terragen, crashed at render (although distribution of the instances worked fine with weight maps in surface and points mode, scaling and rotation). Decreased to 500 trees, crashed. Decreased to 5, crashed also. So definitely not a memory or power issue, imho.

Sorry I can't investigate further for the moment, I'll try to conduct new tests tonight and this week-end and provide sample scenes. That is, if my daughters grant me some spare time. ;)

dpont
10-01-2010, 02:34 AM
...I encountered constant crashes at render...


I would like to study these issues in the original win32 version first,
You know there's a another thread dedicated to DP Instance,
for posting specific reports.

May be too many things here, I'm confused,
I must add that render issues are often random,
it is more easy to test them with a content scene,
so please before investigating more, could be
nice to focus on a reproducible issue from a scene,
also testing a huge number of instances,
could be very slow here for investigating...

Denis.

littlewaves
10-01-2010, 04:13 AM
I've found the render is crashing on MAC UB in 9.6.1 beta (although works fine in 9.6)

content attached

simple object instanced on a particle emitter.

Just load up and F9 crashes 9.6.1 but fine in 9.6

of course could just be a bug in the beta but thought I post anyway


imac 24" c2duo 2.16ghz
3GB ram
OSX 10.6
Nvidia graphics

littlewaves
10-01-2010, 04:27 AM
Are these also available for Mac?

Node Volume
Node Texture
Node Item Motion
Node Channel Filter
Node Image Filter
Node Pixel Filter
DP Filter

These have proved to be useful, but have only been available for Windows up to now

The missing ones would be great if Mike get the time to compile them for Mac UB.

And I AM serious when I say Newtek should be paying these guys for their time.

Having nodal access to all these areas is something that should have been part of the 9.x cycle anyway.

They paid for buggy broken Fibre Factory and thought they could fix it just by renaming it and listing it in their marketing so why not pay for these guys hard work too?

CaptainMarlowe
10-01-2010, 08:10 AM
I've found the render is crashing on MAC UB in 9.6.1 beta (although works fine in 9.6)

content attached

simple object instanced on a particle emitter.

Just load up and F9 crashes 9.6.1 but fine in 9.6

of course could just be a bug in the beta but thought I post anyway


imac 24" c2duo 2.16ghz
3GB ram
OSX 10.6
Nvidia graphics

Out of curiosity, I tried most of the the scenes that crashed in 9.6.1 64 bits with the same 9.6.1 in 32 bits.
Render fine in 32 bits too ; no crash, even with the "heavy one", with Terragen terrain and 5000 trees of several sorts. So it may be a 64 bits compiling issue ?

EDIT :

renders as well with three different trees, 50000 instances and, an environment and radiosity on. Renders also with particle based instances.

Lightwolf
10-01-2010, 08:28 AM
So it may be a 64 bits compiling issue ?

It could also be due to the beta status of the 64-bit OSX version of LW.
I'll have a look to see if I can find something obvious...

Cheers,
Mike

Lightwolf
10-01-2010, 08:48 AM
So it may be a 64 bits compiling issue ?

Actually, it is. The source used a variable type (long) that causes nothing but problems in cross platform as well as cross-bitness code.
I've fixed it and sent a new version to Denis.

Cheers,
Mike

dpont
10-01-2010, 08:59 AM
I re-uploaded the Mac UB version of DP Instance,
this is still the v1.14 but with the specific modifications
from Michael for OSX 64bit,
http://dpont.pagesperso-orange.fr/plugins/DP_Instance.html

Denis.

CaptainMarlowe
10-01-2010, 10:04 AM
You got it : whatever it was, it is rendering right now 25000 trees in 64 bits.

Congratulations and thanks a lot. :)

BlueApple
10-01-2010, 10:58 AM
Downloading this stuff tonight. Thanks for your obscenely generous work.