View Full Version : Vertex paint issues

Ryan Roye
09-23-2010, 06:48 AM
I have a few issues with vertex painting.

Following the Newtek video tutorial, I am immediately stuck at vertex color painting in modeler...

Using a simple object like a sphere, I can get it to work as intended, but if I do anything more complex, or if I copy/paste from other models to construct a new one then vertex painting refuses to do anything.

Vertex color maps also won't show on any subpatched object in modeler, and anything that is subpatched after painting eliminates the vertex color map in preview (though oddly it still shows in the vertex paint application), yet in the tutorial video the objects were obviously subpatched... what gives?

I've also tried the archaic built-in vertex paint application but it crashes every time it saves.

Is there something I'm missing? Why can't I use vertex painting on a subpatched object? And for some models, why is it that my painting only shows up in vertex paint and nothing else?

EDIT: Heres some pics to illustrate my issue:


Ryan Roye
09-23-2010, 09:10 AM
Update: I am able to get this to work if I select the points then select "Set map value"... but this isn't interactive and I can't see my results until I transfer my object to layout. And yes, I'm using "multitexture" shading, not GLSL.

02-15-2011, 09:28 AM
Try using standard subpatch mode. I suspect you're in Catmull-Clark. That should allow you to see the vertext paint when you exit subpatch mode. Good luck:)


Ryan Roye
02-15-2011, 09:51 AM
Wow, worked like a charm! I do see the slight difference between the two modes, but regular subpatch mode suits my needs just fine.

Thanks a bunch, I didn't think I'd get this question answered.