PDA

View Full Version : Weird Bump Displacement



Revanto
08-21-2010, 11:33 PM
Hi,

I'm doing a bit of experimenting trying to make basic jewelry designs via images and displacement maps (specifically bump displacement). Anyway, I set up a simple ring shape using a low poly mesh, turned on sub-divs and applied a bump map to it in Layout. The subdivisions were set to 'first' to about level 50 (around 1 million polys). Anyway, when I set the displacement to bump displacement for the object, I got the displacement BUT I also got this weird grid pattern that shouldn't be there. (Thanks to my friend Paul for letting me host the pic in his gallery)

http://i711.photobucket.com/albums/ww116/mix_mash/weird_render.jpg

I think it might have something to do with the displacement order but I tried everything and it still comes up weird.

I don't want to subdivide an object in modeller and then use that instead of a sub-div object because LW can't handle so many polygons in Modeller (I had trouble even subdividing an object to only 200k polygons in modeller, once... soooo slow....). SO basically, it has to stay a sub-div object.

Anyway have any ideas?

Cheers,
Revanto :p

toby
08-22-2010, 01:06 AM
Very odd. Does the grid match the subD polys? Is it there if you remove the texture? Can you post the scene/object?

Revanto
08-22-2010, 08:36 PM
The grid matches the original polygons of the pre-nurbed mesh. When I turn off the bump texture, there is no displacement as the bump displacement is driven by the bump map channel.

Sorry, I can't provide the scene file as I don't have access to it at the moment.

I think the issue has to do with the conflict between the subdivision order of the mesh and the subdivision order of the bump displacement settings.

Rev.

gerry_g
08-23-2010, 04:21 AM
Is the writing on a UV Map, is the grid still visible behind the lettering on the UV image ?

Revanto
08-23-2010, 06:10 PM
Is the writing on a UV Map, is the grid still visible behind the lettering on the UV image ?

The grid is not in the bump image. I did UV map it cylindrically but because it is a ring shape mesh it was easy to apply the texture cylindrically as well (the NON-UV cylindrical mapping type, that is). Saying that, I tried both UV cylindrical mapping and normal cylindrical mapping but the results were the same.

Rev.