PDA

View Full Version : Dongle id and lock id



Mr Rid
07-23-2010, 11:28 PM
Am trying to use a new dongle and I am never clear on how the LW license/dongle ID/lock ID works (why do we need 3 numbers?).

I attach dongle, run 'RegisterLightwave.exe' & enter the license #. Run LW9.61, and it is in Discovery mode. When I click 'Enter License' under Help, I get error, "Line 31, illegal arithmetic operation on data type"(?).

Creating a license key from scratch in a text editor does not work either.

Where is the Lock ID derived from (not the dongle ID)?

rsfd
07-24-2010, 02:41 AM
Did you have registered at your NT registration account with your new DongleID+LW serial?
You should then find your Unlock key on your "My Products" page.
The Unlock key is needed to generate the license key file.

rsfd
07-24-2010, 07:42 AM
Wait a minute - you are running 9.6.1? The beta? Don't you need a special beta license key for that?

Exact, the OpenBeta has separate Unlock keys which are renewed every 80 days.
But first, he needs to register the OpenBeta with his *new* DongleID to get the OpenBeta Unlock key (which is what you call License key).

(And the OB license key file should be separated from the 9.6 license (also the preferences).
I'm usually on the Mac and sorrily can't remember the way that is used for that on Windows.
I remember it being more complicated as for OSX, with special linkages to the apps combined with a -c flag.
But I'm sure you guys know how to do).

Mr Rid
07-24-2010, 05:17 PM
Thanks for taking time to respond! Its VERY annoying when I have to waste hours on something so tedious that ought to be straightforward.

First off, when I need to download something NT related, I dont get why NT does not have a typical DOWNLOADS link, instead of a 'registration' link. I dont neeed to register, but whatever. Then I dont get why the 'My Downloads' page is separate from the 'My Products' page. Seems like My Download is My Product, and these could be in one place.

But to answer rsfd, yes I already registered for 9.6 and 9.61 beta. I recently swapped a parallell dongle for a usb. I was not given a new serial # if that is what you are indicating. When you say 'Unlock key' I assume you mean the 'License Key.' LW96 works, but LW961 does not.

On My Products page, I have 3 lines of v9 license info, but it does not specifiy versions (although it should). One says 'Purchased From- Spinquad', which is my 9.6 license. The 2nd one says 'Purchased From- Beta Phase 3', and the 3rd one is 'Beta Phase 5' dated 6-28-10 which I assume to be the latest 9.61 version. The same 4-digit 'Lock ID' is listed for all three... what the hell is that number for? Is the 'Lock ID' and the number on the dongle suppose to be the same? My dongle has a third, different, 5-digit number written on it.

You also suggest to register my new 'Dongle ID', but I see no option to enter a 'Dongle ID.' When I register for the 9.61 beta, the fields are automatically filled in for my x32 license. Under the x64 slot it asks for my 'Lock ID' which is not the same # on my dongle. So is the problem that the 'Lock ID' and the 'Dongle ID' are suppose to be the same number? If so, why confusedly refer to the same number by two different terms? Why doesnt NT just call the number on the dongle the 'Dongle ID'?

Mr Rid
07-24-2010, 07:46 PM
Well, under 'Enter License' in LW, or if I run the Registration.exe, one says 'Dongle ID', and the other says 'Lock ID' and they are both the same number that does not match the 'Lock ID' listed in 'My Products.' So I gather that the 'Dongle ID/Lock ID' is a number that comes from the dongle. If I register it does not allow me to use this number. So, yeah I have to wait to call NT 'support.'

Mr Rid
07-24-2010, 09:15 PM
So am wondering why NT does not explain anything when they send a new dongle. And how come 9.6 works fine with the new dongle but 961 does not?

rwhunt99
07-28-2010, 08:07 PM
I have a similar problem. I switched from 32bit to 64bit, got new serial and when I put it in, it says it was successful, yet when I restart it, it reports license key was not found. and tells me I need to contact Newtek. It will see my 32bit license, but gives me a warning that it is a temporary license and I need to contact Newtek. What frustrates me the most is I don't get much help from them. First I e-mailed customer service and they told me I need to turn off UAC in Windows 7 because it doesn't work with it on. I did that but same results. Then they turned it over to tech support and they asked me a question about did I install with the dongle in and I answered it yes and that was all. Still waiting

rsfd
07-29-2010, 08:18 AM
@Mr Rid
sorry for the late reply.

DongleID = LockID = Product Lock
(depending on where it is written, should definetively be unified by NT)

Well, you say that your new USB-Dongle shows a different ID than your previous one in "About Layout/Modeler". As Megalodon states, this was to expect.

You wrote you tried to register for 64-bit OB and you were asked for your LockID.
That is the 4-digit DongleID.
You have already seen your new DongleID, so I would say: just try to re-register with your (old) serial for 64-bit OB and enter your new DongleID.
This *should* work (but I can't guarantee of course).
You *should* then see a new "Unlock key" (xxxx-xxxx-xxxx-xxxx) in your "My Products" page with addition "Beta phase 5".
That is the number which is needed for the OB-license file.
I would create the license.key file manually and place it where it belongs under Windows.

License and preferences for OB should be separated from official LW9.6.
OB license is valid for a period of 80 days (with 58 day left since today) and will be automatically renewed by NT in your account.
You will then have to enter every new OB-license in your License.key file.

@rwhunt99
agree with Megalodon.
For your issue with a "temporary license":
Are you using 9.6 or 9.6.1?
If 9.6.1, then this would be normal as 9.6.1 is the OpenBeta and not yet officially released.

wesleycorgi
08-02-2010, 12:45 PM
Mr. Rid, not sure if you resolved this, but I had recent 9.6.1 reg problems with "Line 31." First, I installed 32-bit and the issue was I didn't have the latest Sentinal Driver --- in a different thread, someone mentioned that one of the installs actually installs an earlier driver that doesn't work with 9.6.1. So after using the latest driver, my problem was fixed.

Then I updated to 64-bit LW, because I switched to Win 7 64-bit. This time, I had the latest Sentinal driver but still incurred the Line 31 error.

The issue was Win folders properties --- it wouldn't save a License.key file. Even though I kept changing the folder properties to allow modifications, it wouldn't let me. So I created the license.key file separately and then copied and pasted into the 9.6.1 Programs file.

Now it's working. I'm a Mac guy, so I'm not sure why Win 7 won't let me permanently change the folders properties. I'm liking Win 7, but I hate that every operation prompts you for confirmation several times before it actually executes. I know it's a security precaution, but it's a pain in the arse.

Speaking of pain in the arse, I agree with your original comment that the whole Newtek Lightwave registration process sucks. It's one thing about the hoops you have to jump through to get the dongle/reg number resolved. But it seems like Newtek decides to change where the license key resides with each iteration --- so you waste minutes (if not hours) trying to find where the heck the license.key is when troubleshooting.

arcanor
08-03-2010, 05:22 AM
If you're running on Windows 7, or probably also Windows Vista, you must RIGHT CLICK the Registration Utility (RegisterLightwave.exe) then select "Run as Administrator".

I found this quite confusing as the Registration utility didn't give any indication of an error. It just silently failed to create the appropriate license key file, and when I tried to start modeler it kept running in Discovery mode. It was only after I ran the Registration Utility as the administrator that I was able to run modeler without restrictions.

I hope this helps some people.

edsegar
11-23-2010, 09:48 AM
hey arcanor,

it looks like it solved it for me .. thanks