View Full Version : Object doesn't stay deformed

07-16-2010, 03:00 AM

I have a little problem with an object I'm manipulating with bones. It's a filmstrip. I've added a series of 48 bones to be able to shape the strip into an "S" shape. I did that alright, but when I save the scene, get out of Layout, and then, re-enter Layout, and reopen the scene, the filmstrip is no longer conformed to the bones. The bones are still bent, but the filmstrip is straight and at an arbitrary angle.

I've tried changing the SubD Order to Last, After Bones, etc..., but nothing seems to get the filmstrip to re-conform to the bones' bends.

Any & all help is greatly appreciated.

07-16-2010, 03:04 AM
If you post your LWS we could help you immediatly.

07-16-2010, 04:58 AM

Are the bones activated in the Bones Properties panel? Also if you select all the bones and hit the 'r' key the object might go back into the 'S' shape.

Hope this helps

07-16-2010, 07:43 AM
If he hits the 'r' key (which btw is default key for Record Bone Rest Position not just any arbitrary key) when the bones is in the s-shape then obviously it won't fix a thing. So I just want to add: go to a frame where the bones conform to the shape of the undeformed mesh or make the bones conform to the mesh on a new frame. Then hit 'r' to rest bones, ie bind the mesh to the bones in their current state.

Personally I think it's another case of using Record Pivot Rotation (aka RPR; note: not same Record... as above) and not (rekeying and) reresting afterwards. RPR will alter the orientation of your bones and thus you need to rerest. RPR is better avoided imho as it is it truly just a cosmetic function and will not add anything essential to your rig. Cosmetics as we know, hides the blemishes but doesn't fix the problem.

07-16-2010, 09:11 AM
When I set up this scene, I manipulated all the bones on frame zero, because it's just for a still shot. I was then going to save the deformed filmstrip as a new object, but I had to do some texturing work, before I did that. I've tried all the different options under bone orientation, but nothing works. No Part of the filmstrip is aligned with any of the bones.

I did have to fix gimble lock on the first bone, before I started my bending/twisting process with the bones. Could that have anything to do with it?

07-16-2010, 09:46 AM
Sure. If you changed the rotation on the first bone, either directly (rotate tool) or indirectly (RPR), after resting, that would offset child bones and thus the bind pose aswell. How did you fix the gimble lock? RPR? Did you rerest the bone (the first one or all you edited) afterwards? (You should have)!

Also, I wonder, do you turn off deformations globally or deactivate bones when tweaking them?

If your mesh doesn't follow the bones into the s-shape anymore, then clearly you've lost the correct rest pose and have to go back a step and redo the resting process. If you truly did only edit the first bone you should be able to take it back to the same state it was before you rested the first time (and before the gimbal lock fix) and just rerest. Ie align the bones to the undeformed mesh and rerest.

If you still can't seem to do it, upload the scene (bones with s+shaped pose) and object. If you don't care to give out content then make a simplified version of the object that approximates it's shape.

07-16-2010, 12:27 PM
Thanks for the help everyone!

Dan: That's what it was, but I'll have to start all over again. I did a test where I drew 1 bone for the filmstrip and split it into 48. From there: I did Record Pivot Rot (Shift + P) for each bone. Then I did Record Rest Position (r). Then I manipulated the bones, which deformed the filmstrip, and saved the scene. After clearing the scene, I reopened it, and the mesh was still deformed the way it was supposed to be. I was unaware that once you set the RPR on one, you had to set them on all the bones, and re-rest them all, too.

Thanks again.