PDA

View Full Version : Light not affecting certain objects



stevenpalomino
07-05-2010, 08:16 AM
I know this might be a noobish question, but how do I get a light to not affect certain objects in my scene?
Thanks!
Steven

UnCommonGrafx
07-05-2010, 08:49 AM
Look at the objects tab on the light panel.
Exclude objects in that list.

stevenpalomino
07-05-2010, 09:02 AM
:D duh! Thanks! :)

jrandom
07-06-2010, 11:14 AM
Is there a way to have a light not affect an object in a render but still illuminate it in the OpenGL viewports? As far as I can tell, there's no way to separate the two.

Dexter2999
07-06-2010, 11:18 AM
In the light properties panel, uncheck everything except OpenGL?

But if you don't want it rendered, wouldn't you want to just use Headlight?

jrandom
07-06-2010, 11:30 AM
In the light properties panel, uncheck everything except OpenGL?

Ah-hah. I had been altering the object's properties instead. I will look into this. (I do a lot of scenes lit entirely by fully-luminous polygons so this will help greatly.)


But if you don't want it rendered, wouldn't you want to just use Headlight?

What is this Headlight of which you speak?

- Brad

Dexter2999
07-06-2010, 11:46 AM
William explains it better than I could.

ftp://ftp.newtek.com/multimedia/movies/LW_9/Layout_Headlight.mov

(might want to right click "Save As")