PDA

View Full Version : Import OBJ - Weight maps/morphs/etc. from ZBrush



We-Co
06-15-2010, 10:26 PM
I made a model that has weight maps, morphs, bones and such and then I exported it out as a OBJ to bring into ZBrush. Now that I'm done sculpting it I brought it back into LightWave but I want my stuff back(weight maps, morphs, etc.). I know, I know I should have done it in ZBrush first but I know there was a plug-in for this called ZWave but it doesn't work with LW 9.6 apparently is there another solution?

Thanks.

Dodgy
06-16-2010, 12:02 AM
If all the points are in the same place from the old one, select all the points, copy them and paste them into a new object. Clear the UV map that you used in ZB from them then copy the object from Zbrush into the new object, then merge. Both sets of points should contribute their morphs/weights/UVs to the new composite object.

We-Co
06-16-2010, 12:52 AM
DANG IT! So close... But still so far away.

I did it and it looked like I wanted it. Only problem is, the polys somehow got mixed up?!? Interesting... All the polys and points match up, the only difference between the two objects are the non-planar. Is that a problem? And if so how big? Please don't tell me I have to make the morphs and stuff again :'(

We-Co
06-16-2010, 02:32 AM
Thank God. A few hours of playing around in LightWave and problem solved! If you're having the same problems as me, here was my steps for anyone who cares. :-P

STEPS:

(1) Load in your ORINGAL (NOT THE OBJ) LW object and make sure SUBPATCH is OFF the WHOLE TIME!
(2) If you have bones delete them or copy and paste them in a BRAND NEW OBJECT (NOT a different layer)
(3) Delete ANY/ALL TEXTURE MAPS you have. (F8 - shortcut key)
(4) LOAD your OBJ file.
(5) Copy and paste in the SECOND LAYER of where your LWO is located.
(6) In the SECOND LAYER, select your UV Texture and copy (MAP >-uv/texture- MORE > COPY UVs)
(7) In the FIRST LAYER - UNWELD the polys (Crtl U - shortcut key)
(8) Create a NEW UV map (DO NOT CHECK INITIAL VALUE!!!!)
(9) Then SELECT/HIGHLIGHT the LWO and paste the UV map (MAP >- uv/texture- MORE > PASTE UV's)
(10) CHECK!!!!!!!!! If your polys are mixed up! You did something wrong! Check steps again.

P.S. Check by selecting the face or certain spot on your object on the UV MAP. Do other places get selected or highlighted? If so figure out what you did wrong. If you followed the step, please dont hesitate to PM me or Skype me. :-)

Copying morphs STEPS:

When you done with the UV text, you need to do the follow up morphs right? Well okay.

(1) In FIRST LAYER, make sure you LWO is STILL UNWELD.
(2) in SECOND LAYER UNWELD the OBJ (Crtl U - shortcut key)
(3) Go back to the FIRST LAYER then put you SECOND LAYER In the background.
(4) Copy morphs (MAP>-morph-BKG TO MORPH) LEAVE default.
(5) DELETE SECOND LAYER
(6) Select BASE in your morph "M" at the right hand bottom of the screen.
(7) Apply morph to base (MAP>-morph-APPLY MORPH) 100% on "Bkgmorph" hit OK
(8) Merge polys (m - shortcut key) and hit TAB to turn on SUBPATCH
(9) Check!!!! And you should be good to go.

If you still have problems follow steps again, or as I said before PM me or Skype. I might do I video tut if I feel up too it. Anyway Good luck Lightwavers.