PDA

View Full Version : Can't get foot to rotate properly....



Paradise
06-11-2010, 10:48 PM
So, I am trying to pose my character with the help of weight maps. But, no matter what I do for the weight map of the legs, the foot would not rotate properly and would end up twisting my whole leg out of shape.

http://img.photobucket.com/albums/v351/angel_or_devil28/weightMapProb.jpg

I have tried doing separate weight map for different sections of the leg (i.e. thigh, knee, ankle, toes, heel), but that did not help :/.... Then I tried to making weight maps that cover the whole leg, ... that did not work either.......

Please help :( cause I don't know how to fix it!!! :help::help::help:

nickdigital
06-11-2010, 11:01 PM
Have you rested your bones properly?

Are you actually assigning your weight map to the bone that you want? If you're making separate weightmaps for each section that means you're assigning those maps to different bones.

Paradise
06-11-2010, 11:23 PM
Mmm, sorry I am still pretty new to this :/
When you say "rest the bones" what exactly do you mean by that? .... (most likely did not do this... but I used SimpleRigger to create the skeleton, would this change anything?)

Well, when I make the weight map, i just highlight the polygons corresponding to the bone... am I supposed to highlight the bones as well? I have never actually done weight maps for bones before.. only for textures.

Sorry for all the questions :(

nickdigital
06-12-2010, 09:13 AM
When you turned on the bones did you do it by hitting the "r" key?

In Layout, select the bone that you want to assign a weight map too, hit the "p" ken and in that panel there's a pull down to specify which weight map you want associated with that bone.

Never used SimpleRigger but the advice above is independent of any plug-in.

Paradise
06-12-2010, 09:36 AM
oh i did not press the r key when selecting a specific bone, ..
but i did associate all of them with a weight map.

Paradise
06-12-2010, 01:53 PM
So I tried it again, after pressing r and checking the weight maps again, the foot and arms still do not bend properly. >__< I don't think I could ever get this to work properly lol :/

Nickdigital, thanks for your help though.

RebelHill
06-12-2010, 02:11 PM
select all the bones at once and rest them... then try... could be other things though, gimbal issues, other bones elsewhere in the setup influencing the area, etc, etc. Hard to say without more specifics.