View Full Version : Months on same scene

05-07-2010, 12:10 PM
I'm wondering if there's a negative cumulative effect of some kind when working on the same scene over many months. I've gotten to a point where dragging the Tension arrow to affect one key in the Graph Editor hangs Layout forever. I've tried 9.6 and 9.6.1 on my 1.42 GHz dp G4 tower. Over the months I have cut frames, added frames, cut and added cameras and lights, then cut and added them again. I have changed and screwed things up in hundreds of ways, but until now I've gotten away with it. I often use "Save As", and re-number the scene. No objects have changed for at least a month. Also, I'm running Maestro2. Maestro is so stable I really don't see it as being the cause of the problem. Besides its excellent rig, I use it mostly as a 'picker'.

The scene has one character running, bouncing a basketball. Some of the other elements of a bball game are there, the floor, stands made up of half-a-dozen objects with crowd projected on the main object, bball pole & hoop. The objects have been textured to varying degrees, but keeping it as simple as possible.

For the last month or more the BG elements have been hidden and unseen by camera. I've been working on this scene about five days a week.

I've learned to animate (!) during this months-long span. For this scene, I've kept the man object in place while animating the mesh away from it. At first, I had (unnecessarily) tilted the entire object to get the man in a more forward-leaning position. A few months ago, I straightened the object back into a normal position, then corrected the animation accordingly.

There are approx 125 frames in the scene. At pose 70, the man makes a right angle turn. In order to accomplish this without putting too much strain on the IK, I moved and rotated the man object (from 12 to 3 o'clock) through 8 frames or so. This re-positioned him in mid-action. --Think of moving the end of a broom handle while keeping the broom brush rotating in the same place. From frame 70 on, the man runs in a new direction.

This has all worked Ok. Now I'm trying to fine-tune the timing at the end--the last 16 frames or so. To do this, I cut some frames using the scene editor. I'm wondering if these cuts are 'the straw that broke the camel's back', because Layout now hangs when working in the Graph Editor.

From the beginning I've been keeping a log of all my actions. Every time I achieve something useful, I perform a "Save As" on the scene; maybe there are one hundred of these scenes, with progressing numbers. For the last two days I've been slowly working backwards, re-opening previous versions of the scene looking for one that's stable. I think this method will be successful, but I wanted to ask the question. Is there a negative effect from cutting and adding frames, cameras, and lights over long periods of time?

05-07-2010, 01:38 PM
I'm not much of help on animation, but I discovered something in the Graph Editor today. If you hit "d" while in there, one of the options said something like, "lazy update." It might help speed edits up.

05-07-2010, 03:46 PM
If there is some glitch forming because of a buildup of some odd effect, there is usually a good fix. Open a new scene, name the light and camera to (deleteme), use load from scene, and load in your entire scene file, lights and all. Then delete the old camera/light. Now go through and set your frame range, bg color, fog and stuff that doesn't carry over.

This has helped me in the past with errors that have popped in a particular scene file.

One thing that REALLY can slow an animation scene down with character rigs is when you are deforming lots of geometry. Turn any characters you aren't working on display subd to 0. And the one you are animating to 0 or 1 maybe. But if you don't have a bunch of deforming objects, then ignore this.

05-08-2010, 05:09 PM
Working in 9.6.1 I tried using Load From Scene the way you describe. The scene loaded OK, but the illumination was wrong. Before doing anything I saved the scene. The light was wrong because Ambient Intensity had changed to its default, and one of the two Distant lights included with the scene didn't illuminate anything. The bad light object didn't display it's usual barrel-shaped icon on screen, the light was only represented by its position arrows. I tried changing light types, but when that didn't work I cleared the light and cloned the good one, moving the new light into position. I didn't save the scene. At some point an error occurred:

Line 11569, invalid argument 1 value to method getKeyTime()

and Layout crashed.

After reboot and loading scene, both original imported lights were operating correctly. I ran a Preview, then moved the ball object into a few key positions over 12 frames. Everything looked good until I tried to set the Tension on one key, which made Layout hang forever.

I've noticed that when Layout hangs, the trouble is often brought on by doing something in the Graph Editor. I guess that's because it's the heart of Layout.

Mr Rid
05-09-2010, 03:11 AM
You might open your scene file in a text editor and see if there is a lot of something unusual. I once had a scene bog down abnormally and become enormous when saved. Basically there were TONS of these damn expressions multiplying in the graph editor from doing a lot of load from scenes, leftover from someone else's scene in the pipeline that were no longer needed.

05-10-2010, 05:39 PM
Wow! It looks like patience and remaining calm has paid off. The other day I wanted to throw the #@%! machine out a window, but went to a show and took it slow for a couple of days instead..

'Occam's Razor' says to try the simplest solution first. Every time Layout went to the clock, I was adjusting a key in the Graph Editor, so I thought the trouble was with the GE. Turns out one of the objects, the basketball, had gone sour somehow. I cleared it out, saved, Quit LW, and rebooted for good measure. Now whadda ya know, the scene seems to be Ok.

Months ago when I decided to change the animation, I selected all the basketball's Y keys and moved it up out of the way. Apparently, that tangled something. So far today I've only set the tension on a couple of keys, but so far so good, the GE is friendly and responsive. After the reboot, the scene seemed to load faster, too. It just seemed healthier from the start.

BTW, I did compare a couple of scenes in BEdit and couldn't find any outrageous or obviously strange lines of text in the scene files.



05-11-2010, 06:55 AM
Could you perhaps try and save a scene out with only this troublesome object (maybe even replace it with a null)? It would be interesting to study.

05-17-2010, 10:38 PM
I eliminated every object from the scene but the man and the basketball, but first replaced the ball with a copy I'd made in Modeler. I figured this might clear out any problem connected to the specific ball object. I used 'Save As' to save the scene with a new name. I loaded, and worked with the scene for an hour or so, and everything seemed to be Ok. I had decided not to claim victory until I'd worked a whole day without incident.

Eventually the time came to set the Tension on a ball key, and again the Tension-setting arrow lit up, stayed lit, and Layout hung forever. After rebooting, I worked a while but then Layout crashed when trying to copy a key in the GE. (I've had this trouble before) The Right Mouse Button drop-down menu activates, but no highlight is visible. Subsequent mouse movement triggers the crash, and Layout disappears.

Then I thought I'd see if loading the original ball object into a fresh scene would bring on a crash when activating the Right Mouse Button drop-down menu. This time I didn't reboot, just started up Layout again. I loaded the object, animated 6 positions, went to the GE, tried to copy a key, and got a crash again.

So I figured I'd compress the two objects and scene file, start a new case at FogBugz, and upload the archive along with my description. Hopefully, this will help someone figure it out. When logging in here though, I realized I had forgotten to tell them about the error number I reported above. I don't see any way to add this to my FogBugz case.

Thanks for your interest,
Dual 1.42 GHz PPC G4; OS 10.5.8; 2 GB RAM