View Full Version : VT not showing up in WME: Solution

Chris J.
09-11-2003, 02:34 PM
Not desiring to reinstall VT3 after having recently installed WME9, I discovered that WME (i think) changes one of the entries in the registry causing the VT3 not to show up.

In the VTCAPVID.inf file it points to a registration entry: HKLM,SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers32,MSVIDEO,,VTCAPVID.dll

However, in the registry, the entry MSVIDEO was linked to vfwwdm32.dll

So I added a new string named MSVIDEO1, with the value VTCAPVID.dll. Then altered the inf file to: HKLM,SOFTWARE\Microsoft\Windows NT\CurrentVersion\drivers32,MSVIDEO1,,VTCAPVID.dll

and, whalla, the VT now appears in the WME list. What a relief!

Hope this helps

09-12-2003, 06:37 AM
I really don't know enough about this, but having looked your workaround over - you don't suppose simply removing the second comma from the original would have done the trick, do you?

It sort of looks as though the intent of the VTCAPVID.inf listing is to offer multiple sources. The first one would apear to be DV and webcam devices, while the second one would be the VT - but the second one is messed up by the dual comma? OTOH, I may be talking through my nether regions :-p

Chris J.
09-12-2003, 09:04 AM
I also don't know enough about it , but what you says makes sense. The thing I found was that the VTCAPVID.dll was not present at all in the registry as indicated by the .inf file, so it seems it will be neccesary to add that in somewhere and maybe adding it to the MSVIDEO entry would be sufficient, making it unneccesary to alter the .inf file or create a new entry.

Perhaps where this is headed is to see if Newtek can figure out a way to prevent the original entry from being altered when WME is installed, (if there indeed was a MSVideo entry to begin with!) and then there would be no need for this in the future. In the mean time, we'll keep Toastin'!

(Maybe someone who does understand registry entries can shed some light on this)

09-12-2003, 10:34 AM
why did you need to do this?

Chris J.
09-12-2003, 01:10 PM
Hi jerm,

I was following the tutorial on this site to set up for streaming, and after installing WME, the VT did not show up in WME sources list, like it showed in the tutorial. Other posts in the forum said you would need to reinstall VT to get it to show up, or if a new setup, install WME first, then VT3.

I did not want to reinstall the VT3 and so went to find out why the VT wasn't showing up and that is how i stumbled upon this workaround.

And because it worked, I was hoping this idea may spare some others needing to reinstall for the same reason. Now it works with WME and MSM too as a webcam source. Kinda fun!