PDA

View Full Version : Transparency Rendering Issue



Cubit
04-28-2010, 12:48 PM
I wonder if someone can help me out.

I downloaded the free trial of lightwave 9.6 (I'm used to using version 8.5) and have hit an issue that I can't seem to solve.

In the rendered frame provided I have a large landscape object, textured with a simple grid image repeated on the y axis, a particle emitter, and an 80% transparent cube partially covering the emitter. I'm using the classic camera with ray tracing transparency turned on.

When I render the image you can see the particles but the landscape texture through the transparent cube does not render correctly. If I turn off ray tracing transparency then the background renders ok - but I don't see the particles behind the transparent cube.

I have tried loads of different ways and combinations to try and resolve the issue but without a solution. (including changing to other camera types with different combinations of ray tracing transparency on and off, changing the settings of mipmap quality of both the grid image surface covering the landscape and in the image editor).

The exact same scene works perfectly on my 8.5 version of lightwave so I must be missing something in the 9.6 version.

I've been banging my head on this for about 4 days solid now and I would appreciate it if someone could tell me where I'm going wrong! I've included an image and the scene below.

Thanks for your time.
Regards Cubit.

84401
84402

medicalart
04-28-2010, 05:22 PM
You didn't say if you tried the anti-aliasing settings for the camera.
Your grid lines look good, so I'm probably wrong, but you can try setting classic camera properties to antialiasing PLD7 or something.

Cubit
04-29-2010, 05:04 AM
Thanks for your input Medicalart

I tried a PLD 7-pass with box filter, classic camera, ray tracing on. It improves it a bit but the landscape texture through the transparent object still does not match up with the landscape seen without the transparent object (see render below). I've tried higher passes but still no luck.

Any other suggestions would be appreciated.

medicalart
04-29-2010, 06:56 AM
I'm out of ideas.
if you aren't moving the camera, you could probably make a fake surface texture for the cube that pretends to be the transparent background. (I told you I was out of ideas...) Puzzling that it works in LW 8.5. Good luck.

Twisted_Pixel
04-29-2010, 07:06 AM
Welcome to the forum Cubit.

Not sure if I will be able to add any more than medicalart, but will take a look at the scene this evening.

Cubit
04-29-2010, 10:38 AM
Medicalart - unfortunately I am going to be moving the camera - this is just a test render - the scene I'm planning to do will require lots of transparent objects + the landscape + particles - that's why I need to either use a different camera or classic camera with ray tracing transparency on - its a pity none of these options work.

Twisted - thanks for the welcome. I appreciate you trying the scene out - I look forward to hearing if you have the same problem.

Cheers again guys!

Ps - I'm going to try recreating the landscape and scene again in the 9.6 version - maybe the file is corrupt or something.

Twisted_Pixel
04-29-2010, 11:04 AM
Been having a look at the scene, been through every option I could think of.
Decided, to try a different image types (BMP, PNG, TIF) for the landscape grid, now it is more apparent there is something not quite right.

See sample images below, scene remains the same except for changing the grid image in surface editor.

From the images you can see your tga file shows the problem discussed, the others do not show the problem. However, the quality overall is lower.

Elmar Moelzer
04-29-2010, 12:35 PM
This seems to be related to the anisotropic filtering, which in turn is related to various other factors. If you choose raytrace transparance, a new ray is started at the transparent surface. So that may have an effect on these other factors. You could try turning the MIPMapping down all the way for either the image in Image Editor, or the texture in the Surface Editor. You will have to employ much higer AA settings in order to get acceptable AntiAliasing of the lines, but they should look much more alike. I am affraid that I have not been able to try that, so I am just guessing.

medicalart
04-29-2010, 12:49 PM
There are some tutorials on making transparent glass. I've forgotten the technique, but it may be having a rectangle inside the rectangle with the polys flipped, in order to create the inner surface of the glass. It's possible one of those tutorials would give you an idea... just thinking out loud.

Dexter2999
04-29-2010, 01:15 PM
Looks similar to the thread about "not rendering black" which was something to do with turning "dithering" off. Not sure if dithering was available in the older version so might be worth checking out?

Cubit
04-29-2010, 02:42 PM
Thanks all for the input!

I recreated the scene over again - still same results.

But then I found with some of your advice I can get the texture to be the same on both transparent and non transparent sides - see renders. The only problem now is I can't take advantage of a high mipmap strength on the surface of the landscape to make it fade out to grey into the distance. Even at a high AA pass the landscape is going to shimmer quite a lot. All the renders had motion blur dither turned off - I also tried it on for a render but there was no difference.

Is this a limitation of Lw 9.6? - Lw 8.5 doesn't seem to have the same issue?

Thanks again for your solutions guys - I appreciate it.

Twisted_Pixel
04-29-2010, 02:55 PM
Is this for an animation or a still shot?
I'm guessing animation, but if not I did a quick comp so that it looks as you require.

Cubit
04-30-2010, 02:40 AM
It's for an animation Twisted.

Elmar Moelzer
04-30-2010, 07:25 AM
You could try bluring the texture yourself and then blending these texture variations with the original texture by using distance to camera and incidence angle gradients. Yes this is quite a PITA, but I am affraid that this is the only thing you can do in this particular case.
I do wonder though, whether the refraction problems would really be that appearant in a real life situation (no repeating textures).

Twisted_Pixel
04-30-2010, 08:30 AM
Just a random thought, can't test at work. (Will test when I get home)

Do you get the same issue, if you use object dissolve set to a % to acheive the look you are after, rather than using the transparency surface setting? It may end up the same, but thought it would be worth testing.

Twisted_Pixel
04-30-2010, 10:22 AM
So much for that idea.
Gives the same results.

You said initially it worked fine in 8.5, is there any reason you can't render the project in that version?

Cubit
04-30-2010, 01:35 PM
EUREKA!

Elmar came up with the solution! :thumbsup:

It took a bit of fiddling about but the distance to camera tip worked beautifully (see image).

I had to turn off mipmap quality on both the image editor and the surface editor, I used 2 surfaces; one of the grid and one of grey with a distance to camera alpha gradient set to 1km. I used the classic camera with transparency turned on but it also works with Real Lens Camera with transparency turned off.

Thank-goodness it works - I want to upgrade to the new version of Lightwave and this just puts my mind at ease!

Cheers guys for helping an extremely perplexed soul! :)