PDA

View Full Version : Apple almost fixes Quicktime for x64 Windows



biliousfrog
04-09-2010, 07:28 AM
It's only taken the best part of 5 years but Apple have finally managed to enable the player controls within browsers for 64bit Windows users.

http://forums.cgsociety.org/showthread.php?f=59&t=870815&page=1&pp=15

No word on the gamma issues or a proper x64 version though...but it's a start.

Wickster
04-09-2010, 07:38 AM
Awww. Just when I have finally accepted the fact and made it to be a part of life that Quicktime will just work like that...forever.

OOZZEE
04-09-2010, 08:23 AM
last friday, I updated the usual quicktime update, rebooted to a "missing operating system" error.....lost lots of stuff !!! on win64... I'm done with quicktime !!!!

Myagi
04-09-2010, 08:48 AM
I'm still waiting for a proper x32 version, going on 15 years or something :D

aurora
04-09-2010, 08:58 AM
I gave up on Quicktime a couple years ago. It will take a lot to get me back to it. I thought that was crude and harsh saying that then I thought of all the people that are now saying the same thing about LW. Me being what many claim to be a LW fan boy, makes me see the other side, sot of. I guess 'maybe' I'll give it a try so I'm just slightly less a hypocrite then I know I am.

BigHache
04-09-2010, 09:35 AM
Yay! Yeah Apple seems to hate x64 Windows. iTunes also tells it me it was improperly installed every time I start it. If Apple won't fix the issue maybe they could at least provide an honest error message and own up:

"We're sorry, we didn't develop iTunes properly for Windows x64, some functionality will never be available."

Thaaaaaaaaaaaanks! :)

OnlineRender
04-09-2010, 09:43 AM
apple seem to have a bad habbit of building something with promise then killing it off , IPAD will last 3 weeks ooohhhhhhhhhhhhhhh IPAD IN A BLENDER http://www.youtube.com/watch?v=z_BshfWGQos

Larry_g1s
04-09-2010, 10:24 AM
Yeah, I'm glad to see that I can see the time frame now in a web browser.

ivanze
04-09-2010, 08:48 PM
On Win7 x64 systems just run your browser in Windows Vista SP2 compatibility mode and it shows the controls.

Captain Obvious
04-09-2010, 09:18 PM
No word on the gamma issues or a proper x64 version though...but it's a start.
If you've got QuickTime Pro, you can fix the gamma issue without even having to re-encode. It's just a matter of changing a few settings in the QuickTime file's properties.

hrgiger
04-09-2010, 09:37 PM
I hate Quicktime. But unfortunately it's in so much use everywhere I don't want to not have it. Wow, nice to see I'll actually have a scrub bar. Who'd thought those were useful.

Silkrooster
04-09-2010, 11:20 PM
I hate Quicktime. But unfortunately it's in so much use everywhere I don't want to not have it. Wow, nice to see I'll actually have a scrub bar. Who'd thought those were useful.

I am almost in total agreement. I am still debating on whether I like it or not. My biggest complaint is that they don't want to give it any attention, till now that is. I think they are more interested in their toys since thats their money maker.

biliousfrog
04-10-2010, 04:28 AM
If you've got QuickTime Pro, you can fix the gamma issue without even having to re-encode. It's just a matter of changing a few settings in the QuickTime file's properties.

It's an annoying extra few steps every time you need to send a proof though

Captain Obvious
04-10-2010, 07:25 AM
It's an annoying extra few steps every time you need to send a proof though
If you're on a Mac, you could probably set up an Automator or AppleScript droplet that does it for you.

toby
04-10-2010, 09:38 PM
If you're on a Mac, you could probably set up an Automator or AppleScript droplet that does it for you.
If you were on a mac you wouldn't need to fix it - ? Is there no way to script in Win?

Qt works waaay better on mac than Win, incl. on 64bit snow leopard; makes me wonder if MS is withholding... they've done it before, and tried to suppress Qt too

Captain Obvious
04-11-2010, 12:39 AM
If you were on a mac you wouldn't need to fix it - ? Is there no way to script in Win?
If you save a video in QTPro on a Mac and view it in Windows, is the gamma farked up?

Any and all problems with QuickTime are solely Apple's fault. It's still a pretty good application, though. It's quick and easy, and actually lets you step frame by frame, loop, etc. I still haven't found a player for Windows that I think works better. And if you say "VLC," it just means you're an idiot! :thumbsup:

toby
04-11-2010, 12:56 AM
If you save a video in QTPro on a Mac and view it in Windows, is the gamma farked up?
Not sure - but if so, wouldn't that be because the gamma is different on each system?... or I'm just not getting it :help: If Qt is simply not correcting for windows, it would be too dark instead of too bright, wouldn't it?

Or is it that they set the display gamma too high, then just left it that way?

Captain Obvious
04-11-2010, 01:28 AM
I honestly don't know what QuickTime is doing. The problem is NOT that Mac and Windows has different gammas. Besides, Apple switched to 2.2 anyway...

Eugeny
04-11-2010, 03:26 AM
From Quicktime player go to Edit/Preferences/Quicktime Preferences/Advanced tab ...
Switch video to from "DirectX" to "Safe mode" ...
Restart QT ...
Now the same video will be darker ...
Unfortunately print screening in Win 7 didn't help at all to proof it, same milky QT movie print screened and pasted to Photoshop looks darker. But believe me this trick is working.

Larry_g1s
04-12-2010, 07:40 AM
It's quick and easy, and actually lets you step frame by frame...frame by frame is honestly what sets QT apart from anything else right now.


Or is it that they set the display gamma too high, then just left it that way?I believe this is the issue.


From Quicktime player go to Edit/Preferences/Quicktime Preferences/Advanced tab ...
Switch video to from "DirectX" to "Safe mode" ...
Restart QT ...Thanks Eugeny, that seemed to help give it the not so washed out look.

Captain Obvious
04-12-2010, 08:22 AM
If you want to stop QuickTime Player crashing your browser, you might also want to try to turn off automatic updates. I've had that cause instability in Windows quite a few times.

Andyjaggy
04-12-2010, 08:36 AM
It's not as simple as a gamma difference between windows and mac, besides they both run the same gamma now, shouldn't be an issue at all. I spent weeks researching this topic once and never could come to a satisfactory conclusion, explanation, or fix.

Being able to step frame by frame is the sole reason I use quicktime. Invaluable for client reviews.

biliousfrog
04-12-2010, 10:26 AM
From Quicktime player go to Edit/Preferences/Quicktime Preferences/Advanced tab ...
Switch video to from "DirectX" to "Safe mode" ...
Restart QT ...
Now the same video will be darker ...


I might be wrong but that just changes how quicktime displays the video not the video itself, open it on a different computer and the gamma will still be out unless that user has also changed their QT settings.

The way to fix the video is to open the .mov, go to "Window - Show Movie Properties" and click on the video track. Click on the "Visual Settings" tab and you'll see a "Transparency" pull down - set it to "Straight Alpha", close the window and save the video.

As Captain Obvious says it's QT Pro only but it's a very useful upgrade to have anyway.

Larry_g1s
04-12-2010, 10:34 AM
I might be wrong but that just changes how quicktime displays the video not the video itself, open it on a different computer and the gamma will still be out unless that user has also changed their QT settings.

The way to fix the video is to open the .mov, go to "Window - Show Movie Properties" and click on the video track. Click on the "Visual Settings" tab and you'll see a "Transparency" pull down - set it to "Straight Alpha", close the window and save the video.

As Captain Obvious says it's QT Pro only but it's a very useful upgrade to have anyway.How do you like QTpro on the x64 Win OS? I know it's still 32bit, but how well does it work on x64 machines?

Andyjaggy
04-12-2010, 10:39 AM
I might be wrong but that just changes how quicktime displays the video not the video itself, open it on a different computer and the gamma will still be out unless that user has also changed their QT settings.

The way to fix the video is to open the .mov, go to "Window - Show Movie Properties" and click on the video track. Click on the "Visual Settings" tab and you'll see a "Transparency" pull down - set it to "Straight Alpha", close the window and save the video.

As Captain Obvious says it's QT Pro only but it's a very useful upgrade to have anyway.

Except!.............. this makes your video play a bit chunky. At least in all the testing I have done, but it does indeed fix the black problem.

Captain Obvious
04-12-2010, 10:41 AM
How do you like QTpro on the x64 Win OS? I know it's still 32bit, but how well does it work on x64 machines?
I haven't had a problem with it.




Except!.............. this makes your video play a bit chunky. At least in all the testing I have done, but it does indeed fix the black problem.
I haven't had a problem with it. :P

biliousfrog
04-12-2010, 10:48 AM
It seems to work just as well as it ever did on x64 (aside from the fore-mentioned niggles).

I haven't had any problems with changing the transparency setting either, it seems to work a treat.

Exception
04-12-2010, 01:06 PM
And if you say "VLC," it just means you're an idiot! :thumbsup:

KMPlayer?

Not the simple route, but certainly better than Quirkytime.

Exception
04-12-2010, 01:09 PM
The way to fix the video is to open the .mov, go to "Window - Show Movie Properties" and click on the video track. Click on the "Visual Settings" tab and you'll see a "Transparency" pull down - set it to "Straight Alpha", close the window and save the video.

While that is -the- trick, it also forces it to use alpha, and it reduces play speed and introduces some serious choppyness on larger movies.
So, from one problem to the other.

I stopped using QT. H264 = great. But you have to be able to use it in production as well as have great technical abilities.

Byt the way, the gamma problem is not a QT player issue in itself. It's only an issue with the H264 codec. Switch to another (mpeg4 for instance), and it's gone.

Andyjaggy
04-12-2010, 01:13 PM
To make it even more confusing, it's dependent on which computer you are viewing the quicktime on. My computer at work suffers from the washed out blacks in quicktime, but my computer at home, with the exact same file shows the black perfectly. HA, figure that one out.

Andyjaggy
04-12-2010, 01:14 PM
I haven't had a problem with it.




I haven't had a problem with it. :P

Really?

There is noticeable chug when viewing a (alpha tricked) 720P quicktime file for me. Not terrible, but definitely there.

Andyjaggy
04-12-2010, 01:21 PM
Byt the way, the gamma problem is not a QT player issue in itself. It's only an issue with the H264 codec. Switch to another (mpeg4 for instance), and it's gone.

I still get the washed out blacks when using Mpeg4. Attached an image. Middle is animation codec, left is mpeg 4 and right is h264.

Silkrooster
04-12-2010, 11:45 PM
I still get the washed out blacks when using Mpeg4. Attached an image. Middle is animation codec, left is mpeg 4 and right is h264.

Maybe the mpeg codec threw out the black...:D

Fausto
04-13-2010, 05:28 AM
Has anyone tried Quicktime Alternative? The issues that Apple software introduce on Windows machines forced me to eliminate any and all their software, including the worst of the bunch, itunes. This seems to work for me, allowing me to view files, and also preview as needed inside Bridge without the cramps that come with installing Quicktime. I run Windows 7 Pro 64bit.

http://www.softpedia.com/get/Multimedia/Video/Video-Players/QuickTime-Alternative.shtml

biliousfrog
04-13-2010, 05:46 AM
I've used QT alternative in the past but had some issues with it last time I tried - probably on XP x64. It also doesn't have the little extras that QT Pro offers...certainly worth a look if you just want a QT player though.

Larry_g1s
04-13-2010, 08:13 AM
KMPlayer?

Not the simple route, but certainly better than Quirkytime.


Has anyone tried Quicktime Alternative? The issues that Apple software introduce on Windows machines forced me to eliminate any and all their software, including the worst of the bunch, itunes. This seems to work for me, allowing me to view files, and also preview as needed inside Bridge without the cramps that come with installing Quicktime. I run Windows 7 Pro 64bit.

http://www.softpedia.com/get/Multimedia/Video/Video-Players/QuickTime-Alternative.shtml

Do either of these allow for frame by frame? That is the real reason I use QT.

Red_Oddity
04-13-2010, 09:01 AM
KMPlayer does frame by frame yes, though by default it is mapped to F and Shift-F.

Larry_g1s
04-13-2010, 09:08 AM
KMPlayer does frame by frame yes, though by default it is mapped to F and Shift-F.Can one use the scrub bar to do it? Thanks for the reply.

Red_Oddity
04-13-2010, 10:52 AM
Can one use the scrub bar to do it? Thanks for the reply.
With most Avi files yes (if you set your playback options correctly)
With QT files it's hit and miss, i think it depends on what H264 decoder your use or which demuxer/filter.

Larry_g1s
04-13-2010, 11:05 AM
With most Avi files yes (if you set your playback options correctly)
With QT files it's hit and miss, i think it depends on what H264 decoder your use or which demuxer/filter.Gotcha, thanks. Maybe I'll download and check 'em out. But at least with this QT fix I'm happy with it.

JML
04-27-2010, 11:41 AM
Yes, the gamma issue is driving us nuts here too.

It affects pc and mac, It's worse with H264 but it also happens a little
bit with other codecs.
It's only quicktime messing it up. Load that same quicktime file in keynote or final cut and the gamma look correct there.

So to fix that, I made a preset in after effects to darken the footage to
compensate H264 washedout.. when I know it's going to be viewed in quicktime and saved in H264...
So sometimes I have a version for each, gamma 'fixed' mov for the client
to look at, and the non-corrected one that will go to final cut or keynote.

huge pain.

monovich
04-27-2010, 11:53 AM
doesn't encoding to x264 fix the gamma issue in quicktime instead of using the default h264 encoder? I know it does on the mac side, but I have't been able to figure out how to encode to x264 QT files on the PC side. On the mac side you just install the x264 QT codec and go, but on the PC side there wasn't a QT codec when I last checked.

I have the same performance hit when I change the alpha settings to fix the blacks with default h264. It definitely introduces a performance hit, but some computers may be fast enough to not show the hit. It gets worse and worse with 720p and 1080p.

Quicktime may be buggy in windows, but for me its indispensable. Frame by frame, easy switching from timecode to frames, both are important for me.

I've lived with the black playback bar in the browser for years, I can almost scrub by braille now by guessing where the bar is and clicking till I find it.

Andyjaggy
04-27-2010, 11:58 AM
Yeah I finally decided I would rather have my blacks dark and deal with a little chugging then have it smooth with washed out blacks. So I always do the alpha fix these days.

It is only quicktime player that does this, load the exact same file inside any video editor and the blacks will look fine.

I spent several hours once tracking down the PC X264 codec and figuring out how to use it. In the end it still had the washed out blacks, so don't bother. :)

I hate to think of how many hours I have spent trying to solve this problem. It only increases my hatred of Apple. Then again I love everything else about quicktime. :)

Andyjaggy
04-27-2010, 12:01 PM
Yes, the gamma issue is driving us nuts here too.

It affects pc and mac, It's worse with H264 but it also happens a little
bit with other codecs.
It's only quicktime messing it up. Load that same quicktime file in keynote or final cut and the gamma look correct there.

So to fix that, I made a preset in after effects to darken the footage to
compensate H264 washedout.. when I know it's going to be viewed in quicktime and saved in H264...
So sometimes I have a version for each, gamma 'fixed' mov for the client
to look at, and the non-corrected one that will go to final cut or keynote.

huge pain.


The main problem with that approach is not all computers suffer from the washed out blacks. My Dell PC at home does NOT wash out the blacks in quicktime, but all the machines I use at work do wash out the blacks.

So if your cranking your levels to compensate when someone views it on a machine that doesn't wash it out, it's going to be too dark. Ya just can't win.

I'm curious if anyone here as an ATI card? My Dell at home doesn't wash out the blacks, and it is the only computer I have used with an ATI card. I'm wondering if it's a Nvidia thing. Any other ATI users out there that can confirm QT not washing out blacks on their machines?

Rayek
04-27-2010, 02:20 PM
Aarghhh, Quicktime (player) - please let it die. Just use DJV Imaging, and you will have quicktime playback, frame by frame, flipbook player, convert image sequence to movies, EXR layer support (have not tried this - will check), batches, etcetera. And it works on Linux, Mac and Windows, best of all: open source and free. Better than many a commercial product. Best smooth image sequence player I know.

For 3d animation and fx it's become an essential app for me to have around.

http://djv.sourceforge.net/

...And a proper windows 64bit version. (just checked, no 64bit quicktime playback yet - probably in the works now)

JML
04-27-2010, 02:45 PM
The main problem with that approach is not all computers suffer from the washed out blacks. My Dell PC at home does NOT wash out the blacks in quicktime, but all the machines I use at work do wash out the blacks.
So if your cranking your levels to compensate when someone views it on a machine that doesn't wash it out, it's going to be too dark. Ya just can't win.
I'm curious if anyone here as an ATI card? My Dell at home doesn't wash out the blacks, and it is the only computer I have used with an ATI card. I'm wondering if it's a Nvidia thing. Any other ATI users out there that can confirm QT not washing out blacks on their machines?

Hmm.. interesting about the nvidia/ati thing, can't test here since all the computers I use at work or home have nvidia cards..
It's really fustrating when you work a lot on a shot and then the quicktime codec screws it..

The other thing that's annoying is when you export footage from after effects that's aspect ratio 1.2, and you play it in quicktime after,
it will not stretch it and show it instead square pixels..
but as a wmv file, it actually shows it correctly, using the 1.2 aspect ratio.
Quicktime really does not support aspect ratio or am I missing a step somewhere ?

Larry_g1s
04-27-2010, 02:55 PM
Aarghhh, Quicktime - please let it die. Just use DJV Imaging, and you will have quicktime playback, frame by frame, flipbook player, convert image sequence to movies, EXR layer support (have not tried this - will check), batches, etcetera. And it works on Linux, Mac and Windows, best of all: open source and free. Better than many a commercial product. Best smooth image sequence player I know.

For 3d animation and fx it's become an essential app for me to have around.

http://djv.sourceforge.net/

...And a proper windows 64bit version.Thanks, I'll check it out.

Rayek
04-27-2010, 03:08 PM
Before I forget to mention this, you will still need Quicktime installed to play stuff - djv is just the better player.