PDA

View Full Version : NormalMap Node Help



RayO3D
04-03-2010, 04:41 PM
Hey guys had a quick (hopefully) question.

I am trying to use a normal map I generated from ZBrush 3.5 in LightWave 9.6. I think I have everything setup properly but I am hitting a roadblock with NormalMap Node in Layout. When I apply the node to the surface and do a render, I am not seeing any trace of the normal map no matter how high I set the Amplitude. I have tried the same normal map in 3D Max and it seems to work fine there but I would prefer to render in LightWave just because I have a template scene I use for portfolio renders here and like the results more for final output.

Can anyone think of a reason why the normal map would not be generating any results at all on the render? I am not using a displacement map at this time but I wouldn't think that would be the issues (I could be wrong).

Any help or advice anyone could help would be appreciated.

Thanks,
Ray

zarti
04-03-2010, 04:49 PM
any screenshot of surface setup and render would help a bit more ...

RayO3D
04-03-2010, 11:24 PM
Yeah sorry about that. Was rushing out the door earlier. I have tried PSD, TGA, and TIF files just to see if it was something in the file and all got the same results.

Here is a render with the NormalMap node properties and the node layout.

Thanks again

meshpig
04-03-2010, 11:37 PM
For some reason if you assign the normal map in the bump channel as well (ie. in the surface editor bump) it works.

RayO3D
04-03-2010, 11:50 PM
Tried that and still no luck. It is just weird to me that I am not seeing any change even if it did not look right. I have even tried changing the UV mapping to spherical just to see if I can see something stretching and no luck.

probiner
04-04-2010, 02:12 AM
You are using GI Lightning right?

Activate "Use Bumps" in the GI panel. If that doesn't work, check everything one by one, that eventually they will show up :D

Cheers

Shiny_Mike
04-04-2010, 03:18 AM
weird stuff, but I'll try- A: maybe your object isn't subpatched? (hard angles in the render, if so, load it into modeler, hit tab, save as an .lwo - reload), B: maybe a problem with the "reference object" defined in the normal map node? C: ignore my input cause I dunno :)

OnlineRender
04-04-2010, 04:47 AM
normal maps dont work correctly for me" but I don't use nodes " I use TBnormal pluggin from flay but my subd in ZB -LW have to be atleast 2 or above for the map to sit correctly !

RebelHill
04-04-2010, 05:48 AM
its either enable bumps not being turned on in GI... or more likely the reference object, set it to none.

3dworks
04-04-2010, 05:49 AM
it works here, but only if you linked the normal map node to the surface bump channel for one time. after removing it and assigning it again to the normal channel it seems to work. not sure if it will be loaded as well after saving the LWO. (*)

seems that there is a bug in here and the nodal system needs to be 'triggered' first by feeding the bump channel.

cheers

markus

(*) edit: the normal map is still active after reloading the scene, here...

Philbert
04-04-2010, 02:46 PM
I've had no problems with normal maps, in fact 3D-Coat exports LWO models with the normal map node already connected, so I just load it up in layout and hit F9. I do recommend trying it with just normal lights though and seeing if that works. Even with the Use Bumps option normal maps don't always show up perfectly without real lights.

You can see in my current WIP here,. shown with and without normal maps, the back of the head is only radiosity and looks the same either way.

http://content.screencast.com/users/philnolan3d/folders/Jing/media/d4dd1957-77f8-4ec8-98fc-5f689fdb4900/2010-04-04_1645.png

RayO3D
04-04-2010, 03:32 PM
Thanks for the help so far. I had forgotten about Enable Bump in the GI tab and once I turned that on everything started working again. I am not sure about linking it to the Bump Channel and then back to Normal since I had done that a couple of times just trying to get results. I have some other parts of the model I am working on and I will try it with and without and see if that still needs to be done and post back.

I am pretty new to ZBrush (this is my first project in it) and I am having a hard time with the seams on the Normal Map being pretty harsh. Has one worked with that much and have some recommendation on settings to use in either the Normal Map or UV Map settings in ZB?

Thanks again for everyone's help.

RayO3D
04-12-2010, 08:34 PM
Ok while I think I am getting closer to a final solution I am still running into a few issues on the render. I am still fairly new to doing renders in LW so there is a good chance that I am missing something (as I was with the GI tab).

The first image attached is what I have found works pretty good for me so far from ZBrush 3.5 to Lightwave 9.6 for creating the normal map (of course once I get these problems hammered out that might change).

The second image is of a render using the NormalMap node. The normal map itself seems fine but there are very harsh seams where the UVs are. I have tried this same model and normal map in 3D Max 2009 and everything rendered perfectly there so it seems like there is some weirdness going on in the LW render. Also, it seems like the smoothing is not being applied with the NormalMap Node active (I did a test render without nodes and smoothing kicked back in).

The last image is using the NormalMapShader plugin and no nodes at all. Again, the normal map seems fine (I switched from the posted ZBrush settings to Adaptive only) but the smoothing group is not kicking in at all (or at least not as much as it should).

I am *really* trying to stick to LW for my renders because I like the final result more and I have already done several renders for my portfolio site in LW and want to stay consistent. I am not really particular on if I use the node option or the NormalMapShader just as long as I can still use my LightWave render setup so any advice would be appreciated.

Thanks again for the help so far

Sensei
04-13-2010, 11:07 AM
If you would attach scene, this issue would be probably solved week ago..

The first question, that came to my mind was: "why are you using Reference Object" in Normal Map node..
Second- do you have any nodes connected to Diffuse Shading and/or Material? You covered that part of Node Editor by rendered image, so I can't see these inputs..

Connecting something to Diffuse Shading and especially Material for 90% will discard Normal.

RayO3D
04-13-2010, 12:29 PM
Yeah sorry I didn't attach the scene earlier. I probably should have to make it easier.

The Reference Object thing was a mistake I made early on and have turned off since. I was using a Standard Material and then attaching it to the Surface but I have redone that in the attached scene. However, I am still seeing a problem with the smoothing.

I am also trying to keep the subdivision at level 1 right now for testing with the normal map on a lower polygon model.

Thanks for looking at this.

Sensei
04-13-2010, 01:11 PM
Make such test:

Turn off GI- your object is black, no direct lighting.
Change light type.. Distant type can't be used inside of geometry (only outside in exteriors). Basically they ignore light position and use only direction. Change it to point light or area. Adjust light intensity to 100%, so it'll start working.
For now you should see your normal map.

There are very badly looking transitions between body and arms. They were like this in ZBrush?

Normal mapping is always working with only direct lights and never with GI. Between all direct lights the all samples and normal vector there is done math -Dot Product( surface_normal, light_sample_direction ), this value is then multiplied by color and giving you Diffuse Shading.

I don't have NormalMapShader so I pressed No when LW asked whether to load it.. You can't mix normal map node together with normal map shader. With normal map node you should have better control.

Sensei
04-13-2010, 01:26 PM
Change Display & Render Sub-Patch from 1 to 3. Turn Invert Y in Normal Map on. After that I am getting nice render.
Set GI Intensity to 50% and direct light Intensity 50%.

RayO3D
04-13-2010, 01:46 PM
I turned Invert Y on and regenerated the normal without FlipG active and it looks much better.

The seams around the arms and other areas are a bigger issue. I cannot figure out why they show up on Lightwave. They do not appear in Max when I do a quick render or an active preview (I think I have the name for that wrong) so I don't think it is a problem with the normal map globally. Maybe there is something that needs to be done differently for LW... I really am not sure. This is all kind of new ground for me unfortunately.

Sensei
04-13-2010, 02:00 PM
I turned Invert Y on and regenerated the normal without FlipG active and it looks much better.

I guess so, Invert Y and Flip G is exactly the same thing.. ;)
As long as, it's R=>X, G=>Y, B=>Z. Because it could be mixed too, sometimes..
Having them both, completely discard other.



The seams around the arms and other areas are a bigger issue. I cannot figure out why they show up on Lightwave.

I told you already- Object's Properties > Sub-Patch Level 3..

That's how he should looks like??

RayO3D
04-13-2010, 02:59 PM
Thanks for your help. I finally got what I am looking for. I kind of wish I could still use GI but I can live without that so not a huge deal. I also changed one last thing in ZB and that is I turned SwitchRG off and FlipG on and got exactly what I wanted.

Thanks again.

Sensei
04-13-2010, 03:01 PM
Of course you can use GI! But not entirely exclusively.. :)

I have made animation of your guy.. It's like above image, with GI 50%, and Direct Lights 50%..

RayO3D
04-13-2010, 03:10 PM
Oops... yeah I got it now. This is what happens when I don't spend enough time actually making renders.

Thanks again