PDA

View Full Version : VT3 audio versus Windows audio



kgwilso
09-09-2003, 02:09 PM
I have read through the other posts and have found similar errors, but nothing exactly like what I am experiencing.



When I boot up the PC (Windows 2000), the audio behaves normally. I can run Media Player, SF's Acid, Internet Explorer... all programs with audio work. I can use the Windows audio icon in the taskbar, and am able to adjust the volume.

When I load Toaster (VT3), the Toaster's audio mixer takes control of my speakers, as expected. I can adjust the volume through the master volume slider.

When I close down Toaster, control is not restored to the Windows volume controller. The audio is very, very quiet (even though my studio monitors are hissing as if they are cranked full). It's almost as if VT3 still has control of the audio levels.

This problem occured after I upgraded to VT3. When I was using VT2, I never experienced this.

I have tried to kill winrtme.exe, but the problem does not go away. The only way to return audio control to my speakers is by restarting the computer.

Has anyone been able to fix this?

Thanks!

Ken

pfrench
09-15-2003, 12:36 PM
This is one of those situations where we basically had to vote on what the behavior of windows audio volume would be. There are basically two levels of control for Windows audio volume on VT2/VT3 systems. The overriding control is within VT3, because some of our live production people could get "you've got mail" sounds in the middle of their productions. So we determined it best that if somebody turns off windows audio in the VT3 audio mixer, that it stays off no matter how loud windows audio devices think they should be.

However, since WinRTME is maintaining the "switcher states" even after you exit VT3, the audio volumes remain.

Killing WinRTME should be enough. When it starts it "erases the blackboard." Note however it won't restart until the Windows audio device has left it alone for about ten seconds.