View Full Version : Graph editor object dissolve keyframes not saved.

03-25-2010, 03:44 AM
When I set object dissolve key-frames in graph editor, they magically disappear after closing the project and opening the scene up again. Does anyone know why this is? I've even tried saving all objects before quitting too.

I'm using Lightwave3D 9.6 on a mac.

03-25-2010, 01:32 PM
Object dissolve properties/keyframes are not stored with the Object file, only with the Scene file. I assume you've answered "Yes" when asked if you want to save the Scene file before closing it. If you're still having trouble, try saving as a new Scene file name.

03-27-2010, 02:25 AM
Here is exactly what I am doing.
Open the scene which has many objects that must pop up over time. Each object has already got a key-frame set for Dissolve at arbitrary frames in the time-line. All these values are currently set to 0 (no Dissolve).

I open the graph editor.
Now, with all the Dissolve channels selected (loaded from a saved selection), I use the Add Key-frame tool to create a new Key-frame for every object's Dissolve channel before the existing Key-frame with one click.
While still selected, I type in a value of 100% (dissolved). I then use the Move Key tool to drag these keys to the right until all the keys are set at the frame before the original 0% key (with Allow Key Passthrough unchecked) and set the keys to linear. I check the scene and see that the editing in Graph Editor has indeed taken place. I see that it has.

So what I have now is:
All the objects that I have key-framed will pop into view at their respective key-frames over time. Brilliant!

Next thing I do is save the scene and clear it from layout.

Now here comes the magic! I open the scene again and can see that the key-frames are not saved. I go into Graph Editor to confirm this and voila, no key-frames excepting the ones that were already there the first time before editing.

What is going on?

I have tried trashing the config files and even re-installing Lightwave.

I am on 9.6 on Mac OS X 10.5.8.

03-27-2010, 02:54 PM
Hmmm... Definitely sounds like you're doing everything right. I have several scenes in which I've used dissolve with no problem, but I can identify with your frustration, because I've had other little "gotchas" get to me. Perhaps you should try setting up a separate, simple, single-object scene, with as little "moving" of keyframes as possible, and try to determine where your bug is by process of elimination.