PDA

View Full Version : Updated MacUB DPKit



dpont
03-01-2010, 08:13 AM
I want to thank Michael Wolf
for the last Universal Binary update of DP Kit package,
http://pagesperso-orange.fr/dpont/plugins/nodes/Additionnal_Nodes_2.html

All fixes, changes and node additions listed
in the readme file.

Regards,
Denis.

boarslight
03-01-2010, 09:18 AM
very much appreciated!

JeffrySG
03-01-2010, 11:26 AM
Cheers guys!!

3dworks
03-01-2010, 12:10 PM
thank you!

toby
03-02-2010, 11:50 PM
Nice, thanks Denis and Michael!

dpont
03-03-2010, 05:06 AM
If you need some improvements in Light Group node,
like a choice between different Diffusion and Specularity
models, this has been added today and fastly ported
to UB version by Michael,
download again,
http://pagesperso-orange.fr/dpont/plugins/nodes/Additionnal_Nodes_2.html

Denis.

Scazzino
03-03-2010, 12:08 PM
Thanks Denis & Michael! Much appreciated! :beerchug:

jwiede
03-07-2010, 05:12 PM
Great! Thanks Denis & Mike!

Yamba
03-08-2010, 05:57 AM
As per usual, many many thanks for your efforts.

Shane
MacPro, Quad-Core 2.8Ghz, 12Gb Ram, 10.5.8, nVidia GeForce 8800GT

3dworks
03-12-2010, 02:50 PM
when using the dpkit 'blur' and 'fast blur' nodes, i'm getting a consistent crash or hang (beachball) on my mac. i've setup a very simple network: connected 'color' from the 'color layer' node to those nodes and then linked to color on output. i'm previewing the nodes with viper.

can you reproduce the problem or do you need a sample scene?

specs: OSX 10.6.2 with LW 9.6.0, latest dp kit UB, macpro 2 x 4 core cpu (nehalem), 12G RAM, nvidia GTX 285.

cheers

markus

dpont
03-12-2010, 03:37 PM
It works here on PC (not Viper),
with an image map or procedural in Layer node,
what node editor are using, Image or Pixel Filter?
Posting a simple scene could help,
but not sure to be able to fix it,
Blur & Fast Blur are mainly to be used
with stored Buffers.

Denis.

Lightwolf
03-12-2010, 04:25 PM
can you reproduce the problem or do you need a sample scene?

I suppose the best way would be to send a sample scene with steps to Denis. If he can't reproduce then he can forward it to me.

Cheers,
Mike

3dworks
03-13-2010, 04:39 AM
thanks for caring! please open the attached scene, open surface editor and the nodes panel for the people_rvi... object. simply try to connect layer color to the fast blur node, then the color output to color on the object node... it crashes immediately here. same happens with 'blur' node, but not immediately, just when you render.

would be useful to have this working...

cheers

markus

dpont
03-13-2010, 10:29 AM
I spoke above of node editor contex because,
Blur and Fast blur are a part of DP Filter
so exclusively for using them in the Image Filter
node editor or a second
instance of Pixel Filter node editor,
because stricly pixel based,
same limitation for almost all nodes listed in
DP Kit 'processing' tab (know this could
cause confusion).
So no way to get them working in the
LW Surface node editor and no way to solve
this in the plugin.

The Image Filter node editor can be used
as pre-processing filter in the Image node editor
with full compatibility with Blur, Fast blur nodes etc..
Add Image Filter node to the image or its
instance, use the Render Buffer node color output
and plug it in one of this node.
You can then use the filtered image to
map a surface even as a texture layer.

Denis.

3dworks
03-13-2010, 03:24 PM
thanks denis, for the clear explanation and tips, i will go the way of pre-processing then!

cheers

markus