PDA

View Full Version : LightWave 3D v9.6.1 Development Update - 04 Feb 2010 - Discussion Thread



Chuck
02-04-2010, 03:12 PM
Hi, LightWavers! :)

Last week the team gathered in San Antonio, and had a very productive set of meetings and work sessions. This week everyone is back home and hard at work on prepping the next builds of the LightWave 3D projects in development. The managers are evaluating the status of each product to determine what else is needed in order to issue the next builds. Below is the latest news on the LightWave 3D v9.6.1 work.

LightWave 3D v9.6.1 / Cocoa Conversion: Beginning last week and continuing this week, the team has been working on a thorough evaluation of Cocoa status, both from the standpoint of engineering findings and user feedback. There are a lot of issues that have been addressed in the code since the previous build, but still quite a number remaining, and the engineering staff has produced a comprehensive report on those, with solutions planned for them as well in most cases. Work on implementing proposed solutions and on designing solutions for the remaining issues is in progress.

Subject of course to change based on our unit testing, we hope to get the next build of LightWave v9.6.1 out within the next few working days. The build will include the Cocoa changes and fixes implemented to date. Work has gone into making the text handling and the UI much more stable, in some cases revising our previous work in the wake of an Apple advisory that certain issues should be handled directly via long-standing lower level APIs that are still supported, rather than attempting handling at the Cocoa level. The team has also put in a lot of work to improve behavior and stability of the OpenGL preview rendering system on the Mac side.

That's it for now!


Please Keep Those Bug Reports Coming: Getting in reports on any bugs you may have encountered but not yet reported is very important. Don't forget to include steps and content, as they are needed to insure that we can duplicate your bug properly and get it fixed. For those of you who need a refresher as to how to report bugs, check this link:

Instructions for Bug Report and Feature Request Database (http://www.newtek.com/forums/showthread.php?t=73227)