View Full Version : Dropped frames - Help me before I RAGE against my machine.

09-05-2003, 04:32 PM
Hey all:

First, I'm having touble capturing video as .rtv or .avi(DV encoder) without getting dropped frames. This seems to be an intermittent problem and is really putting a crimp in my production schedule. Here's my computer specs:

VT(2): Build 3890
OS: Windows XP Pro version 2002 service Pack 1
MB: Super Micro P4DC6+
includes onboard Adaptec AIC-7899 Ultra 160 PCI SCSI Card
CPU: Dual 2.4GHz Xeon
RAM: 1.0 GB
Video Raid: Medea RTRX 460 GB with 388GB free space at time of
attempted captures.
Video Card: NVIDIA GeForce4 Ti 4600
Monitors: 2 NEC LCD1850X monitors
Chassis: AMS CF-481
DVD/CD: Sony DRU-500AX

That should be more than enough specs to give you and an understanding of my system.

Well, I sat down today to capture some footage about an hour and 17mins. in length. I setup the following VT[2] modules: TVision, Switcher, Audio Mixer, and Capture. I have an input to Channel 1 YC on the BOB and an audio input to Channel 3. I made sure the switcher was program out YC. So far so good. I set the capture format to RTV and set record to a folder on my video raid. I adjusted audio levels and than began recording. It recorded about a minute of video and than reported a dropped frame. This was with the drop frame box checked in the options menu. I unchecked that box. Why? I was desperate. I tried again and this time got the message wintrme...(something I can't remember exactly what it was) Well after about an hour of trying different trouble shooting ideas: turning off the computer completely, ending the winrtme.exe in the task manager(more on this later), trying the DV encoder, and checking my drive speed I headed to the NewTek discussion board to release my RAGE!!

While writing my RAGE thread I began to cool off. I decided to give the toaster one more try before letting NewTek have it. This is about a half hour since my last attempt. I sat down and opened up the module configuration that I had saved to do the capture. I did everything the same except for one thing and I did this by mistake. On the switcher I highlighted only the Main bus under my YC input, Usually I highlight all three buses. Why? I don't know. In fact the only high light on the switcher this time was the YC on Main bus. And behold I captured an hour and seventeen minutes worth of RTV without a single dropped frame. Hmmm.... Could this have been the problem? If it's not and it does this intermittently whenever it decides to drive me crazy I shall have to write that RAGE thread.

Oh, yeah. In reference to the winrtme.exe thing above. I've gone to task manager many times and ended it. Well, it never seems to end. I've opened task manager while the VT[2] in running and there it is again. This is after having ended it in task manager before opening the Toaster. It really doesn't seem to do anything. Perhaps I'm ending it wrong.

Any help is appreciated before I RAGE against the machine.


09-05-2003, 04:46 PM
Some reasons for dropped Frames/
-Scsi stripe faulty, check Disk Manager.
-Drive Indexing turned on. RT click the Video Drive, choose properties and turn off drive Indexing.

Actually here's a post at Safe Harbor that addresses your problem.

There are 3-4 Options in Pref for recording.
Check them out.

The thread above should help.
T2 will capture a stream on a decent single IDE drive if all is config'ed correctly. So with a monster system like yours, any dropped frames are most likely not the T2's fault.

Good LucK

Keep posting


09-05-2003, 05:05 PM

I forgot to say that I had already turned off the drive indexing. I had learned that from others in the forum. I'm going to contact Medea and see if they have any ideas.

A very related issue that I have occasionally happens when editing in TED. Sometimes my raid LEDs will flash rapidly even though I'm not doing anything in my project. When I open a project the LEDs flash as the raid loads the information. This is normal. However, sometimes the raid LEDs will flash very rapidly when I'm not doing anything in the project and it appear to be just my raid and not the system drive. I've opened task manager and no other applications are running in the background except the T[2]. When I close out the project and exit
the T[2] the LEDs on my raid stop. It happens intermittently and only when working with the T[2].

Thanks and I'll try you link.


PS - any ideas about the winrtme.exe question

09-05-2003, 05:38 PM
Here is what I learned at the safe harbor link.

1) Make sure the preview is set to black on the switcher

In preferences:


2) BG processing while recording to [Disabled]
3) Minimize PCI Bandwidth usage to [Enabled]
4) Disable PGM out while recording to [Enabled]

My settings at the time of my successful capture were:

BG processing while recording [Enabled]
Minimize PCI Bandwidth usage [Enabled]
Disable PGM out while recording [Disabled]

I'll try the suggested settings if I have the problem again.

Thanks, Paul

PS - I would still like an answer to the winrtme.exe qeustion.

09-05-2003, 06:51 PM
winrtme.exe starts with windows and is neccessary while running the T2(3).
The only time it will shut down and not show or reappear in task manager is if T2 is not running or not restarted.

09-05-2003, 06:55 PM
Thanks for answering that question Jim.


Paul Lara
09-06-2003, 05:35 AM
Originally posted by INOV8Pro
Sometimes my raid LEDs will flash rapidly even though I'm not doing anything in my project.

You may not be doing anything in your project, but VT is: it is performing a background render of layers it suspects your system cannot play back in real-time.

So relax, it's not a virus eating up your machine, but rather VT transparently compacting complex portions of your show.

09-06-2003, 01:21 PM
Thanks Paul, looks liked I'll have to get a faster system. :)


Pete Draves
09-06-2003, 05:04 PM
I have the same motherboard and memory but with dual 2.2gig xeons. My system is working fine 3 streams
Your machine is faster but
I would look at the raid media has had som dificulties
with theri sustained speeds
Call their tech support.
with win 2000 sp3 (seems better than xp)


09-07-2003, 06:29 AM
Media's were reported to SUCK many times before
on the toasternt board.
I would give a serious look at your array and go SCSI.
Thats the place I would start and stay.
Dual Xeons at that speed should not be the issue unless
there is something wrong with the system like a weak
power supply. That can cause issues as well.

PS, Media swore to its users that the drive would do
XX MB/sec and after many long tests with disk tests
it just was not so. You need something that can
do continous rate with little to no spikes.
Thats what SCSI give you.


Pete Draves
09-07-2003, 06:59 AM
some people ha skimped on purchasing the expensive powersupply for the supermicro xeon board. If you have this problem there is an inexpensive answer.

There is an adaper available from motherboard express that converts a standard hard drive popwerplug to the 8 pin cpu extra powerplug on the motherboard.
This 12 volt plug is to keep the internal power runs from starving the cpus.
the other 4 pim plug that is on every p4 supply is to keep the chipset from being starved.

The adapter is very inexpensive and it works.

It is something to consider.
BTW I used to be a beta tester for media, and I agree with bobt
they suk.
the three ware cards work but don't have as high a bandwidth as scsi but they do work.


09-07-2003, 07:51 AM
i had same troubles on a single p4 machine - what i noticed was that my last drive in the raid ( 4 seagate 18gb scsi) was acting really weird - you check this using the performance graphs for your machine in the control settings - you can select what you want to graph and see the actual reads and writes to disk - the drive was very slow and the other 3 were okay - i relplaced that drive and the problem stayed - always - even swapping the order of the drives in the system - then replaced the scsi connector - or by wiggling it around the problem went away. i had been getting dropped frame and winrtime errors exactly like what you described.:)

09-07-2003, 01:29 PM
Correct me if I'm wrong, but it's Medea and not Media and correct me if I'm wrong again but my RTRX is U160 SCSI

I read the board for months before I built my machine and I heard nothing but good remarks about Medea. True, I choose to go with a raid three option that will reduce some speed compared to raid Zero, but I believe I will have more than enough speed when I go dual channel and add another 460 gigs to my RAID. At least I hope.

As for my Power Supply it is a Turbo-Cool 510 XE I bought it from PC Power & Cooloing. it had the 4, 8, and 20 pin connectors and cost about $199.00. It wasn't easy to find. Though I don't believe this to be a problem I would appreciate if someone could explain a means of testing a powersupply. www.pcpowercooling.com

Hruffin 3 - I'm going to try your performance graph test. I used to be a Canopus user and borrowed the REX tester from my other computer. I tested the read and write speeds of my Medea raid and it went off the scale. It said 68MB/sec. on the write speed. I'm not sure if this was the actual speed or the Maximum the the REX test could handle.

And Yes I will be calling Medea's tech support all this week. I spent a lot of mony on this raid and it better perform.

Please keep posting.


Pete Draves
09-07-2003, 02:06 PM
Medea - one of the gorgons from greek mythology
a raid with many heads!!!

Medea raids are ide inside adapted to scsi interface
not all commands are available

The 3-ware cards are much better than medea and scsi is allegedly even better

BTW every scsi raid we have built has had drives die within 6 months regardless of manufactuer .

western digital 7200 ata100 have been having long lives
very long lives.

09-07-2003, 03:17 PM
Thanks Pete:

I'll have to brush up on my Greek mythology. Thanks for the clarification of Medea adaption from SCSI to IDE.

I'm hoping that the trouble I'm having was with my settings. I now know that the first few times I tried to capture my settings were wrong and it did finally capture an hour and seventeen minutes of RTV no problem once my settings were correct.

I'll look into 3-Ware and true SCSI.


09-23-2003, 08:09 PM
I've had a problem with some RAID systems whether SCSI or IDe based where one drive in the group is flaky but not dead. The result is that intermittantly this particular drive will require many retries before it can receive the data. Over all the raid performance as a whole may be 80 - 100 megs per second. But the one drive's sporadic performance will cause the kinds of video dropping you describe. Then on the next day due to God know what (lower temperature, higher voltage, less bus activity who knows) the drive works fine and all is well. Fortunately in the two times I have had to trouble shoot this, the drive eventually got bad enough that its flakyness was detectable with ontrack's drive tools. Try substituting one drive in your Array and rotate the substitute around. Having one extra drive on hand is probably a good idea anyway.