PDA

View Full Version : Noisy image maps



skywalker113
02-01-2010, 07:15 PM
I've created a armored troll, and got some rusty metal textures from the internet and used them for the texture of the armor. When I play a renderd animation, the image maps seems to be very noisy. The surfaces with no image maps are fine though.

Thanks

JeffrySG
02-01-2010, 08:16 PM
Could it be the MIP setting on the image texture? What do you have it set to now?

skywalker113
02-01-2010, 10:35 PM
Heres the settings

jin choung
02-01-2010, 11:34 PM
depending on the distance from camera, noise textures can be too fine for the resolution.

anything that's high frequency can end up looking just noisy and is basically the equivalent of looking at fine dots through a screen door or previous NTSC restrictions from wearing stripes.

you might have to either make the noise larger and/or less visible.

jin

skywalker113
02-02-2010, 02:55 AM
How do I control the noise size?

jin choung
02-02-2010, 03:23 AM
How do I control the noise size?

If you're using texture images you can't in lw. Emidufy the texture in Photoshop (a simple blur is a primitive solution but it'll work).

Use otherwise, repainting the texture or rescaling it in Photoshop would be the ideal way.

Try blur first and see if it helps.

Jin

Danner
02-02-2010, 06:53 AM
play around with mip map quality and mip map strenght

skywalker113
02-02-2010, 06:10 PM
I replaced the textures with this super small image and there still seems to be a noise effect.

jin choung
02-02-2010, 06:29 PM
can you post a render? there's a limit to what we can diagnose from "noise effect".

: )

jin

skywalker113
02-02-2010, 09:16 PM
Heres a image sequence

toby
02-02-2010, 10:44 PM
Looks like you don't have anti-aliasing on.

JonW
02-03-2010, 12:43 AM
Up the Mipmap stretch to 5 or so, experiment!

In PS pre blur the texture.

Up the AA passes. You are going to have to do it at a higher number for an animation. 9 or 17 passes (double plus one, 5 ,9, 17, 33 etc. is best)

Sampling pattern “Fixed”

It may be better to render at 1440 x 960 with say 5 passes rather than 720 x 480 with 17 passes, & then reduce in post to 720 x 480. The right combination of double the size & less passes can get rid of a lot of noise & flickering.

Once you compress it, that also knocks a bit more off.

jin choung
02-03-2010, 12:59 AM
gah...

that doesn't look normal at all... wtf....?

honestly i've never seen that effect before on a render.... especially on something that seems so reasonably simple....

do you have radiosity or ambient occlusion or some other crazy kind of shader action going on?

try killing the surface that you're using and just make a new one and assign it to the helmet and try adding the texture to that new surface.

also, try turning off ray tracing AND turning off shadow maps.

play around with it because that's definitely not normal and i'm doubtful that's coming from the texture now...

if you can't figure it out, upload the model with the textures (or just a part that is flickering and its texture) and someone here will take a look at it for you - if no one else, i will.

luck.

jin

Mr Rid
02-03-2010, 02:28 AM
Am curious if you render with bump maps disabled.

Danner
02-03-2010, 12:49 PM
looks odd, like the bump map is moving upwards, antialias does seem too low too.

skywalker113
02-04-2010, 07:43 PM
I was able to solve the problem by making the mipmap values higher, and getting rid of the bumps.

Thanks!

Mr Rid
02-05-2010, 02:44 AM
I was able to solve the problem by making the mipmap values higher, and getting rid of the bumps.

Thanks!

Told ya. :)