PDA

View Full Version : SCSI delayed write error



David
09-05-2003, 06:47 AM
One of my SCSI drives keeps saying it has a delayed write failure. I have a four disk striped set, disk 0 seems to always fail. I downloaded seatools and the disk passes the short test sequentally and individually. I am going to change the SCSI twisted cable and try again. The drives are all hot swap 80 pin drive with 68 pin adapters on them. After I re-activate the drive it will work for 5-10 min then fail locking up my toaster. Some times the toaster will say unable to write to cache.

If anyone has had the same problem or knows a solution let me know.

Thanks!!!

David
09-05-2003, 06:59 AM
I dissabled the write caching on all the disks in the stripe set as stated in the article below and I no longer get the error but is this the best settting for toaster? And am I loosing performance?



http://support.microsoft.com/defaul...kb;en-us;330174


"Delayed Write Failed" Error Message When You Manage Files in Windows XP
The information in this article applies to:
Microsoft Windows XP Professional
Microsoft Windows XP Home Edition

This article was previously published under Q330174
SYMPTOMS
When you save or move documents or during general file-management activities in Windows XP, you may intermittently receive "Delayed Write Failed" error messages.

CAUSE

This issue may be caused if any of the following conditions exist:
The "Enable write caching on the disk" feature for your disk is turned on.
Your Ultra Direct Memory Access (UDMA) hard disk controller is configured in either of the following ways:
You are using a 40-wire connector cable to connect the UDMA drive to the controller instead of the required 80-wire, 40-pin cable.
Your BIOS settings are configured to force faster UDMA modes.

RESOLUTION

To resolve this issue:
Make sure that your UDMA hard disk controller is using an 80-wire, 40-pin cable. For information about how to do so, view the documentation that is included with your computer, or contact your UDMA hard disk controller manufacturer. Test to determine if the issue is resolved. If the issue is resolved, do not complete the remaining steps. If the issue is not resolved, go to the next step.
Warning Do not change your BIOS settings unless you are very familiar with all the effects of changing BIOS settings.

Make sure that your BIOS settings are not configured to force faster UDMA modes. For information about how to do so, view the documentation that is included with your computer, or contact your computer manufacturer. Test to determine if the issue is resolved. If the issue is resolved, do not complete the remaining steps. If the issue is not resolved, go to the next step.
Turn off the "Enable write caching on the disk" feature:

Note If you turn off the "Enable write caching on the disk" feature, your disk performance may decrease. Because of this, you may want to monitor system performance after you complete the following procedure.
In Windows Explorer, right-click your hard-disk, and then click Properties.
Click the Hardware tab.
Click the hard disk, and then click Properties.
Click the Policies tab.
Click to clear the Enable write caching on the disk check box, and then click OK two times.
Repeat steps c-e for each hard disk that is installed in your computer.
MORE INFORMATION
When you start your computer, the BIOS checks the system-specific settings that are stored in the complementary metal-oxide semiconductor (CMOS) chip. You can modify these settings as your computer or your needs change.

David
09-21-2003, 10:15 PM
It was my SCSI Cable, I replaced the SCSI cabke and system works fine now. Thanks for the help!!!!!!!!!!!!!!! Sure

This forum was no help at all!!!!!!!!!!!!!!!