View Full Version : SnowLeopard>File Requester>2ndMonitor?!?

01-22-2010, 02:33 PM
Any time I open a scene/model/image/etc. my file requesters always open on my 2nd monitor. It's driving me up a wall.. I've tried unplugging my second monitor, letting the mac switch to me just having one, opening things, then pluggin back in my second. I've swapped the cables in the back of the Macpro and software swapped which monitor is primary. Nothing...

My main monitor has the Apple bar and dock in it.. Is there a place to set where file requesters default to?

It happens in other programs too.. AE, PS, and some others.. It all started when I upgrades some months ago, but I can't take it anymore lol.

Thanks for any ideas you guys have.

Edit: don't even get me started about every program basically forgetting where you last loaded/saved/exported... You know, you save as.. then want to save as.. again figure it would jump right to where you saved last.. no.. almost always the damn default root.

01-22-2010, 04:50 PM
I see what you mean, I had not noticed this because I do use my second display for many menus and palette items.

I did find a cure. Turn your Mac off, disconnect the monitor cable, if you use an adapter remove that. Then start your Mac back up and load Lightwave, open up any requesters that your having problems with once (load... Save...) then quite layout, turn off the Mac again, hook the monitor back up, turn the machine back on and load Lightwave.

Your requesters will now open on the main monitor again. The problem is the first time you drag them to the second monitor again, they will stick there again and you will need to repeat the steps above to fix it.

It's not enough to just turn the monitor off because the Mac still thinks it's there if the cable is hooked up same thing if the adapter is hooked up.

Good luck!

01-23-2010, 08:27 AM
It could be a bug in the OS...have you tried reducing the screen resolution of the second monitor?

It's something I read on the Apple help forums but I'm not sure if it'll work or not.


01-25-2010, 04:44 PM
Thanks for the tip Sublimationman! This has been really bugging me as well. AE, LW, and a lot of other apps are screwing up as well. Like 4Dartist said, didn't see this behaviour till a Snow Leopard update a month or two ago. Will give your solution a try in the morning!