View Full Version : What happened to the teapot?

12-27-2009, 11:36 AM
I am reading the Modeler Manual (yes, some people do read it) and have come across the story about the teapot (pg 108 of the pdf low res). It says that the tool is in the Menu (create>primitives>more) but I don't see it. The story is also in the Help Menu in the top toolbar and in the Help Menu to the left of the Viewports. Not a big deal, by any means, just curious about what happened to it! Does anybody know? ;)

12-27-2009, 12:14 PM
When you say you don't "see" it, do you mean it doesn't show up on the Primitives > More drop-down menu, or that once you select it from the drop-down menu that you can't see it in the viewport? If the latter, you may have your viewport windows set too large. Press "a" to zoom-to-fit.

If the former, what version of LightWave do you have?

12-27-2009, 12:20 PM
Yes, I mean I don't see it in the menu, doesn't offer it as a choice to select. I have version 9.6 on my Mac.

12-27-2009, 03:08 PM
Hmmm, don't know if it's the same for Macs, but for PCs, if you've got the Studio Menu Layout Preset selected for your Menus Configuration (F10), the Teapot isn't an option in Primitives. It only shows up on the Default Preset.

12-27-2009, 03:24 PM
Well, I've checked that out and am using Default Menus. You did give me an idea though. I checked the "Configure Keys" list to see if the teapot tool shows up there and can not find it.

Oh well, don't know why but it seems like it has been removed from this version for Mac.
Thank you for your input, I guess I'll have to live without it unless somebody else knows the answer to this mystery!

12-27-2009, 03:49 PM
Alt/F10/search for teapot, drag to RHS where needed in menus

12-27-2009, 04:43 PM
Yes, that's how I searched and the response was "Command search string not found."
I'm not sure what you mean by "RHS" ??

12-27-2009, 05:19 PM
"right hand side" I'd guess -

Here's what I have, but it's for lw CFM, not UB. 'Teapot.p' is CFM, UB would be 'Teapot.plugin'. I guess they didn't bother to convert it for UB.

12-27-2009, 05:44 PM
Hi, thank you for the file, but I'm not sure how to get it into Lightwave ?? I am using the UB version of Lightwave so you may be right. Maybe they didn't convert for it?

The mystery of what happened to the Teapot continues . . . !!

12-27-2009, 05:58 PM
I didn't find a Teapot.plugin on my system, if you don't find one on yours then don't bother using UB, just run CFM (it's probably there already), make a teapot then save it for re-use in UB -

To add plugins go to the Utilities, press 'add plugins' and browse.

12-27-2009, 06:38 PM
I don't have a Mac but my v9.6 has the "teapot" in that same drop-down menu. Got to go now ... it's teatime ;)

12-27-2009, 06:57 PM
Use Utilities > Edit Plug-Ins, Scan Directory button on entire LW directory.
Then use Edit > Edit Menu Layout, press Search button and enter tea and press enter/OK.. Then drag-n-drop what is found wherever you want from left list to right list.

12-27-2009, 07:16 PM
Hello and thank you for your suggestion. I did what you said with Plug-Ins and did the Search in the Menu Layout Editor again and still no Teapot ??
Do you think that the problem is a missing plug-in? There were no instructions in the Manuals about installing plug-ins and the PDF Manual acts as if it is something that is supposed to be there ??

I'm beginning to wonder if I'll ever find the missing teapot!!

12-27-2009, 07:33 PM
Looks like they didn't compile a 64bit one either

12-27-2009, 07:39 PM
This may sound strange but worth a try:

Open up modeler and drop that menu down. Then select any primitive on that drop down menu to open anything. After doing that, restart both modeler and layout.

See if the restart will give lightwave a kick. Maybe that'll do something.

12-27-2009, 07:57 PM
OK, that was worth a try but still no darned teapot !!

12-27-2009, 08:11 PM
OK, that was worth a try but still no darned teapot !!

Nobody use it anyway, it doesn't have any parameters.. ;)
Same effect would have sending you LWO through Internet.

12-27-2009, 08:33 PM
OK, that was worth a try but still no darned teapot !!

wait... hold on... I'm channeling Neo ... "there is no teapot..."

Did you miss my post about running the CFM lw? That's all you have to do.

12-27-2009, 09:03 PM
Hi! Yes, I did get the post but don't quite understand what CFM lw is. Is it the version that runs on Power PC Macs? If so, how do I find it on my Intel Mac?

Here is the reason why I am on the Teapot quest. This is what the manual says about it:
You’ve probably never heard of Martin Newell, but his work is as ubiquitous as the Mona Lisa. In 1974, the world of computer graphics imagery was being advanced at the University of Utah. When Mr. Newell built a 3D replica of his wife’s tea set, he unwittingly fashioned an icon for the industry that would persist for more than three decades.
Dubbed the Utah Teapot, it was both beautiful in form and utilitarian in function. Its smooth curves and simple design made it an ideal candidate for testing new surface shading algorithms. By the time 3D Modeling and animation software reached the personal computer, the Utah Teapot had already become an industry standard.
The attributes that made this object so useful in the 70s still stand today. The teapot is the perfect stand-in object and is useful for testing lights and textures in your scene. Best of all, its low polygon count means that it will render quickly, even on older computers.
You can generate the Utah Teapot by simply clicking the Teapot button (Create > Primitives > More).
NOTE: The object will be generated with two principal surfaces: TeapotChrome and TeapotGaps.
Take pride when you invoke the Teapot primitive. For when you do so, you become a part of CGI history and join the ranks of those whose use of 3D has changed the world.

So, I guess it's the nostalgia that makes the quest seem worthy!

12-27-2009, 09:06 PM
What this tool generates is attached..

12-27-2009, 09:14 PM
Yes it's the PowerPC version. It should be on your install cd, or you can download it from 'my downloads' of the registration page

12-28-2009, 01:11 AM
When I needed the teapot a while back, I ended up using LW on a PC to get it (at that time, I had a PC to do it with; now I don't - but I did save the teapot as an object should I ever need it again).

12-28-2009, 03:38 AM
u can always try reloading ur plugins. that might help if its not working. or not there at all.

12-28-2009, 03:36 PM
Hi toby, I checked the CFM version on my Mac and don't see it there either.

So, I think, as toby says, and the consensus is, that there is no Teapot after all. Oh so sad . . .

Thank You Sensei for the lwo download. At least I'll have it as an object and can keep it for nostalgia that way.

Thank you all for your input, I'll get back to reading my manuals and see if I can find any more mysteries to solve.

12-28-2009, 03:42 PM
I checked mine too and it wasn't loaded either. You just have to follow the plugin loading instructions we gave. It's something you'll really need to know anyway.

12-29-2009, 06:40 AM
OK, understanding plug-ins is a good idea. I'll check in to it and see if there is a section in the Manual on them.
Thank you and Happy New Year!!

12-29-2009, 09:32 PM
OK, understanding plug-ins is a good idea. I'll check in to it and see if there is a section in the Manual on them.

You can find couple free Mac UB plug-ins on my website http://www.trueart.eu
to test adding 3rd party plug-ins.
Such as f.e. SaveSceneAndAllObjects(Increment).

12-30-2009, 06:55 AM
Thank you, Sensei for the link. I've loaded the plug-in and it looks like its going to be a useful tool!
Happy New Year to you and everybody!!

12-31-2009, 03:39 AM
strange, no teapot in 64 windows, but in teh 32bit version, its there..

my other half laugths at me as i only play with cubes and spheres, says i should use something else... so i showed her the teapot...


12-31-2009, 03:47 AM
Maybe it is 3rd party plug-in and NewTek doesn't have source code to recompile to other systems than original 32 bit executable.