PDA

View Full Version : Help me please



neilp
11-18-2009, 09:29 AM
:help:Guru's
I have a problem using FPrime and wondered if anyone knows a quick fix.
Im rendering glass in a building that reflects trees, the trees are single polys mapped with jpegs in the colour chanel and transparency chanel. The trees that I see in the foreground render perfectly with their transparent backgrounds however the reflected trees in the glass have white backgrounds - Any ideas?

stevecullum
11-18-2009, 10:44 AM
Instead of using transparency use clip maps - it will render quicker and should eliminate the dodgy reflections. :)

neilp
11-18-2009, 10:48 AM
Clip maps - never used them before, can you briefly explain how please

stevecullum
11-18-2009, 10:55 AM
Sure..

Select the tree plane object and hit p to bring up the properties box. On the render tab you will see an option to use clip maps. Then use a black and white map to clip away the geometry at render time. White means clip all - Black is no clip.

neilp
11-18-2009, 11:02 AM
Thanks steve
Is this technique possible with two crossed polys for the tree to give it more dimension. If it is how would I do that? Once you have the clip set up do you then remove transparency?

stevecullum
11-18-2009, 11:26 AM
In modeler, create your plane and create a UV map for it. Then duplicate and rotate into the cross position. Now if you apply the maps to the UV you created, it will stick to both planes. Yes delete the transparency maps after you have set things up.

toby
11-18-2009, 03:34 PM
The trees that I see in the foreground render perfectly with their transparent backgrounds however the reflected trees in the glass have white backgrounds - Any ideas?
Sounds like the ray recursion is too low.