PDA

View Full Version : particles still visible in scene after their "death"



Johnny
11-10-2009, 11:21 PM
I have a scene which uses particles, which are still visible long after emitter stops emitting and long after their +/ life time has expired.

The render times are killing me. The typical render time for most of the frames with particles is 5 minutes. Some of the frames with particles are 16 hours!

Shutting off hypervoxels remedies the render time problem, but I'm not getting truthful information: my particles' property settings say they should all be dead and gone by frame 60, yet I still see them at frame 150 in test renders!!

So, if I shut off the hypervoxels for those emitters, I'll see a sudden disappearance of particles that won't look right.

It has been brutal developing this scene. Testing has taken days because of mystery astronomical render times and need to troubleshoot their cause.

I could really use some help making these particles behave themselves, and to obey the values I've typed into their properties settings.

Thank you,

J

WCameron
11-11-2009, 06:59 AM
Have you done any tweeking to the Particles then forgot to recalculate maybe?

Worse comes to worse, you can manually Delete specific particles at specific frames using the EDIT tab on the Particle Emitter. Just click on the particle you want gone and push the Delete button.

- Will.

Johnny
11-11-2009, 08:03 AM
Have you done any tweeking to the Particles then forgot to recalculate maybe?

Worse comes to worse, you can manually Delete specific particles at specific frames using the EDIT tab on the Particle Emitter. Just click on the particle you want gone and push the Delete button.

- Will.


how would I recalculate particles?

Is this some button you click to make sure particle behavior is updated to reflect changes you make in emitter property settings?

J

shrox
11-11-2009, 08:33 AM
how would I recalculate particles?

Is this some button you click to make sure particle behavior is updated to reflect changes you make in emitter property settings?

J

The "Calculate" button on the right side of the object properties window under the "Dynamics" tab.

Johnny
11-11-2009, 10:04 AM
The "Calculate" button on the right side of the object properties window under the "Dynamics" tab.


yep...there it is.

Many thanks to you and to WCameron!!!

Do I have to recalculate for *every* emitter in the scene, or does it recalculate any/all particles in the scene?

and, provided I don't change the particles, will any scene I make by Save As also have it's particles recalculated, or do I do this every time before hitting F10?

J

Johnny
11-11-2009, 06:23 PM
I probably answered my own questions...have LW blasting away calculating particle information right now...4 emitters, 480 frames...lotsa chair time.


again, thanks for information about this!

J

Johnny
11-12-2009, 11:05 AM
OK...after a day of non stop processing, this procedure is failing.

It initiates just fine, but either aborts or gets stuck in beachball land more often than it completes the calcs.

To me, it seems that my scene has vastly exceeded Lightwave's ability to manage it.

I have 6GB of RAM, so I don't believe it's a resource issue.

Any thoughts?

I'm leaning toward dumbing down the scene to one without particles, but I'm wide open to suggestions.

particles seem to be *VERY* expensive in terms of CPU time.

thank you for any help and input.

J

shrox
11-12-2009, 02:38 PM
OK...after a day of non stop processing, this procedure is failing.

It initiates just fine, but either aborts or gets stuck in beachball land more often than it completes the calcs.

To me, it seems that my scene has vastly exceeded Lightwave's ability to manage it.

I have 6GB of RAM, so I don't believe it's a resource issue.

Any thoughts?

I'm leaning toward dumbing down the scene to one without particles, but I'm wide open to suggestions.

particles seem to be *VERY* expensive in terms of CPU time.

thank you for any help and input.

J

What is your segment memory limit set to?

shrox
11-12-2009, 02:41 PM
I probably answered my own questions...have LW blasting away calculating particle information right now...4 emitters, 480 frames...lotsa chair time.


again, thanks for information about this!

J

I have a scene with 5 emitters with about 30,000 particles each and 480 frames. It will even run in preview.

Johnny
11-12-2009, 03:23 PM
what is your segment memory limit set to?

1024mb.

J

Johnny
11-12-2009, 03:25 PM
I have a scene with 5 emitters with about 30,000 particles each and 480 frames. It will even run in preview.

You're running it on PC?

J

shrox
11-12-2009, 03:35 PM
You're running it on PC?

J

Yes, this test right here. There is a hiccup in the HVs, it is just test.

http://www.newtek.com/forums/attachment.php?attachmentid=79153&d=1257882071

Johnny
11-12-2009, 03:39 PM
Yes, this test right here. There is a hiccup in the HVs, it is just test.

http://www.newtek.com/forums/attachment.php?attachmentid=79153&d=1257882071

ahh....well, I'm on mac OSX...wonder if that explains the issue.

WCameron
11-12-2009, 11:02 PM
How complicated is your scene? more than one emitter? if its borking on the emitter calculations, and there are more than one, bake the Calc to a PFX file one emitter at a time, clear the scene, load in the original and reapply the pfx files to each emitter. that way the calculations are cached to a file.

- Will.

Johnny
11-13-2009, 04:53 PM
How complicated is your scene? more than one emitter? if its borking on the emitter calculations, and there are more than one, bake the Calc to a PFX file one emitter at a time, clear the scene, load in the original and reapply the pfx files to each emitter. that way the calculations are cached to a file.

- Will.


this partic scene, I have 4 or 5 emitters.

I don't believe it's complicated...

thank you for that suggestion I have another particles scene which could benefit.

J

Mr Rid
11-13-2009, 07:25 PM
I have a scene which uses particles, which are still visible long after emitter stops emitting and long after their +/– life time has expired.

The render times are killing me. The typical render time for most of the frames with particles is 5 minutes. Some of the frames with particles are 16 hours!

Shutting off hypervoxels remedies the render time problem, but I'm not getting truthful information: my particles' property settings say they should all be dead and gone by frame 60, yet I still see them at frame 150 in test renders!!

So, if I shut off the hypervoxels for those emitters, I'll see a sudden disappearance of particles that won't look right.

It has been brutal developing this scene. Testing has taken days because of mystery astronomical render times and need to troubleshoot their cause.

I could really use some help making these particles behave themselves, and to obey the values I've typed into their properties settings.

Thank you,

J

Um, this does not make sense. Particles do not remain in a scene beyond their life time frame value. Particles born on frame 0 with a lifetime if '10' will all disappear by frame 11. If the '+/-' is '5' then the particles will die between frames 5 and 15. But now your emitter may continue to emit new particles until it reaches the particle limit. Lower the particle limit, or envelope the birth rate to stop new particle births by a particular frame.

Voxel render time depends on variables like the amount of particles, the type, size, render Q, shadow Q, texture shadows, thickness, opacity, stretch, number of lights, number of slices.