PDA

View Full Version : Encountering visible seams between polys with colinear edges.



Beerbaron
10-20-2009, 01:52 AM
http://img12.imageshack.us/img12/3418/seams.jpg

I am modeling an old west gunbelt, and I am running into the problem visible in the linked image. When I modeled it, the edges of the polys didn't line up, but I went and merged the points at each end of the two poly's edges, so the edges should be colinear, no? The seam shows up both in the Open GL preview and the render. What am I doing wrong here? Thanks.

OFF
10-20-2009, 02:34 AM
what texture mapping method you use?

Beerbaron
10-20-2009, 02:45 AM
what texture mapping method you use?

This is a procedural texture (inverted crumple and veins) that applies to all the leather.

Deadlyforce
10-20-2009, 08:29 AM
Did you check for 2 point polys ?

Amurrell
10-20-2009, 10:21 AM
You could try to UV map your model for better control of textures, but I think there is a problem with the mesh construction in some way. I'm not sure, but the procedural texture may be following point order form begining to end and overlapping where you welded the points together, thus causing a seam. I could be just blowing it out my a** though. For an experiment, you could always turn the objects so the seams face away from the camera re-render to confirm this problem.

That's all I have without more information.

cagey5
10-20-2009, 12:24 PM
Did you check for 2 point polys ?

:i_agree:

Amurrell
10-20-2009, 01:41 PM
Or the 2 point poly thing...:)