PDA

View Full Version : Motion Blur warp anomally



Larry_g1s
10-10-2009, 06:01 PM
I'm getting this crazy warp look when I have motion blur applied in a particular scene. What's strange is that I can have the MB down to like 5% and it does a slight blur on the character but also this huge warp. If I take MB off, the character renders fine but obviously with no MB. These are done from fPrime, but Kray also renders them out like that. This character is animated in Maya and brought in through Point Oven. I've had this same pipeline with other scenes and haven't had this issue though. Any ideas?

SplineGod
10-10-2009, 06:44 PM
Just for fun have you tried the classic camera with standard motion blur?

Jarno
10-10-2009, 07:12 PM
Have you looked at how the character behaves in Layout when scrolling through fractional frames? It looks like it isn't interpolating between keyframes in the way you are expecting. It could be a motion plugin not behaving correctly when evaluated at a fractional frame, or possibly a wraparound in rotation values (e.g. interpolating between a heading of +180 degrees and -180 degrees causes a big movement, even though both represent the same orientation; particularly nasty in some converted motion capture data).

---JvdL---

Larry_g1s
10-10-2009, 07:48 PM
Hey thanks guys. I'll try the classic cam later tonight. As for the fractional level I'm not sure. Like I said, I've just imported it via Point Oven like other animatios before. I'll take a look at it.

SplineGod
10-10-2009, 07:57 PM
Also what are you using to playback the mdd file?
I like Dponts mddpoint node because you can use an envelope to control the playback speed etc.

Larry_g1s
10-10-2009, 09:29 PM
Also what are you using to playback the mdd file?
I like Dponts mddpoint node because you can use an envelope to control the playback speed etc.I'm using the Point Oven reader. If the classic cam with it's blur doesn't work, I'll see if tha DP mddpoint node will read what Point Oven produces.

Larry_g1s
10-10-2009, 11:28 PM
UPDATE: I'm still getting the same warp with the Classic Camera and it's MB.

SplineGod
10-10-2009, 11:47 PM
I use mdd files quite a bit but never had that issue with MB,
Id try using the mdd files using Dponts plugin or one of LWs other mdd playback plutins.

Larry_g1s
10-16-2009, 10:08 AM
Quick little update, it obviously has nothing to do with the render engine as you can see from just these screen captures with Layout set to show MB. It's very strange because I just rendered out an animation of a character from Maya imported to LW through Point Oven, with very broad cartoony animation and the MB is fine. Very strange. I'm going to check my settings from Point Oven and if that doesn't work I'll try the DP mdd reader as suggested.