PDA

View Full Version : listing out all uvmaps in my .lwo



dsdsdsdsd
10-05-2009, 07:50 AM
hello;

is there a way to list out all uvmaps that are being used within my .lwo file;

I have a collada export that suggests that one particular model has a uvmap assigned to it that it should not;

thanks,
Shannon

dee
10-05-2009, 07:57 AM
In modeler go to Windows -> Vertex Maps Panel or press F8.

dsdsdsdsd
10-05-2009, 09:13 AM
dee, thanks for your response; I found the dialog box;


do you know if there is a way to see uvmap assignments; in other words if I have a uvmap called uvm_tire, I would like to see if uvm_tire is assigned to any models other than my_tire, such as my_steering_wheel;


when I review my_steering_wheel_surface in the surface editor, there appears to NOT be any associations with uvm_tire; but when I export to collada, collada is identifying a relationship;

thanks for your time,
Shannon

dee
10-05-2009, 09:38 AM
Set a modeler window to UV Texture. Now select your map and it will show the assigned polygons in this window.

dsdsdsdsd
10-05-2009, 09:53 AM
dee, thanks;

I have the UV Texture option chosen, and indeed it shows me the uvmap's polys;

but I guess what I am trying to find out is if uvmap_A is assigned to model_X, or more accurately, if it is assigned to surface_X;

when I export to collada ( which is really just an xml file ) I expect to see that the only reference to uvmap_A is found in the section regarding model_A;

but lo and behold I also find a reference to uvmap_A is found in the section regarding model_X;



I suppose my next option is too create a new .lwo and simply rebuild it; though I would rather figure out where LW is getting its uvmap assignments from;


I will keep looking - if I find something I will report it here;


thanks,
Shannon

dee
10-05-2009, 10:07 AM
Ok, select the polygons of "uvmap_A" in the UV Texture window. Set selection mode to Polygons, open Polygon Statistics (w), go to the Surf dropdown an select your surfaces one after another. If the surface to wich the selected polygons belong is reached, the row "Surf:" should become white.

Hope you understand what I mean, my English is not so good.

dsdsdsdsd
10-05-2009, 10:33 AM
dee, interesting - I didn't know that you could do that;

according to this there are not any erroneous associations - everything is as it should be;

apparently collada export is doing something strange;

I appreciate your time,
Shannon

dee
10-05-2009, 10:39 AM
Maybe a bug. Please make an bug report with content so it hopefully get fixed in the next release.

http://www.newtek.com/forums/showthread.php?t=73226

dsdsdsdsd
10-05-2009, 11:18 AM
I think probably before I do that I will rebuild my .lwo and see if I still get the strange collada;


thanks for your time;