PDA

View Full Version : PSD Export plugin?



bjornkn
09-28-2009, 07:56 AM
I'm having big problems here getting the PSD Buffer export plugin to work correctly. I set it to export a layered composite + final render because I want to blur the reflection channel (renders so slow).
When I render at small size (25%) it loads just fine into PS. But when I render at full res (2500x3500px) PS refuses to read thelayers. It just tells me that it has problems reading layer data, and if I want to load the composite instead, which is not what I want!
This is so frsutrating, and it wastes so much time!
The PSD file is 86MB, so it definitely have some layers saved in it.
Any tips on how to make this work?

Bytehawk
09-28-2009, 10:50 AM
have you tried reading the file in xnview and checking the layers there?

bjornkn
09-28-2009, 11:32 AM
Thanks for the tip. I have XNview installed, but didn't know that it had any PSD/layers support.
It says that the PSD file contains multiple pages, and when viewing each page there are only 2 different ones, one of them the final render.
When opening the small PSD version (which PS could open) it shows all the different layers correctly, like reflection, specular etc.
Apparently it is a bug in the PSD exporter in LW when exporting large files?

archijam
09-28-2009, 02:39 PM
Try GIMP too.


Does limited region work with the exporter? Might be an option for now if you are in a squeeze ..

bjornkn
09-28-2009, 03:36 PM
It loads into PS with limited region no borders, but it is not correct. It only imports with 8 layers, only the purple/violet ones, and it is not at all looking like the result I get with a similar image rendered with a 25% mutiplier. XNview reports 9 "pages".
When rendering with limited region borders it still outputs the region without borders (another bug!).
I finished the project by rendering with reflection blur directly, using a nodes trick from lightwiki. After all it took less time than fighting the PSD exporter ;-(

Steph
09-29-2009, 12:46 AM
Hello

I have had the same problem from time to time (on the Mac) . It appears that when I running low on memory, the PSD Exporter seem to writing a wrong psd file and althought the file has a big size (so I could thing it contains layers) I can't open it in Photoshop.
So before I recompute the image in layout, I try to shutdown all applications that consume memory and I can manage the PSD exporter to work correctly.
I try too to make the Segment Memory Limit (Render Global Panel) as low as possible (you could try something like 32 or 16Mo or 8Mo), the image will be longer to render but it consume less memory.

Apologie for my bad english and hope it could help

bjornkn
09-29-2009, 01:13 AM
It's good to know that I'm not alone experiencing these problems ;)
I'll keep your tips in mind.
I usually have the segment memory limit at 64, but right now I'm trying to rerender with 16MB.

bjornkn
09-29-2009, 03:37 AM
After test rendering with 16, 128, and 8MB segments I have still not been able to get a working PSD layered file :(
The rendering speed was about the same, but with 8MB Layout crashed right after saving the PSD!

archijam
09-29-2009, 06:53 AM
Bug reported?

JeffrySG
09-29-2009, 08:35 AM
Have you tried rendering the scene at 25% to see if it works? If it does work at a smaller size it might be a memory issue or a file size issue. Also, are you rendering at 16bit / channel or 8bit?

I've rendered some large files (MB wise) with out any problems, but the images were not too large pixel dimension (around 2000px wide or so). I usually render 16bit / channel and the files usually end up being a few hundred MB for each image.

bjornkn
09-29-2009, 09:49 AM
It renders fine at 25%, and I'm rendering at only 8 bits. The full size is 2500x3500px, but even when I skip all extra channels but the layered composite and final render it cannot make an understandable PSD file. There are no memory problems rendering it, it just doesn't put the layers where they should be if the res is too high. The files are less than 70MB.
What is strange is that it renders the PSD file, but it scrambles it somehow, so that PS is unable to open it as layers, which is the whole point by using it, but only opens it as a composite.