View Full Version : LW Crash after Snow Leopard Upgrade

09-17-2009, 12:06 AM
okay, here is the thing. I have read that there are some bugs that need to be fixed, but so far everyone was able to launch the applications before the bugs strike. I am not that lucky, I get the spinning beach ball straight at the beginning before LW loads the Grid-interface. Both applications and hub are not responding :-(
Interestingly, discovery mode (without the dongle) seem to be okay, although I can't test all functions, but at least it opens. Just to be sure, does anyone have a similar prob? Any fix advice?

09-17-2009, 06:41 AM
(Just assuming, as it is hard to tell without knowing anything about an individual installation ...)
Seems you're the first with such heavy issues (at least among the Forum users) and it seems it's an issue with USB or the dongle drivers.
You could try to plug the dongle into another USB port (preferably directly on the Computer or at the keyboard) unplugging all other USB devices first.
Also repairing permissions could help, maybe resetting PRAM.
If your Mac is working without any further issues and it's exclusively LW which gives you problems, I would just reinstall the LW application bundle and - assuming you use 9.6 - follow the installation guide ( http://www.newtek.com/forums/showthread.php?t=94245).

09-17-2009, 08:13 AM
Thanks for the tip. LW9.6 was working fine on my machine until the Snow Leopard upgrade. First, my dongle was on a USB hub, then changed that to direct USB interface on my MacBook Pro, however, same result --> no launch. In fact it manages to launch the HUB but then crashes. It is definitely not the permission or any .plist, as I have done all of that. If nothing else works, I will consider the re-install. Is there any way to test if the dongle is okay?

09-17-2009, 10:38 AM
It shows up in System Profiler when it is connected, but I don't know of a serious testing routine. SafeNet offers driver downloads, but this possibly could lead to other conflicts, as the Dongle drivers are now inside the Modeler and Layout application packages and not installed system wide.
Another try: rename hub.app, so that LW starts without the hub, just to see if maybe the hub is causing the troubles.

09-17-2009, 09:04 PM
Thanks for your help, but it seems not to be the HUB. It hangs itself with and without the HUB. The USB dongle appears in System Profiler from SafeNet, but as you mentioned it is not conclusive. I will uninstall LW9.6 and re-install it. I'll do a re-install through the download from Newtek Site and entering my serial number. I hope this goes smoothly. Cheers.

09-18-2009, 03:40 AM
Probably the best choice, good luck!

09-21-2009, 06:37 AM
Just wanted to inform that I have installed LW, and re-installed it again. It works in discovery mode, i.e. application does launch (without the hub) then I successfully register my s/n. So after restarting the application again, same old problem :(

09-21-2009, 08:39 AM
Ack sorry to hear your news..

What mac are you using? Video card?

Did you do the Control-Option-P-R at boot?
(This may help clear any OpenGL/Graphical issues)

Did you make a 'preferences' folder in the lightwave app folder? (This will insure your lightwave isn't using any other preferences/license files on your mac) Just make sure to put a license file in here.

09-21-2009, 09:50 AM
that's sad news to read.
seems to lead to a licence issue - did you have several copies of LW previously installed?
Usually LW should state that it did not find a license, but I remember having booted into Discovery Mode without any warnings (although closing and restarting LW did fix it for me).
The Installation Guide I mentioned earlier describes where LW now puts the license and preference files (as I remember, the guide also shows how to use different copies without having one version's preferences affect another version).
The discovery version doesn't boot the hub (it's a "demo limitation"), so this would be "normal" when LW does not find a proper license and boots into "discovery mode".
(And just to be safe: with s/n you surely mean the unlock key 'xxxx-xxxx-xxxx-xxxx' for registration, not the serial number?)

09-21-2009, 06:32 PM
okay, let me answer one point after the other:

I am running a MacBookPro 2.6 GHz Intel Core 2 Duo with GeForce 8600M GT 512MB
I did have LW 8.5 in the past, which I have un-installed by trash app folders as well as preferences and app-support files in the root/user library. When I installed LW 9 it all work well. Then I un-installed LW 9 and downloaded LW9.6 and installed it, and it worked fine. Then I installed Snow Leopard, and here I am ...
I did reset the PRAM and also placed the dongle in different USB ports on my MBP, just in case ... but no luck here.
Yes, sorry, I meant with the S/N the key lock xxxx-xxxx-xxxx-xxxx. In discovery mode of LW where you activate the key, it seems that it accept it, and it kindly asked me to restart my LW. But then I'll get the spinning beach ball :(
Just an additional point I realised, when starting LW, it does open the Hub but get stuck, in fact the little dot underneath your app icon in the dock is still blinking. The Hub icon is there with no blinking dot. Force-quitting lightwave also forces me to force-quit the hub too.
Apart from the LW96 folder in the applications folder, I have
user/library/Application Support/Lightwave 3D/Presets,Plugins,Extension Cache
Okay, I don't have a preferences folder in the app folder. I will do that now and report shortly ... [2 minutes later] ... I will rename the ~user/preferences/LW folder under my user account for the time being. -->no luck, same issue. But LW wrote kindly my preferences now within the newly created preference folder in the LW Applications folder. So it does do that.
Another thing I realised is that the licence key has the extension .key which automatically defaults to my Keynote (iWork) application. I change that to TextEdit to test out, but also no luck. Is there any specific app should I relate the licence key to?

Well, I am running out of ideas slowly, any other?


09-21-2009, 07:03 PM
8.Don't bother relating the license file to any app. Just make sure it's plain text only, and not fancy text. If you open TextEdit, open your license file, up top in the menu find or make sure it's set to 'plain text'. Then save it as license.key It may ask you, "are you sure you want to use .key instead of .txt, then say yes. That's all there is to that.

7. You can basically ignore all folders in the /user/ area now that you made the preference file in your Lightwave directory. All your preference file will be put in there now. Make sure your license file is in here though.

Good luck getting it fixed.

09-22-2009, 08:16 AM
so LW starts in Discovery Mode with and without the dongle?
Maybe the Licensing process fails due to an incompability with SL, so you could create your license file manually in Simple Text by opening a new document, entering just the unlock code xxxx-xxxx-xxxx-xxxx and save as plain text file named license.txt, then swap the .txt suffix to .key in Finder and place it into the appropriate folder.

~/Library/Preferences/Lightwave 3D/license.key is the default path for the license file.

Other ideas would be firewall or anti-virus settings that interfere with the communication between hub and layout/modeler, but standard settings of OSX firewall work without issues and not many Mac users have anti-virus protection installed, so I guess this leads to nirwana too.

Installed 10.6.1 myself last weekend and luckily had no issues, only ftp client cyberduck didn't start due to an incompatibility, but LW and all other software doesn't show any issue. (It was the first time I did just an update, normally I do a clean install).

If everything fails, I would consider a clean install of Snow Leopard and all applications after reformatting and erasing the harddrive. As your system is able to run both SL and LW everything should be fine then. But it's the hardest way, I guess.

09-23-2009, 02:44 PM
hi again and just another weak try:
(assuming you're booting SL default with 32-bit kernel)
verify that Hub, Modeler and Layout are each set to "boot into 32-bit mode": yes; "use rosetta": no; "protected": no in applications Info window (cmd-i)

09-28-2009, 12:27 AM
okay this is a thought worth considering. I may have led myself to the wrong path. In fact, I did not use LW BEFORE installing Rosetta AND SL. It may work without Rosetta. I had to install Rosetta to get my MS Office working and other apps. Then I went down in my application folder to test all apps, incl. LW which then failed to launch. Could it be Rosetta? Though not sure yet how to disable it (I will research how now), but this is worth a try. Thanks for the tip, I will report on the outcome.

09-28-2009, 12:47 AM
Okay this was easy to test. All apps don't work with or without Rosetta checked. Tested with CMD-I checked and unchecked, in both cases, same result. Spinning beach ball of the app that launches the Hub but not itself :-(
Realised that I didn't answer this question:
so LW starts in Discovery Mode with and without the dongle?
The answer is no. LW starts in discovery mode WITHOUT the dongle, but crashes WITH the dongle. With the dongle it launches the Hub then enter into the spinning beach ball of the app.

I also check the plain text option of my licence number, so this is okay. I wonder if thread of Chuck
has something to do with this? I do have a Rainbow Duo purple dongle!

09-28-2009, 01:19 PM
The dongle issues arise with the upcoming cocoa LW 9.6.1 (64-bit); afaik LW 9.6 isn't affected by these issues.

With the dongle it launches the Hub...
For some reasons it seems to me that LW does not find (a) the dongle or (b) the license file or that (c) the license contains an incorrect unlock key.
But sadly I have to confess that I'm running out of ideas too. :(

09-29-2009, 09:15 PM
I'm glad to catch this thread.

I'm having the same issue, but with me my Lightwave works fine when I have a wifi connection. Without wifi, or just ethernet, Lightwave will not start.

Well, here are a few more clues about the Snow Leopard upgrade.......

10-01-2009, 06:34 AM
that's strange, as I don't have any issues since the SL upgrade and I have deactivated any wi-fi and bluetooth connections, I am using only cable bound ethernet.
But it can be machine dependant, I'm not using a MacBook Pro, I'm on MacPro with Sentinel Dongle.
It could be related to the network settings, as I remember having read in another thread a while ago that the hub is using some network tech to allow interaction between Modeler and Layout (hence my idea with firewall/anti-virus).

10-05-2009, 04:17 AM
I thought I'd drop a line to inform that Newtek has sent me a new Dongle for my crash issue. I will receive it out in the next days and report on the progress. Thanks to everyone who tried to help.

10-06-2009, 11:57 PM
Okay, I have done a lot and now I am out of ideas. My last resort is to un-install Snow Leopard.
After throwing away all preferences
After repairing all permissions
After un-installing and re-installing LW
After ordering a new dongle and testing it
After trying to use it with and without Rosetta and in 32bit ticked and un-ticked
... now I am at the end of my efforts.
Unless, someone has another tip for me, I am un-installing Snow Leopard.

10-07-2009, 04:13 AM
You're really gone through the ultimate software nightmare.
Sadly, no new ideas from me.
If you are considering to do a complete and fresh re-install of OSX on a wiped hdd, I would suggest one last try with a SL install. You could then install LW to check if it works - if it still does not, you could re-install 10.5 (having lost only about 2 hrs).
Good luck and best wishes!

10-07-2009, 02:58 PM
just encountered a non-starting app (crash on startup), identified wrong permissions for an additional library as reason (I'm using a two user accounts setup on all my Macs: one admin for installation/administration and one standard user for normal working and a group containing admin and user to unify certain tasks, app was working from the admin but failed from the standard user).
So changing permissions to rw for my group solved it.

You had repaired permissions, but did you check if - for some reason - the SL update screwed up LW permissions for your user account (should be at least 'read' for LW folder, Hub, Layout, Modeler and SharedSupport folder). Permissions problems are sometimes caused by Apples migration manager, didn't use it while upgrading, but maybe you were? And 1 needed file with wrong permissions is sufficient to prevent an app from starting.

10-08-2009, 04:23 PM
Thanks for that tip. I do also have a test account that I do use for testing some crashes and in fact, I tried this also but did not work either.
However, what I did not try is your suggestions with the permissions. I did a SL upgrade over Leopard. I did repair permissions in general, where I have only a couple of irrelevant SUID alerts, but nothing relating to LW. Now you suggested to individually check this for LW. I must admit I do not know how to do that. Terminal UNIX commands?

10-08-2009, 04:35 PM
With respect to the Get Info on Folders, my admin account, which I use mainly for LW, has read/write permissions and privileges. My test account has only read privileges.

I am assuming that as LW is working on SL for some, it must be something very specific to either my setup, computer or installation. The latter one I will target soon, I may need to make a clean installation for SL and re-install everything from scratch, however, I am reluctant to do so, as I am in the middle of other projects and want to minimise more potential problems. Maybe I should have thought about this before installing SL. Anyway, we never stop learning. I am now hoping that NewTek-TechSupport :newtek: has the 'secret'. Initially, no direct answer, now I have to call!

Fingers crossed!

10-09-2009, 04:57 AM
Terminal UNIX commands?
well, basically yes. You can use 'ls -l' command for the Lightwave Application folder and the content to see the privileges for owner, group and other.
A short info about that could be found in the Westwind reference (http://www.westwind.com/reference/) or other UNIX sites.

...it must be something very specific...
I agree completely, if you want to try further you could have a look at the X-lab FAQ
http://www.thexlab.com/faqs/faqs.html to get some more ideas about why this could have happen and also to get good tips about a clean install if that is your last resort.

Hope you get it all sorted, good luck!

10-12-2009, 03:40 AM
Okay, here is my terminal output:

drwxr-xr-x Hub.app
drwxr-xr-x Layout.app
drwxr-xr-x Modeler.app
drwx---r-x Plugins
drwxr-xr-x Preferences

so all seems to be correct. Thanks rsfd for the tip, I'll check the xlab site. My clean install to everything is scheduled soon.


10-13-2009, 09:51 AM
I've reinstalled SL and LW and didn't use the migration assistent and everything works fine.

Still don't know why it worked when I was connected via the wifi and not eithernet on my previous install.

10-17-2009, 09:02 AM
@mona tony
nice to read you're "up and running" :thumbsup:

10-18-2009, 05:15 AM
I thought I drop this email just in case anyone (like me) had a similar issue. The issue has been finally resolved without me doing a re-install of Snow Leopard. This is what I had to go through:

First, I had to exchange the old dongle (Purple) with a new SafeNet one. Secondly, install the Sentinel drivers from SafeNet. Reboot, fix permissions and restart LW Layout. Then Quit (incl. the Hub) and restart Modeler. Then quit (incl. the Hub). Then restart finally and all was fine, including the switch between layout and Modeler (intra-app). Here you go!

I thought a drop a line of thanks here to all the help and also the NewTek team.

Cheers! :thumbsup: I am :D now

10-19-2009, 02:52 PM
seems, as if it was the missing Sentinel Driver, it should have worked with the Duo too.
sometimes, I think I can't see the forest for the trees!

nice to read you're "powered" again!

10-19-2009, 07:09 PM
I think the upgrade has done something to the purple Aladin dongle driver (though I can't remember that I have installed anything for it in the first place). But the communication between the dongle and LW wasn't correct. Somehow with the installed driver it did overcome the communication hurdle and fixed the issue. I will however to a clean install of SL in Xmas, and hopefully, you won't see me posting the same topic again. At least now we have more to probe with :)
Thanks again for the support.

10-20-2009, 04:32 AM
You're welcome, good luck for Xmas!

…hopefully, you won't see me posting the same topic again.
:eek: No, it's me posting something similar in the OB forum!

04-06-2010, 12:18 AM
I thought instead of starting a new thread, I continue this thread as the same issues are appearing again.
In short, I can start in discovery mode without my dongle (and without the hub), with my dongle attached and L-key in place, I get the spinning beach ball (sbb) straight after the hub launches. LW & Mod enter in the sbb at startup, where even the grid doesn't get loaded. I used to have my dongle on a USB hub and now I am worried that my USB hub (could) has(-ve) caused a problem. Is there a way to test that the dongle is ok?

04-06-2010, 05:00 AM
hi again,
have a look at SystemProfiler where the Dongle should show up in the USB section.
But this only tells you that the OSX sees the Dongle, it does not imply that LW sees it too.
Best choice: plug the Dongle directly into a Mac USB port (or to the keyboard hub) and see, if that helps.
I remember someone where I could nail his issues down to a Hub-attached Dongle (it wasn't working correctly as it didn't get enough power through the Hub: was easy to fix > just plugged in the power cord for the USB-hub making it an active one, that helped)

04-06-2010, 08:51 PM
Thanks again for responding ... yes, I plugged the dongle directly in but with no success. I am sure it has to be the dongle not speaking 'enough' to LW. The reason is if it does not detect the dongle it should open in discovery mode. But it does detect it - I think - but doesn't get Modeler or LW over the hood. This may also relate to a USB issue, where it is still stuck to USB bank ports. I have attached an image of my system profiler, I still can see 'hereditary' from my old USB bank, which by the way I have thrown away now, because it seems to be non-functioning properly and may even have caused this headache. Is there a way to reset the USB ports? any ideas?

PS: I have also attached the driver that I have installed. I hope that is the right one: SENTINEL SYSTEM DRIVER v1.2.3 MacOS (10.5.5) - Intel.


04-06-2010, 09:26 PM
Hi there,

I was looking at the console message and couldn't figure out what this means. I have also attached it here.

04-07-2010, 03:21 AM
from your System screenshots I see that SystProfiler calls your Dongle a Sentinel "SuperPro", you say you have installed Sentinel System Drivers, but SafeNet lists explicitely "SuperPro"-Drivers too (first line v.7.4)
On the other hand, I'm still wondering why you have to install drivers at all: LW Modeler and Layout 9.6 both contain all 3 driver frameworks inside the application package (right-click on application icon > open package > content > frameworks)
[OpenBeta is different: drivers are located in OpenBeta SharedSupport folder]

As for your 2nd screenshot: Not sure what it means too, but I don't think it has something to do with LW.
(when I start LW, I don't have any reportings from apple.coreservices, I only read messages from Hub and Layout/Modeler).
But I saw the Firewall entry: do you use specific firewall settings? This could be a hint (if you just use default "on" it shouldn't be an issue - it's working here without isssues)

04-07-2010, 05:32 PM
Thanks for that, I should have double-checked the driver SW. I quickly installed the SuperPro Driver and tried it out, but with no success. However, it may be worthwhile to try to uninstall the other driver first and maybe even cleaning the kernel cache and then re-installing the other driver. I do install the driver without the dongle plugged in. Is that okay? I have read that this is what I should do, now I am not quite certain about that either.

04-08-2010, 06:38 AM
I do install the driver without the dongle plugged in. Is that okay?.

yes, it's the best method to install drivers without having the hardware attached.
Some drivers require rebooting, most don't.

(I still wonder why you have to install dongle drivers anyway - they should be part of LW 9.x)

04-08-2010, 07:39 PM
Well, the only reason why I have installed the driver was because I have been advised by Newtek Tech support to do so. Now I have un-installed all drivers and tried to relaunch LW but with no success either. The dongle is now directly attached to my MacBook Pro and no drivers, LW boots and starts-up the Hub but then LW ends up in the beach ball crash.
Though I have almost given up and will re-install MacOSX from scratch next month after finishing some current projects, I really wonder what it can be :question: Thanks a lot for all the advice. Maybe I will wake up one day and say, YES, it is this! I am dreaming on now.