PDA

View Full Version : short hair with FiberFX, please help!! :)



milivoj_popovic
09-14-2009, 12:36 PM
hi there!

i'm trying to make short fibers (short hair) with Fiber FX and it seems impossible to do unless i make my head 100 times bigger then normal head size (which screws up my SSS setings coz now i have a head that's 100m meters in size :( ). I can put the Scale of fibers at 0.1% or 10%, i get the same big size fibers.
Is this just a bug in FiberFX or am i doing something wrong here? Any help would be great!! tnx in advance!!

jasonwestmas
09-14-2009, 03:15 PM
Please show settings in FFX. Also, if you are certain about your settings, you can try saving out your settings, deleting the fiber filter modifier and then applying a new one. Then load in your previous settings. FFX should work fine with real world sizes.

milivoj_popovic
09-15-2009, 01:23 AM
yea, should work fine, but it aint :)
i made a basic ball, 300mm in diamiter, like a awerage human head, and just activated it in FiberFX, left all the settings as they are, just changed the scale in order to get the short hair. Here are the results:
this is the basic setting, nothing changed, looks fine!

http://i18.photobucket.com/albums/b140/milivoj_popovic/fiber01.jpg

Scale now to 50%, still good :)

http://i18.photobucket.com/albums/b140/milivoj_popovic/fiber02.jpg

Scale to 10 %, expected a bigger difference now

http://i18.photobucket.com/albums/b140/milivoj_popovic/fiber03.jpg

Scale to 5%, now it really starts to fall apart (even though the openGL shows everything's fine)

http://i18.photobucket.com/albums/b140/milivoj_popovic/fiber04.jpg

Scale to 1% :(

http://i18.photobucket.com/albums/b140/milivoj_popovic/fiber05.jpg

jasonwestmas
09-15-2009, 07:39 AM
If you are referring to the lack of coverage. As scale decreases, you must increase your density. Hair always appears thicker when it is longer too. Plus, this is true of most fiber filters because the TIP of the fiber is thinner than the Base. So when you decrease the scale the thicker base of the hair disappears and you are stuck with the thinner tip part and the hair therefore appears thinner in overall coverage. OGL doesn't show this change in thickness very well. Try a max fiber density of 200-300. I have found that is necessary for short velvety hair.

milivoj_popovic
09-16-2009, 01:28 AM
tnx for your reply!
no, i'm not talking about the lack of coverage (although that was also bothering me, tnx for the advice on that one!), i'm talking about the size of the fibers.
as u can see on this image, there's not much difference between 10% and 1%. I could go as low as i like (0.1%), and the lenght would still be pritty much the same.

http://i18.photobucket.com/albums/b140/milivoj_popovic/kugle_bad.jpg

BUT! if i increase the size of the ball from 30cm to 12m, then!

http://i18.photobucket.com/albums/b140/milivoj_popovic/kugle_good.jpg

i get what i wanted, that is small fibers, even at 10%. Which, at normal size, even at 1% i can not. And that's my problem :( :)

I did solve it by increasing my head size and then incresing the settings in SSS to match that, but if i had more objects in the scene, more lights, more charachters and stuff like that, that would not bee so simple to do :( :)

jasonwestmas
09-16-2009, 07:21 AM
OK, I'll try to recreate this issue on my puter. I'll be back.

jasonwestmas
09-16-2009, 07:51 AM
I think I found the problem and I think it is a known issue already. If you turn up the fiber kink even in the slightest the fiber will not decrease in scale at lower percentages regardless of the scale% setting. Notice in the picts, the short hair has the same settings as the longer hair, except in the longer hair the Kink is at 25%. This is not a desirable behavior of course so if you want to use kink at all you may have to set it as low as 1% to get the desired length.

Also keep in mind that the "fiber width" setting has a lot to do with the thickness of the fibers.

milivoj_popovic
09-16-2009, 09:34 AM
yea, that did it!! tnx!!!!!:bowdown:

Kojoccio
09-18-2009, 10:21 AM
Now you have dynamic gravity 140 and hair curves inward. I make first gravity 0, and then increase it to suit me.