View Full Version : Can't Import .dae Collada files / LW Looking in Wrong Plugins Folder

09-11-2009, 02:44 PM
Hi All,

I've been bashing my head against this for the better part of a morning so I'm really hoping you can help me out.

I'm trying to open a .dae file. I'm running LW 9.6 CFM on PowerPC Macintosh. I understand that this version is capable of importing collada files, but every time I try I get this error message:

Cannot load external plug-in file <Macintosh HD:Applications:NewTek:LightWave 3D 9.3.1:Plugins:input-output:Conv3D.p>

I assume this means that the program is looking for the plugin in the plugins folder inside Ver.9.3.1. (I'm running LW 9.6 CFM) so I assume I need to go in to LW 9.6 CFM somewhere and tell it to go look in 9.6's own plugins folder but I don't know how to do that.

So far I've tried:
- going to the plugins window and having it scan the 9.6 plugins folder for new plugins, but then it says that zero plugins were added.

- going to the "Paths" window, but I don't see any 'Plugins' path to change

- going to Library/Preferences and opening up the "Lightwave Extensions 9 Prefs" document... but all the paths (well, in the document I guess they're called 'Modules') inside that document ARE pointing to the 9.6 plugins folder.

Does anybody have any ideas/suggestions/comments/questions/criticisms/concerns/witty remarks? Please?:)

09-11-2009, 02:48 PM
I am not a mac user, but sounds to me that you hadn't redirected the LW shortcuts so they use different config files.

Had a look on the manual on how to do that on a mac.


09-11-2009, 02:53 PM
I think it's because you had both versions installed and you've been trying them both without fully quitting in-between versions. You need to clear away your LightWave preferences and start again, or you might try a simple alt-f11 to open your Plugins window and point the scan directory at the right place. By the way, you do understand that you can still run the UB version on a PowerPC-based Mac?


09-11-2009, 03:15 PM
Hmmmm.... well I deleted the Prefs files, and it looks like that took care of the old error message.

Unfortunately my new error message is simply:

Object Loading Failed

Is 9.6CFM not able to load these files after all?

The file I'm trying to load originally came from a Sketchup file. I used Sketchup to export to a .kmz file, then renamed that to .zip, and finally opened that up to access the .dae file inside. I'd been reading that this worked for other people, did something change to prevent it?

And BeeVee, I'm embarassed to admit I didn't know my PowerPC could still run the UB. Would the UB run better on my machine? Thanks! :)

09-11-2009, 03:27 PM
For your machine it might not make much difference, but if you want to run the 64-bit Mac version that will soon be in Open Beta you will need to have the UB.


09-11-2009, 03:34 PM
Any more ideas about how to open the .dae file though?

09-11-2009, 03:47 PM
I'm afraid I don't. There are so many "flavours" of Collada it wouldn't surprise me if SketchUp used a flavour LightWave doesn't get. You should ask James Melsom - Archijam on the forum - since I know he uses SketchUp in his pipeline.


09-11-2009, 03:53 PM
How about importing the .dae file into Blender, then export a .lwo from there?

09-11-2009, 04:07 PM
Also, have a look at this: http://alexvaqp.googlepages.com/sketchupblender

09-11-2009, 04:55 PM
Lol! Right On! I actually found that link this morning. Thank you though!

I think I might have found my problem... I exported as "kmz" file from Sketchup when I should have specified "kmz 4.0"

Anywho it's at least kind of working right now, although I can't open Blender's LWO's textures without LW crashing. As long as I open the file without the textures though it's all good.

Thank you very much for your help, Everyone!!! :)