PDA

View Full Version : Weight Map Issues



Kyntas Romal
09-07-2009, 10:23 AM
Hey everyone. I'm an amature LW user and am currently working on a short to help develope my skills.

I've modeled a Rat for this short and am using weight maps, I'm probably using way too many and have a lot of bones (154 Bones, 111 Weight Maps).

The weightmaps that I'm using currently don't seem to be deforming properly. When I move the arm bone the entire chest cavity is taken along with it (I have made sure that the chest is not affected by the arm weightmap) but apparently I'm missing something. The problem area is in and around the left arm, I have having these kinds of problems all around the model.

Any help with this topic would be greatly appreciated. I have included a couple frames of the problem areas in these test renders.

Thanks again in advance for any help offered.

jasonwestmas
09-07-2009, 10:50 AM
You may have to use a different field weighting for all the bones. Test with the 128 inverse distance bone setting first. This stuff is under bone properties btw. You can turn off the field weighting for the bones by choosing "Use weightmap only" for each bone and just use weightmaps.

SplineGod
09-07-2009, 11:14 AM
I generally start by using no weight maps and see how the bones are deforming on their own. Use that as a starting point to determine if you need maybe some hold bones or just some simple weight maps. For example you can have one weight map for all 4 legs and one for the rest of t he body. All the leg bones can share one weight map and tje rest pf the bones share the other. In the end if you dont need any weight maps or only need very simple ones this will save you alot of time.

Kyntas Romal
09-07-2009, 03:09 PM
Cool thanks, got it working. Now I can get back to work on my project, it's deffinately a good way to learn the program. So much stuff to do and learn.