View Full Version : Cannot add plug-in

08-07-2009, 03:58 PM
I have problem
if im tries add plugin modeler displays me message

"Cannot load external plug-in file<..patch to the plugin..>

I have:
Win Xp SP3 (32Bit)
LW 9.6 (32Bit)
Procesor: AMD ATHLON XP 2000GHz
Chipset SIS on mainboard ECS K7s5a
Graphic Card Nvidia Geforce 7600 GT

now im cannot work on LW!!
Please hepl me! :help:

08-07-2009, 04:20 PM
It could be faulty/outdated code. It could be that it is not compatible with your Lightwave version. If you had a previous version installed, it could be that you just ran the old version so LW has locked up the old file and won't accept another in it's place. Lightwave also doesn't like to have two plugins with the same name installed, so make sure you uninstall the old version first. Lots of reasons... can you tell us what plugin it was?

08-08-2009, 12:55 AM
This is Upgrade from version 9.2
plug-in was oginal from upgrade version 9.6 from newtek ftp

08-08-2009, 03:31 PM
Could it be that you're trying to load the 64bit version instead of the 32

Mr Rid
08-08-2009, 06:10 PM
That error has also turned out to be an odd Windows dll thing for me when I could not get NextLimit plugins to install. I was instructed:

"If you canīt load the plugins in your lightwave is because you donīt have some necessary dll in your system to run the plugin. Basically the windows installer 3.1 is the cause of this. It is the same if you have windows 32 or 64 for it. In the case of the redestributables is necessary to install the version for your platform.

http://www.microsoft.com/downloads/details.aspx?familyid=90548130-4468-4BBC-9673-D6ACABD5D13B&displaylang=en ----- (redestributable 2005 64 bits)

http://www.microsoft.com/downloads/details.aspx?familyid=bd2a6171-e2d6-4230-b809-9a8d7548c1b6&displaylang=en ------ (redestributable 2008 64bits)

Install both."

Have no idea what these are but it fixed the problem.

08-10-2009, 10:29 AM
Thx, bat this not work to. Im have this same efect

Andrew March
08-10-2009, 11:37 AM
what plugin are you trying to add?

08-11-2009, 02:48 AM
now im trying add any plug-in from modeler folder.

Andrew March
08-12-2009, 11:16 AM
have you tried scanning the folder instead?

08-12-2009, 12:24 PM
I've only seen this in a few instances...

trying to add new plugins into an old version
bad plugins

I would take any plugin that's in the \Plugins\model\ folder and try to add it.
(sounds like your doing that).

If that doesn't work it's an indication that LW wasn't installed properly. I'd uninstall & reinstall LW. Don't copy any files around and maybe even delete old LW config files before starting it. These may be pointing to some errant directory. Then try to add one of the existing plugins from the \Plugins\model\ folder.

I've never had problems re-adding a plugin (but that may simply be me).

If these suggestions don't work, you need to contact NewTek support.
I bet they'll suggest some of the same things I have.

Good Luck! :thumbsup:

08-12-2009, 03:57 PM
im reinstall LW 9.6 - without changes, i can't add plug-in
LW 9.5 - without changes, i can't add plug-in
LW 9.3 - without changes, i can't add plug-in

I suspect one of microsoft updating

Andrew March
08-14-2009, 03:27 AM
Nope don't think so, did you delete all of the config files when you reinstalled Lightwave?

08-16-2009, 02:42 PM
Yes, im delete al config. im tried LW7,5 , this version earlier works in this commputer. Now i have this same problem