PDA

View Full Version : ik booster lag



keniarts
07-29-2009, 07:30 PM
Applied ik booster. Whenever I move a controller, 'direction' lines are drawn for every controller being moved in the chain, which causes a serious lag before anything moves. I searched every panel looking for a way to turn this action off. Couldn't find anything. Could it be a video card problem?

I simulated the problem in the attached jpg.

I'm a first time using ik booster user.

Could someone recommend a tutorial for ik booster?

Hardward:
Mac PowerBook G4
2 GB ram
1.67 ghz
ATI Mobility Radeon 9700

geo_n
07-29-2009, 08:21 PM
I think that's motion path in display opengl options.

SplineGod
07-29-2009, 08:44 PM
Those lines are showing the vectors or directions they will go.
The lag is generally caused by LW calculating deformatons.
Try turned the subpatch level down to 1 or 0 if need be.
Also reduce the bounding box threshold.

keniarts
07-29-2009, 11:42 PM
Thanks,

Reset subpatch level from 1 to 0. Reduced bounding box from 50000 to 5000. Deactivated 'Show Motion Paths'. Relaunched LW.

No change. Same lag.

Keni

SplineGod
07-29-2009, 11:46 PM
WHen you lowered the bounding box threshold do the bones show up on their own wh en y ou adjust them?
Also whats the size of t he character?

Scazzino
07-30-2009, 12:12 AM
I don't think that's the cause of the slowdown, but rather the result of it. I believe those lines appear when LW can't update the screen fast enough for IK Booster. Are you on the Mac or PC? I've seen serious slowdowns on the Mac...

SplineGod
07-30-2009, 02:29 AM
Ive also found that if the characters are built at a large scale that things can slow down. You can try adjusting the IK size in the IKBoost menu under Options.

keniarts
08-01-2009, 10:59 AM
Once again...

The character is 14,846 polys (quads). The ik size in the options is set to '1'. I have tried all the other sizes with no improvement.

When I lowered the bounding box threshold, the bones show for a moment when I left click on it, but remain visible when I adjust the bones.

I am on a Mac (OS 10.4.11). See first post for complete hw list.

The problem persists. Any other suggestions before I move on?

Thanks,

Keni

Costanel
08-02-2009, 09:57 AM
Another suggestion is reducing the calculation size in the IKBoost options. It's called Fxlk-size or something comparable(first option), by increasing this it often responds faster(although the editing steps are much larger).

Have you got multithreaded deformations turned on btw?

geo_n
08-03-2009, 04:03 AM
Try lowering the frame range timeline. 0-100 frames only.

keniarts
08-03-2009, 09:22 PM
The ik size option is set to 1. I couldn't locate a multithread deformations panel. However, my PowerBook has one processor, and the thread is set to 1 in the render panel.

The frame range is 0-60.

The problem remains. I'm not going to waste any more time with this. I'm going to build a new rig in a new character. I expect it to work properly. I'll post the results.

Thanks for all your tips. I've learned some new LW features from your advise.

SplineGod
08-03-2009, 09:47 PM
Heres a few things you can do which can help speed things up:
Turn off show motion paths
Turn off show keys in timeline
Lower subpatch levels
Lower the bounding box threshold
Close graph editor
Adjust fKIk size.
Minimize the dopetrack
Use standin characters
Use proxy scenes

keniarts
08-05-2009, 07:55 PM
I put a new rig in a new character. Same results...Lag and motion lines on all bones being adjusted, even though 'show motion paths' is turned off.

I've tried every suggestion.

Thanks everyone.

Keni