PDA

View Full Version : Sliders controls look weird



OlaHaldor
07-22-2009, 09:07 AM
I recently dug up the Vehicle Rigger again, and thought I'd give it a go and make a short animation.

I setup a car with slider control, and to my huge shock, I couldn't see the writing I used to see when I was on Windows Vista. The sliders window is there, but the text is gone. The sliders seem a bit blurred, as if they're anti aliased.

Neither did I get control over the sliders. I clicked, dragged, and tried about anything, but I couldn't control the sliders.


Anyone experienced that one before?

evenflcw
07-22-2009, 09:32 AM
Try adjusting the clip distance.

The buttons might look blurry, because they are images, and how much they are blurred depends on your video driver settings and LWs custom object rendering. The text however should not look blurred.

robert_Lavigne
07-22-2009, 10:47 AM
Hey, I had been working in the cfm version of Lightwave for along time and then today I decided to try and work in the UB version, probably the first time since 9.6 came out. I open up the character I had been rigging and when I first open it up all the sliders looked like the should, but as soon as I clicked on one, all the text disappeared. I tried to add a new slider , but the new slider had no text on it either. I also tried to re add the slider plugin but that did nothing either. However if I open up a blank scene in UB and set up a slider it works just fine, so it must be an incompatibility between UB and CFM. I came on here to make a thread to see if other were having this problem and then I saw that there already was one. Looks like a bit of a bug.

robert_Lavigne
07-22-2009, 10:57 AM
Hmmm very weird. I went back in again and now they are working fine. One thing you can maybe try at least to get the sliders to move is to lock off all the position rotation and scale channels, I'v always found that to help. As for the text I have no idea what thats about now.

OlaHaldor
07-22-2009, 03:29 PM
Would you mind telling me how the h.. I can alter the video driver options in OS X?!

evenflcw
07-22-2009, 05:16 PM
Sorry, didn't notice I wandered into the swamp that is LW Forum Mac section. Windows for me. So anything I say is probably meaningless to you.

Changing the clip distance (in LWLayout Display Option) didn't make any difference? Even at extreme values? On Windows you can see it start to go all distorted (with text disappearing), supposedly because the floating point precision isn't enough.

Anyways, if that don't work I don't think what you might need to change can be altered in any user-friendly GUI. (They don't run that deep. I shouldn't have used the word "setting"). On Windows, if LW openGL ain't behaving, easiest thing to do is to just try another driver, be it older, newer or from a different party. For me ATI regular aswell as laptop vendor driver has selection issues in Modeler (weird delayed redraw until next element selected). I figure older drivers are better for LWs not-so-up-to-date openGL.

Scazzino
07-22-2009, 10:34 PM
You don't normally need to mess with the video drivers on the Mac. They are typically part of Mac OS X, unless you have an after market video board, in which case your mileage may vary.

archijam
07-23-2009, 03:33 AM
Also, send a screenshot to Waldfridson, maybe he's come across your problem during the development/testing of VR.

Post it here too!

robert_Lavigne
07-23-2009, 09:25 AM
I went to grab a screen shot of the problem I was having to see if it compares with Olahaldor. But I can't seem to recreate it. Typical LW.

walfridson
07-23-2009, 04:42 PM
Glad you're picking it up again :D..

Same problem here, I need to disable opengl transparency for it to work

jwiede
07-23-2009, 06:13 PM
Please file a bug about it in FogBugz, there's an update to 9.6 underway as we speak. If the devs don't know bugs exist, they aren't really able to do much about them.

DrStrik9
07-25-2009, 11:34 PM
i just "graduated" from an ATI Radeon 2600 XT (I learned after buying it, that it is a "bottom of the barrel" video card) to an ATI Radeon 4870, which has eliminated all kinds of OGL errors, and works better in virtually all cases ...

:)