PDA

View Full Version : Problems Saving files...



plankton
07-21-2009, 07:52 AM
Hey Guys,

Just having constant issues when trying to save / resave files... it keeps coming up that the files are read only.. i have to go through a repetitive process just to save an updated file..

can anyone help me here.? ive trying changin a few settings, but its a continuing issue..

FutureTomorrow
07-21-2009, 09:12 AM
What version of OSX are you running mate?

FutureTomorrow
07-21-2009, 09:22 AM
Also, have you tried repairing the disk permissions with Disk Utility? I've had to do that before and this (http://songdogtech.net/2009/04/mac-q-and-a-file-permissions/) article covers some ground on the topic.

plankton
07-22-2009, 07:54 AM
im running OSX 10.5.7..

Am going to have a look at the tutorial you just linked.. will get back to you!

Cheers,

Sid.

plankton
07-22-2009, 08:31 AM
So run the disk utility and it keeps coming up with the same problems.. When i open a model or a scene, when i go to do a updated save, the error that pops up keeps trying to save it as 'Lightwave 3d 9.LWO' (Read Only) as the filename, even it it was previously saved as a different name file like rabbit.lwo ..

does this to be a in- lightwave problem or a mac osx problem?

ingo
07-22-2009, 09:51 AM
What happens when you save to a different path, for example the desktop. If that works change the permissions of your project folder.

plankton
07-22-2009, 03:54 PM
I have tried save into different paths, and the same thing keeps happening.

So, i'm just wondering whether i should try to re-install lightwave and see if that fixes the glitch..

toby
07-23-2009, 01:59 AM
This has cropped up a number of times over the years but I can't remember what the remedy is (sorry!).

So I searched the forums for "read-only" and got this one :

http://www.newtek.com/forums/showthread.php?t=73313&highlight=read-only

His solution
"Ok,..I found the problem. in LW 9.2 i used to write the price of the proyect at the end of the name's proyect in the folder proyect, and of course I wroted also the sing "€", and that's the problem, without the "€" or maybe any other extrange symbol, LW 9.3 doesn't found the path to Object or Scene."

You could try removing any characters and spaces from any of your folders/files. Otherwise keep searching "read-only"...

toby
07-23-2009, 02:37 AM
http://www.newtek.com/forums/showthread.php?t=56557&highlight=read-only


"If you remove the hub config file the problem will be solved. Yet this will not fix the hubs comunication prob. you will have to do this on every new start up."

or


"I had it re-installed, so problems seem gone now, but have to go through all plugins again...
well, at least it working now."

looks like there's no one answer. Disabling the hub was another :


"The read-only object error is harder to really classify or reproduce. It's very subtle, but quick to anger, and all I can say, as I said in my PM reply to you, is that it went away immediately (without reboot) on the system when I killed off the hub (via the -0 switch). Since then, I've had no inclination whatsoever to reenable the hub and Modeler has been behaving within expectations (given other known issues)."

Most of these threads cross into a modeler hang-on-launch problem, which is a pc-thing as far as I can tell, so try to keep track of what they're talking about (I found it pretty tough :P)

From '06 :

"Yeah, i feel your pain.... The single most annoying/frequent/random bug is the "unable to write. read-only file" thing that modeller does. It drives me INSANE!!! "

and another one :
http://www.newtek.com/forums/showthread.php?t=56237&highlight=read-only

Kuzey
07-23-2009, 07:33 AM
I usually save it under a new name and that works...or copy the object to a new blank object and save from there.

Kuzey

plankton
07-23-2009, 07:38 AM
thanks for all the help guys, i'll try get this figured out... i just dont understand why it was working fine for over a year, and then it just started doing this about a month ago?

will get to the bottom of it..